Modify

Opened 21 months ago

Closed 5 months ago

#18630 closed defect (duplicate)

NPE at MapillaryImageDisplay.paintImage

Reported by: mapping@… Owned by: taylor.smock
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: template_report update Cc:

Description

What steps will reproduce the problem?

unknown

What is the expected result?

plug-ins get updated

What happens instead?

a list of plug-ins that can 't be updated was shown, after clicking OK, JOSM crashed and bug report was shown

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-01-02 22:34:59 +0100 (Thu, 02 Jan 2020)
Revision:15628
Build-Date:2020-01-02 21:52:31
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15628 en_AU) Linux Ubuntu 18.04.3 LTS
Memory Usage: 847 MB / 1470 MB (199 MB allocated, but free)
Java version: 11.0.5+10-post-Ubuntu-0ubuntu1.118.04, Private Build, OpenJDK 64-Bit Server VM
Screen: :0.0 1366x768
Maximum Screen Size: 1366x768
Java package: openjdk-11-jre:amd64-11.0.5+10-0ubuntu1.1~18.04
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-20ubuntu0.1
libcommons-compress-java: libcommons-compress-java:all-1.18-1~18.04
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:-
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ DirectDownload (35248)
+ Mapillary (1.5.20)
+ OpenStreetCam (280)
+ apache-commons (35092)
+ apache-http (35092)
+ buildings_tools (35248)
+ conflation (0.6.4)
+ jna (35092)
+ jts (35122)
+ rex (53)
+ scripting (30796)
+ tageditor (35258)
+ terracer (35248)
+ turnlanes-tagging (283)
+ turnrestrictions (35248)
+ utilsplugin2 (35248)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Bus_lanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/BesideTheRoad_Speed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SlovakiaBicycleRoutes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Schools&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1
+ ${HOME}/Software/osm-nsw-address-import/src/elemstyles.mapcss

Last errors/warnings:
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0017/224801/favicon.ico'
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0017/224801/favicon.ico'
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0017/224801/favicon.ico'
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0017/224801/favicon.ico'
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0017/224801/favicon.ico'
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0017/224801/favicon.ico'
- W: Region [userProfile_BLOCK_v2]  Problem verifying disk.
- W: Region [userProfile_BLOCK_v2] Resetting cache
- E: Handled by bug report queue: java.lang.NullPointerException
- W: Warning - <html>JOSM could not find information about the following plug-ins:<ul><li>apache-commons</li><li>rex</li><li>conflation</li><li>tageditor</li><li>jts</li><li>Mapillary</li><li>DirectDownload</li><li>OpenStreetCam</li><li>scripting</li><li>turnlanes-tagging</li><li>utilsplugin2</li><li>buildings_tools</li><li>terracer</li><li>turnrestrictions</li><li>jna</li><li>apache-http</li></ul>The plug-ins are not going to be loaded.</html>


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.mapillary.gui.MapillaryImageDisplay.paintImage(MapillaryImageDisplay.java:511)
	at org.openstreetmap.josm.plugins.mapillary.gui.MapillaryImageDisplay.paintComponent(MapillaryImageDisplay.java:488)
	at java.desktop/javax.swing.JComponent.paint(JComponent.java:1074)
	at java.desktop/javax.swing.JComponent.paintChildren(JComponent.java:907)
	at java.desktop/javax.swing.JComponent.paint(JComponent.java:1083)
	at java.desktop/javax.swing.JViewport.paint(JViewport.java:737)
	at java.desktop/javax.swing.JComponent.paintChildren(JComponent.java:907)
	at java.desktop/javax.swing.JComponent.paint(JComponent.java:1083)
	at java.desktop/javax.swing.JComponent.paintChildren(JComponent.java:907)
	at java.desktop/javax.swing.JComponent.paint(JComponent.java:1083)
	at java.desktop/javax.swing.JComponent.paintChildren(JComponent.java:907)
	at java.desktop/javax.swing.JComponent.paint(JComponent.java:1083)
	at java.desktop/javax.swing.JComponent.paintChildren(JComponent.java:907)
	at org.openstreetmap.josm.gui.widgets.MultiSplitPane.paintChildren(MultiSplitPane.java:205)
	at java.desktop/javax.swing.JComponent.paint(JComponent.java:1083)
	at java.desktop/javax.swing.JComponent.paintChildren(JComponent.java:907)
	at java.desktop/javax.swing.JComponent.paint(JComponent.java:1083)
	at java.desktop/javax.swing.JComponent.paintChildren(JComponent.java:907)
	at java.desktop/javax.swing.JSplitPane.paintChildren(JSplitPane.java:1024)
	at java.desktop/javax.swing.JComponent.paint(JComponent.java:1083)
	at java.desktop/javax.swing.JComponent.paintToOffscreen(JComponent.java:5255)
	at java.desktop/javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:246)
	at java.desktop/javax.swing.RepaintManager.paint(RepaintManager.java:1323)
	at java.desktop/javax.swing.JComponent._paintImmediately(JComponent.java:5203)
	at java.desktop/javax.swing.JComponent.paintImmediately(JComponent.java:5013)
	at java.desktop/javax.swing.RepaintManager$4.run(RepaintManager.java:865)
	at java.desktop/javax.swing.RepaintManager$4.run(RepaintManager.java:848)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:848)
	at java.desktop/javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:823)
	at java.desktop/javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:772)
	at java.desktop/javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1890)
	at java.desktop/java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:313)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:770)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:740)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

Attachments (0)

Change History (4)

comment:1 Changed 21 months ago by skyper

Component: CorePlugin mapillary
Keywords: update added
Owner: changed from team to jpietri

comment:2 Changed 21 months ago by Don-vip

Summary: crash when updating the plug-ins (triggered by mapillary plug-in update)NPE at MapillaryImageDisplay.paintImage

comment:3 Changed 5 months ago by skyper

Owner: changed from jpietri to taylor.smock

comment:4 Changed 5 months ago by taylor.smock

Resolution: duplicate
Status: newclosed

Closed as duplicate of #16635.
Fixed in ​aa095b493af3cc6556737185338ebf8239c0aadd. This means the fix will be available in the next v2.0 alpha.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain taylor.smock.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.