Modify

#18620 closed defect (fixed)

Geotools plugin no longer works (ClassNotFoundException: javax.sql.DataSource)

Reported by: christian.asker@… Owned by: Don-vip
Priority: normal Milestone: 20.01
Component: Core Webstart Version: latest
Keywords: template_report java11 Cc:

Description (last modified by simon04)

What steps will reproduce the problem?

  1. Fresh JOSM installation (cleaned all config folders)
  2. Install Opendata plugin, which in turn will install Geotools
  3. Upon restarting JOSM, the Geotools plugin will fail.

What is the expected result?

Opendata and Geotools should work.

NOTE: I have had this problem for at least a month, but thought it was some problem with my config files, cache or similar. Now I cleared everything and started from scratch, but he problem persists.

What happens instead?

Geotools won't load: Trace is as follows:

2020-01-25 20:14:13.556 ALLVARLIG: org.openstreetmap.josm.plugins.PluginException: Fel uppstod i insticksmodulen geotools. Anledning: java.lang.reflect.InvocationTargetException. Anledning: java.lang.NoClassDefFoundError: javax/sql/DataSource. Anledning: java.lang.ClassNotFoundException: javax.sql.DataSource
org.openstreetmap.josm.plugins.PluginException: Fel uppstod i insticksmodulen geotools
	at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:369)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugin(PluginHandler.java:814)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:900)
	at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:943)
	at org.openstreetmap.josm.gui.MainApplication.loadLatePlugins(MainApplication.java:1134)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:906)
	at org.openstreetmap.josm.gui.MainApplication$3.processArguments(MainApplication.java:276)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:703)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.base/java.lang.reflect.Method.invoke(Method.java:566)
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:576)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:945)
Caused by: java.lang.reflect.InvocationTargetException
	at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
	at java.base/jdk.internal.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.base/java.lang.reflect.Constructor.newInstance(Constructor.java:490)
	at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:364)
	... 13 more
Caused by: java.lang.NoClassDefFoundError: javax/sql/DataSource
	at org.geotools.util.factory.Hints$DataSourceKey.<init>(Hints.java:1830)
	at org.geotools.util.factory.Hints.<clinit>(Hints.java:217)
	at org.geotools.referencing.CRS.<clinit>(CRS.java:156)
	at org.openstreetmap.josm.plugins.geotools.GeoToolsPlugin.checkEPSG(GeoToolsPlugin.java:102)
	at org.openstreetmap.josm.plugins.geotools.GeoToolsPlugin.<init>(GeoToolsPlugin.java:37)
	... 18 more
Caused by: java.lang.ClassNotFoundException: javax.sql.DataSource
	at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:471)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:588)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:73)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
	... 23 more

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-01-02 22:34:59 +0100 (Thu, 02 Jan 2020)
Revision:15628
Build-Date:2020-01-02 21:52:31
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15628 sv) Linux Ubuntu 18.04.3 LTS
Memory Usage: 356 MB / 2048 MB (132 MB allocated, but free)
Java version: 11.0.5+10-post-Ubuntu-0ubuntu1.118.04, Private Build, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-11-jre:amd64-11.0.5+10-0ubuntu1.1~18.04
WebStart package: icedtea-netx:amd64-1.8-0ubuntu8~18.04
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-20ubuntu0.1
libcommons-compress-java: libcommons-compress-java:all-1.18-1~18.04
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:all-20171026-2
liboauth-signpost-java: liboauth-signpost-java:all-1.2.1.2-1.5
VM arguments: [--add-reads=java.base=ALL-UNNAMED,java.desktop, --add-reads=java.desktop=ALL-UNNAMED,java.naming, --add-reads=java.naming=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.awt=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/javax.jnlp=ALL-UNNAMED,java.desktop, --add-exports=java.base/com.sun.net.ssl.internal.ssl=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.net.www.protocol.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.action=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.provider=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.util=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.validator=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.x509=ALL-UNNAMED,java.desktop, --add-exports=java.base/jdk.internal.util.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.net.www.protocol.http=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.awt.X11=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,jdk.jsobject, --add-exports=java.naming/com.sun.jndi.toolkit.url=ALL-UNNAMED,java.desktop, -Dicedtea-web.bin.name=javaws, -Dicedtea-web.bin.location=/usr/lib/icedtea-web/bin/javaws]

Plugins:
+ apache-commons (35092)
+ ejml (35122)
+ geotools
+ jaxb (35092)
+ jts (35122)
+ opendata (35280)
+ utilsplugin2 (35248)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Region [TMS_BLOCK_v2] Resetting cache
- E: org.openstreetmap.josm.plugins.PluginException: Fel uppstod i insticksmodulen geotools. Anledning: java.lang.reflect.InvocationTargetException. Anledning: java.lang.NoClassDefFoundError: javax/sql/DataSource. Anledning: java.lang.ClassNotFoundException: javax.sql.DataSource
- W: Inaktivera insticksmodul - Kunde inte läsa in insticksmodulen 'geotools'. Skall den tas bort från inställningarna?

Attachments (0)

Change History (4)

comment:1 Changed 13 months ago by simon04

Description: modified (diff)
Summary: Geotools plugin no longer works in JOSMGeotools plugin no longer works (ClassNotFoundException: javax.sql.DataSource)

comment:2 Changed 13 months ago by Don-vip

Keywords: java11 added

comment:3 Changed 13 months ago by Don-vip

Status: newassigned

comment:4 Changed 13 months ago by Don-vip

Component: Plugin geotoolsCore Webstart
Milestone: 20.01
Resolution: fixed
Status: assignedclosed

Specific to webstart. r15167 wasn't correctly applied on the server. I have just fixed it.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.