Modify

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#18609 closed enhancement (duplicate)

Show same/similar (exception) info message once per run, only

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: opening_hours exception Cc:

Description

What steps will reproduce the problem?

  1. Have several objects with opening_hours syntax in tags including SH
  2. run validator

What is the expected result?

One info message about the same exception, only

What happens instead?

One message about each object with SH in tags

Please provide any additional information below. Attach a screenshot if possible.

I was editing several school bus lines.
Please, do not distract and annoy the user by popping up lots of same or similar messages. Thanks

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-01-23 22:57:46 +0100 (Thu, 23 Jan 2020)
Revision:15755
Build-Date:2020-01-24 02:30:53
URL:https://josm.openstreetmap.de/svn/trunk

Last errors/warnings:
- E: javax.script.ScriptException: An error occurred during evaluation of the value "Mo-Fr 07:30-08:30; PH,SH,Sa,Su off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition in <eval> at line number 46 at column number 4733. Cause: jdk.nashorn.internal.runtime.ECMAException: An error occurred during evaluation of the value "Mo-Fr 07:30-08:30; PH,SH,Sa,Su off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition
- W: java.net.SocketTimeoutException: Read timed out
- W: javax.script.ScriptException: An error occurred during evaluation of the value "Mo-Fr 08:10-08:20; PH,SH off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition in <eval> at line number 46 at column number 4733. Cause: jdk.nashorn.internal.runtime.ECMAException: An error occurred during evaluation of the value "Mo-Fr 08:10-08:20; PH,SH off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition
- E: javax.script.ScriptException: An error occurred during evaluation of the value "Mo-Fr 08:10-08:20; PH,SH off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition in <eval> at line number 46 at column number 4733. Cause: jdk.nashorn.internal.runtime.ECMAException: An error occurred during evaluation of the value "Mo-Fr 08:10-08:20; PH,SH off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition
- W: javax.script.ScriptException: An error occurred during evaluation of the value "Mo-Fr 12:25-12:40; PH,SH,Sa,Su off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition in <eval> at line number 46 at column number 4733. Cause: jdk.nashorn.internal.runtime.ECMAException: An error occurred during evaluation of the value "Mo-Fr 12:25-12:40; PH,SH,Sa,Su off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition
- E: javax.script.ScriptException: An error occurred during evaluation of the value "Mo-Fr 12:25-12:40; PH,SH,Sa,Su off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition in <eval> at line number 46 at column number 4733. Cause: jdk.nashorn.internal.runtime.ECMAException: An error occurred during evaluation of the value "Mo-Fr 12:25-12:40; PH,SH,Sa,Su off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition
- W: javax.script.ScriptException: An error occurred during evaluation of the value "Mo-Fr 07:25-08:20; PH,SH,Sa,Su off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition in <eval> at line number 46 at column number 4733. Cause: jdk.nashorn.internal.runtime.ECMAException: An error occurred during evaluation of the value "Mo-Fr 07:25-08:20; PH,SH,Sa,Su off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition
- E: javax.script.ScriptException: An error occurred during evaluation of the value "Mo-Fr 07:25-08:20; PH,SH,Sa,Su off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition in <eval> at line number 46 at column number 4733. Cause: jdk.nashorn.internal.runtime.ECMAException: An error occurred during evaluation of the value "Mo-Fr 07:25-08:20; PH,SH,Sa,Su off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition
- W: javax.script.ScriptException: An error occurred during evaluation of the value "Mo-Fr 07:30-08:30; PH,SH,Sa,Su off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition in <eval> at line number 46 at column number 4733. Cause: jdk.nashorn.internal.runtime.ECMAException: An error occurred during evaluation of the value "Mo-Fr 07:30-08:30; PH,SH,Sa,Su off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition
- E: javax.script.ScriptException: An error occurred during evaluation of the value "Mo-Fr 07:30-08:30; PH,SH,Sa,Su off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition in <eval> at line number 46 at column number 4733. Cause: jdk.nashorn.internal.runtime.ECMAException: An error occurred during evaluation of the value "Mo-Fr 07:30-08:30; PH,SH,Sa,Su off". Please submit a pull request: https://github.com/ypid/opening_hours.js. no SH definition

Attachments (0)

Change History (3)

comment:1 Changed 2 months ago by skyper

Summary: Show (exception) info message once per run, onlyShow same/similar (exception) info message once per run, only

comment:2 Changed 2 months ago by simon04

Keywords: opening_hours exception added; template_report message removed
Resolution: duplicate
Status: newclosed

Closed as duplicate of #18208.

comment:3 Changed 2 months ago by skyper

Hey, I do not talk about the message in general, but only of the number of appearances per run. Especially as the messages are shown quite some time after the run of validator is finished.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.