Modify

Opened 4 years ago

Closed 4 years ago

#18575 closed defect (duplicate)

Error when splitting polygon

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Plugin shapetools Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Draw line between the borders of a polygon
  2. select the line and then the polygon
  3. Select "split polygon"

What is the expected result?

That the polygon is separated in two along the line

What happens instead?

Just the error message popping up

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-01-02 22:34:59 +0100 (Thu, 02 Jan 2020)
Build-Date:2020-01-02 21:52:31
Revision:15628
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15628 de) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 1909 (18363)
Memory Usage: 773 MB / 989 MB (140 MB allocated, but free)
Java version: 1.8.0_241-b07, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080, \Display1 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (35248)
+ DirectUpload (35248)
+ PolygonCutOut (v0.7)
+ ShapeTools (1240)
+ apache-commons (35092)
+ apache-http (35092)
+ areaselector (359)
+ austriaaddresshelper (57)
+ buildings_tools (35248)
+ contourmerge (v0.1.5)
+ editgpx (35248)
+ ejml (35122)
+ imagery_offset_db (35248)
+ jna (35092)
+ log4j (35092)
+ splinex (35248)
+ terracer (35248)
+ turnrestrictions (35248)
+ utilsplugin2 (35248)
+ wikipedia (1.1.3)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>
- E: Fehlerhafte Anfrage - org.openstreetmap.josm.gui.widgets.HtmlPanel[,0,0,0x0,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]
- W: Region [WMTS_BLOCK_v2] Resetting cache
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 16
- W: Achtung - <html>JOSM konnte keine Informationen über die folgenden Erweiterungen finden:<ul><li>imagery_offset_db</li><li>apache-commons</li><li>splinex</li><li>DirectUpload</li><li>ejml</li><li>ShapeTools</li><li>editgpx</li><li>utilsplugin2</li><li>AddrInterpolation</li><li>PolygonCutOut</li><li>areaselector</li><li>buildings_tools</li><li>terracer</li><li>turnrestrictions</li><li>wikipedia</li><li>jna</li><li>austriaaddresshelper</li><li>apache-http</li><li>contourmerge</li><li>log4j</li></ul>Diese Erweiterungen werden nicht geladen.</html>


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (15) of main
java.lang.ArrayIndexOutOfBoundsException: 16
	at org.openstreetmap.josm.data.osm.Way.getNode(Way.java:97)
	at org.openstreetmap.josm.data.osm.WaySegment.getFirstNode(WaySegment.java:42)
	at org.openstreetmap.josm.plugins.shapetools.DrawableSegment.paint(DrawableSegment.java:52)
	at org.openstreetmap.josm.gui.MapView.drawTemporaryLayers(MapView.java:648)
	at org.openstreetmap.josm.gui.MapView.drawMapContent(MapView.java:585)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:488)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JSplitPane.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JLayeredPane.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintToOffscreen(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
	at javax.swing.RepaintManager.paint(Unknown Source)
	at javax.swing.JComponent._paintImmediately(Unknown Source)
	at javax.swing.JComponent.paintImmediately(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.prePaintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.access$1200(Unknown Source)
	at javax.swing.RepaintManager$ProcessingRunnable.run(Unknown Source)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 by GerdP, 4 years ago

Component: CorePlugin shapetools

comment:2 by GerdP, 4 years ago

Resolution: duplicate
Status: newclosed

Closed as duplicate of #18076.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.