Modify

#18550 closed enhancement (fixed)

don't warn about bollard=unremovable looks like bollard=removable

Reported by: Hanikatu Owned by: team
Priority: normal Milestone: 20.01
Component: Core validator Version:
Keywords: bollard unremovable Cc:

Description

What steps will reproduce the problem?

  1. creat a node
  2. use as tag bollard=unremovable
  3. check it

What is the expected result?

it is ok
(look here: https://taginfo.openstreetmap.org/tags/bollard=unremovable )

What happens instead?

The check shows that the value 'unremovable' is unknown. Maybe 'removable' is meant.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-01-02 22:34:59 +0100 (Thu, 02 Jan 2020)
Build-Date:2020-01-02 21:52:31
Revision:15628
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15628 de) Windows 10 64-Bit
OS Build number: Windows 10 Home 1909 (18363)
Memory Usage: 1489 MB / 3628 MB (568 MB allocated, but free)
Java version: 1.8.0_231-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1440x900
Maximum Screen Size: 1440x900
VM arguments: [-Duser.home=%UserProfile%]
Dataset consistency test: No problems found

Plugins:
+ RoadSigns (35260)
+ buildings_tools (35248)
+ undelete (35248)

Tagging presets:
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/DE.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Light_sources&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Surveillance&zip=1
+ D:\Benutzer\Desktop\alt\OpenStreetMap\JOSM\Vorlagen\Lichtvorlage\Licht.zip
+ D:\Benutzer\Desktop\alt\OpenStreetMap\JOSM\Vorlagen\Strommastvorlage\Strommast_vorlage.zip

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Enhanced_Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/RecyclingMaterials&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransportV2&zip=1
- D:\Benutzer\Desktop\alt\OpenStreetMap\JOSM\Kartenstiel\oberfläche\oberfläche.mapcss
- D:\Benutzer\Desktop\alt\OpenStreetMap\JOSM\Kartenstiel\häuser\häuser.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LitObjects&zip=1
- https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs_EUR.zip
- https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/PriorityRoad&zip=1
+ D:\Benutzer\Desktop\alt\OpenStreetMap\JOSM\Kartenstiel\Strommast\Strommast.mapcss
+ D:\Benutzer\Desktop\alt\OpenStreetMap\JOSM\Kartenstiel\Richtung\ausrichtung.mapcss
+ D:\Benutzer\Desktop\alt\OpenStreetMap\JOSM\Kartenstiel\Licht\Licht.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
- https://www.dropbox.com/s/qo3ai47fpv241jf/Styles_Fixme_and_Notes.zip?raw=1

Validator rules:
+ https://josm.openstreetmap.de/josmfile?page=Rules/GermanySpecific&zip=1

Last errors/warnings:
- W:  Tertiary: Could not get presets icon traffic_signs_presets/ES_tertiary.png
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Region [WMS_BLOCK_v2] Resetting cache
- W: Region [WMTS_BLOCK_v2] Resetting cache
- W: Ungespeicherte Änderungen - <html>Die Relation wurde geändert.<br><br>Wollen Sie die Änderungen speichern?</html>
- E: Error header: Version mismatch: Provided 23, server had: 24 of Way 164878660
- E: Konflikte gefunden - <html>Hochladen <strong>fehlgeschlagen</strong>, da der Server eine neuere Version<br>von einem Ihrer Punkte, Linien oder Relationen hat.<br>Der Konflikt wird durch ein Objekt vom Typ <strong>Linie</strong> mit der Kennung <strong>164.878.660</strong> ausgelöst.<br>Der Server hat Version 24, Ihre Version ist 23.<br>Wählen Sie <strong>Nur Linie 164.878.660 synchronisieren</strong>, um dieses Objekt zu synchronisieren.<br>Wählen Sie <strong>Ganzen Datensatz synchronisieren</strong>, um den kompletten lokalen Datensatz mit dem Server zu synchronisieren.<br>Wählen Sie <strong>Abbrechen</strong>, um abzubrechen und weiterzuarbeiten.</html>
- E: Error header: Version mismatch: Provided 23, server had: 24 of Way 164878660
- E: Konflikte gefunden - <html>Hochladen <strong>fehlgeschlagen</strong>, da der Server eine neuere Version<br>von einem Ihrer Punkte, Linien oder Relationen hat.<br>Der Konflikt wird durch ein Objekt vom Typ <strong>Linie</strong> mit der Kennung <strong>164.878.660</strong> ausgelöst.<br>Der Server hat Version 24, Ihre Version ist 23.<br>Wählen Sie <strong>Nur Linie 164.878.660 synchronisieren</strong>, um dieses Objekt zu synchronisieren.<br>Wählen Sie <strong>Ganzen Datensatz synchronisieren</strong>, um den kompletten lokalen Datensatz mit dem Server zu synchronisieren.<br>Wählen Sie <strong>Abbrechen</strong>, um abzubrechen und weiterzuarbeiten.</html>
- W: Konflikte gefunden - <html>3 Konflikte wurden entdeckt.</html>

Attachments (0)

Change History (2)

comment:1 Changed 10 months ago by Klumbumbus

Component: Internal presetCore validator
Milestone: 20.01

comment:2 Changed 10 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 15694/josm:

fix #18550 - don't warn about bollard=unremovable looks like bollard=removable

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.