Modify

Opened 13 months ago

Closed 7 weeks ago

Last modified 7 weeks ago

#18533 closed defect (fixed)

changeset manager: tags tab: width of column (almost) not changeable

Reported by: skyper Owned by: team
Priority: minor Milestone: 20.12
Component: Core Version: latest
Keywords: template_report changeset manager tags Cc:

Description (last modified by skyper)

What steps will reproduce the problem?

  1. Have a changeset with a long tag value. (e.g. 79130450)
  2. In changeset manager click on Tags tab
  3. try to change the width of the columns hovering the mouse on the middle of the title row

What is the expected result?

The width is easily changeable like in the other three tabs

What happens instead?

The width is not or almost not changeable. I noticed sometimes a small jump but that was all

Please provide any additional information below. Attach a screenshot if possible.

screenshot

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-01-05 23:29:48 +0100 (Sun, 05 Jan 2020)
Revision:15644
Build-Date:2020-01-06 02:30:57
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15644 en) Linux Debian GNU/Linux 10 (buster)
Java version: 11.0.5+10-post-Debian-1deb10u1, Debian, OpenJDK 64-Bit Server VM
Java package: openjdk-11-jre:amd64-11.0.5+10-1~deb10u1
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-22
libcommons-compress-java: libcommons-compress-java:all-1.18-2
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:all-20181227-1

Attachments (1)

josm_csm_cstags_screenshot.png (93.3 KB) - added by skyper 13 months ago.
screenshot

Download all attachments as: .zip

Change History (7)

Changed 13 months ago by skyper

screenshot

comment:1 Changed 7 weeks ago by skyper

Resolution: irreproducible
Status: newclosed

Must have been fixed with other changes.

comment:2 in reply to:  1 Changed 7 weeks ago by skyper

Description: modified (diff)
Resolution: irreproducible
Status: closedreopened

Replying to skyper:

Must have been fixed with other changes.

Oh no, I did not carefully enough read my own report.

This problem still exist but only with the tags tab.

comment:3 Changed 7 weeks ago by GerdP

Resolution: fixed
Status: reopenedclosed

In 17371/josm:

fix #18533: changeset manager: tags tab: width of column (almost) not changeable

  • use ReadOnlyTableModel as in PropertiesDialog to allow resizing of column width
  • don't allow reordering of column headers in Changeset dialogs (because content doesn't match header if allowed)

comment:4 Changed 7 weeks ago by GerdP

After commiting I found the cause for the problem with the old code.
It uses class TagTable which contains

    @Override
    public Dimension getPreferredSize() {
        return getPreferredFullWidthSize();
    }

This method is called whenever you move the mouse cursor inside the dialog and resets the column widths. I guess it should only be used when the dialog is created, but I have not yet found how to change that.

comment:5 Changed 7 weeks ago by skyper

Maybe, breaking long values into several lines could be an enhancement to display more/all content.

comment:6 Changed 7 weeks ago by GerdP

Milestone: 20.12

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.