Modify

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#18529 closed defect (duplicate)

NPE at ICC_Profile.intFromBigEndian

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core imagery Version:
Keywords: template_report javabug jpeg macosx Cc:

Description

What steps will reproduce the problem?

  1. Unsure, it doesnt always occur but usually occurs within the first minute of opening JOSM

What is the expected result? I just want to use imagery I chose

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-01-02 22:34:59 +0100 (Thu, 02 Jan 2020)
Build-Date:2020-01-02 21:52:31
Revision:15628
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15628 en) Mac OS X 10.15.1
OS Build number: Mac OS X 10.15.1 (19B88)
Memory Usage: 776 MB / 1820 MB (80 MB allocated, but free)
Java version: 1.8.0_231-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 188945225 1920x1080, Display 69731458 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Djava.util.Arrays.useLegacyMergeSort=true, -Djnlp.tk=awt, -Djnlpx.jvm=<java.home>/bin/java, -Djnlpx.splashport=-1, -Djnlpx.home=<java.home>/bin, -Djnlpx.remove=false, -Djnlpx.offline=false, -Djnlpx.relaunch=true, -Djnlpx.session.data=/var/folders/sl/vjfkj4p11g1d8tzy5nblzy680000gn/T/session8389649054069479023, -Djnlpx.heapsize=-1,2147483648, -Djava.security.policy=file:<java.home>/lib/security/javaws.policy, -DtrustProxy=true, -Djnlpx.origFilenameArg=${HOME}/Desktop/josm.jnlp, -Dsun.awt.warmup=true, -Djava.security.manager]
Dataset consistency test: No problems found

Plugins:
+ auto_tools (73)
+ buildings_tools (35248)
+ continuosDownload (82)
+ measurement (35248)
+ osm-obj-info (56)
+ utilsplugin2 (35248)

Tagging presets:
+ ${HOME}/Dropbox/Kaart/JOSM/FB_IDN_preset.xml
+ ${HOME}/Downloads/MYS_josm_files (1)/FB_presets.xml

Map paint styles:
+ ${HOME}/Desktop/Overlapping-Ways.mapcss
+ ${HOME}/Dropbox/Kaart/JOSM/rainbow_roads.mapcss
+ ${HOME}/Downloads/MYS_josm_files (1)/FB_style.mapcss
+ ${HOME}/Downloads/MYS_josm_files (1)/FB_rules5.11.validator.mapcss
+ ${HOME}/Downloads/Kaart_QC_Freestone.mapcss

Validator rules:
+ ${HOME}/Desktop/FB_rules5.8.validator.mapcss

Last errors/warnings:
- W: Unable to convert property color to type class java.awt.Color: found Keyword{transparent} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property color to type class java.awt.Color: found Keyword{transparent} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property color to type class java.awt.Color: found Keyword{transparent} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property color to type class java.awt.Color: found Keyword{transparent} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: TMS-downloader-20 (132)
java.lang.NullPointerException
	at java.awt.color.ICC_Profile.intFromBigEndian(ICC_Profile.java:1782)
	at java.awt.color.ICC_Profile.getNumComponents(ICC_Profile.java:1474)
	at sun.java2d.cmm.lcms.LCMSTransform.<init>(LCMSTransform.java:98)
	at sun.java2d.cmm.lcms.LCMS.createTransform(LCMS.java:173)
	at java.awt.color.ICC_ColorSpace.fromRGB(ICC_ColorSpace.java:230)
	at com.sun.imageio.plugins.jpeg.JPEGImageReader.setImageData(JPEGImageReader.java:713)
	at com.sun.imageio.plugins.jpeg.JPEGImageReader.readImageHeader(Native Method)
	at com.sun.imageio.plugins.jpeg.JPEGImageReader.readNativeHeader(JPEGImageReader.java:628)
	at com.sun.imageio.plugins.jpeg.JPEGImageReader.checkTablesOnly(JPEGImageReader.java:347)
	at com.sun.imageio.plugins.jpeg.JPEGImageReader.gotoImage(JPEGImageReader.java:495)
	at com.sun.imageio.plugins.jpeg.JPEGImageReader.readHeader(JPEGImageReader.java:621)
	at com.sun.imageio.plugins.jpeg.JPEGImageReader.readInternal(JPEGImageReader.java:1078)
	at com.sun.imageio.plugins.jpeg.JPEGImageReader.read(JPEGImageReader.java:1058)
	at javax.imageio.ImageIO.read(ImageIO.java:1448)
	at javax.imageio.ImageIO.read(ImageIO.java:1352)
	at org.openstreetmap.gui.jmapviewer.Tile.loadImage(Tile.java:247)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.tryLoadTileImage(TMSCachedTileLoaderJob.java:294)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.loadingFinished(TMSCachedTileLoaderJob.java:183)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.finishLoading(JCSCachedTileLoaderJob.java:257)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.run(JCSCachedTileLoaderJob.java:220)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)

Attachments (0)

Change History (3)

comment:1 Changed 3 months ago by Don-vip

Component: CoreCore imagery
Keywords: javabug jpeg macosx added
Summary: bug in josm after turning on imageryNPE at JPEGImageReader.read

comment:2 Changed 3 months ago by Don-vip

Resolution: duplicate
Status: newclosed
Summary: NPE at JPEGImageReader.readNPE at ICC_Profile.intFromBigEndian

Closed as duplicate of #18087.
Probably a variant of #18087

comment:3 in reply to:  2 Changed 3 months ago by skyper

Replying to Don-vip:

Closed as duplicate of #18087.
Probably a variant of #18087

Strange the last duplicates were all on Mac OS X 10.15 which is 64bit and does not support 32bit

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.