Modify

Opened 11 months ago

Closed 5 weeks ago

Last modified 7 days ago

#18527 closed defect (fixed)

changeset manager: content information of (closed) changeset lost when updating discussion

Reported by: skyper Owned by: GerdP
Priority: normal Milestone: 20.11
Component: Core Version: latest
Keywords: template_report changeset manager content update Cc:

Description

What steps will reproduce the problem?

  1. have a (closed) changeset's content downloaded in changeset manager
  2. click on discussion tab
  3. update discussion
  4. click on content tab

What is the expected result?

The content is still visible

What happens instead?

No content, Have to download again from Server

Please provide any additional information below. Attach a screenshot if possible.

Not sure how to handle open changesets but for closed changesets the content does not change.
The description of the buttons in mini-help hovering over the buttons makes you aspect that content and discussion are handled separately.

before:
before discussion
after:
after

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-01-05 23:29:48 +0100 (Sun, 05 Jan 2020)
Revision:15644
Build-Date:2020-01-06 02:30:57
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15644 en) Linux Debian GNU/Linux 10 (buster)
Memory Usage: 191 MB / 964 MB (66 MB allocated, but free)
Java version: 11.0.5+10-post-Debian-1deb10u1, Debian, OpenJDK 64-Bit Server VM
Screen: :0.0 1366x768
Maximum Screen Size: 1366x768
Java package: openjdk-11-jre:amd64-11.0.5+10-1~deb10u1
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-22
libcommons-compress-java: libcommons-compress-java:all-1.18-2
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:all-20181227-1
VM arguments: [-Djosm.home=<josm.pref>]
Dataset consistency test: No problems found

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Region [TMS_BLOCK_v2] Resetting cache

Attachments (3)

josm_cs_content_down.png (9.8 KB) - added by skyper 11 months ago.
before
josm_cs_content_no.png (11.2 KB) - added by skyper 11 months ago.
after
josm_discussion_screenshot.png (10.2 KB) - added by skyper 11 months ago.
discussion

Download all attachments as: .zip

Change History (11)

Changed 11 months ago by skyper

Attachment: josm_cs_content_down.png added

before

Changed 11 months ago by skyper

Attachment: josm_cs_content_no.png added

after

Changed 11 months ago by skyper

discussion

comment:1 Changed 6 weeks ago by GerdP

Owner: changed from team to GerdP
Status: newassigned

I can reproduce this. Digging into the code now...

comment:2 Changed 6 weeks ago by GerdP

Seems to be a regression of r16826.

comment:3 in reply to:  2 Changed 6 weeks ago by skyper

Replying to GerdP:

Seems to be a regression of r16826.

No, has to be much older:
Replying to skyper:

…
Revision:15644
Build-Date:2020-01-06 02:30:57

comment:4 Changed 6 weeks ago by GerdP

It's probably a re-occuring problem. See my comments in #18919.

comment:5 Changed 5 weeks ago by GerdP

Resolution: fixed
Status: assignedclosed

In 17250/josm:

fix #18527: changeset manager: content information of (closed) changeset lost when updating discussion
Ignore events which are created when tables are sorted. Avoids to download known data again and seems to fix this problem as well. With the old code the content was of the panel was cleared because of events that contained no changeset id.

comment:6 Changed 5 weeks ago by GerdP

Milestone: 20.10

comment:7 Changed 5 weeks ago by GerdP

In 17255/josm:

see #18527 changeset manager: content information of (closed) changeset lost when updating discussion
fix unit tests which call methods with null arguments

comment:8 Changed 7 days ago by Don-vip

Milestone: 20.1020.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain GerdP.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.