Modify

Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#18473 closed defect (duplicate)

Remove Maxar from aerial image list

Reported by: mkoniecz Owned by: team
Priority: normal Milestone:
Component: External imagery source Version:
Keywords: template_report Cc: sommerluk

Description (last modified by mkoniecz)

What steps will reproduce the problem?

  1. Try to use Maxar

What is the expected result?

I see tiles

What happens instead?

I see error messages.

Please provide any additional information below. Attach a screenshot if possible.

https://josm.openstreetmap.de/wiki/Maps/Worldwide - Maxar is present

Maxar stopped providing public tile service, so it is not a JOSM bug. See https://www.openstreetmap.org/user/@kevin_bullock/diary/391652

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-12-01 23:10:15 +0100 (Sun, 01 Dec 2019)
Build-Date:2019-12-02 02:30:57
Revision:15553
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15553 en) Linux Ubuntu 16.04.6 LTS
Memory Usage: 845 MB / 1820 MB (161 MB allocated, but free)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
libcommons-logging-java: libcommons-logging-java:all-1.2-1+build1
fonts-noto: fonts-noto:-
VM arguments: [-Djava.util.Arrays.useLegacyMergeSort=true, -Djnlp.tk=awt, -Djnlpx.jvm=${JAVA_HOME}/jre/bin/java, -Djnlpx.splashport=36401, -Djnlpx.home=${JAVA_HOME}/jre/bin, -Djnlpx.remove=false, -Djnlpx.offline=false, -Djnlpx.relaunch=true, -Djnlpx.session.data=/tmp/session8246345539093259082, -Djnlpx.heapsize=-1,2147483648, -Djava.security.policy=file:${JAVA_HOME}/jre/lib/security/javaws.policy, -DtrustProxy=true, -Dsun.awt.warmup=true, -Djava.security.manager]
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (35242)
+ PicLayer (35104)
+ apache-commons (35092)
+ buildings_tools (35171)
+ continuosDownload (82)
+ ejml (35122)
+ geotools (35169)
+ imagery_offset_db (34908)
+ jts (35122)
+ log4j (34908)
+ measurement (35221)
+ reverter (35226)
+ todo (30306)

Validator rules:
- ${HOME}/Documents/install_moje/OSM software/josm/data/validator/deprecated.mapcss
- ${HOME}/Documents/install_moje/OSM software/josm/data/validator/unnecessary.mapcss
- ${HOME}/Documents/install_moje/OSM software/josm/data/validator/combinations.mapcss

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (0)

Change History (8)

comment:1 Changed 5 months ago by mkoniecz

Description: modified (diff)

comment:2 Changed 5 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #18440.

comment:3 Changed 5 months ago by Klumbumbus

Component: Core imageryExternal imagery source

Both sources still delivers tiles at lower zoom levels (I saw maxar premium up to z12), however they are maybe not usefull at these low zooms.

comment:5 Changed 5 months ago by Klumbumbus

Both sources are full dead now and we should comment them out for now at wiki:/Maps/Worldwide, however these are default enries, @team: are other core changes required in this case?

comment:6 Changed 5 months ago by Don-vip

I'm not sure. I have commented Maxar entries in https://josm.openstreetmap.de/wiki/Maps/Worldwide?action=diff&version=70

comment:7 Changed 5 months ago by sommerluk

Cc: sommerluk added

comment:8 in reply to:  5 Changed 5 months ago by stoecker

Replying to Klumbumbus:

@team: are other core changes required in this case?

As far as I remember they will simply vanish in the configs as soon as the list without them is loaded by JOSM (that's what we have IDs for :-).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.