Modify

Opened 10 months ago

Closed 7 months ago

Last modified 7 months ago

#18460 closed defect (fixed)

incorrect international border Germany - Switzerland

Reported by: skyper Owned by: Don-vip
Priority: normal Milestone: 20.01
Component: Core validator Version: latest
Keywords: international border boundaries germany switzerland Cc:

Description

What steps will reproduce the problem?

  1. load https://www.openstreetmap.org/api/0.6/way/153884363/11
  2. run validator

What is the expected result?

No error warning

What happens instead?

"street name contains ß"

Please provide any additional information below. Attach a screenshot if possible.

While in Switzerland spelling street is "Strasse" in Germany it is "Straße". In my case we are close to the border but still in Germany.

The only reason for this false positive is an incorrect border in JOSM data as the border is correct in OSM data.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-12-24 11:33:02 +0100 (Tue, 24 Dec 2019)
Revision:15611
Build-Date:2019-12-25 02:31:00
URL:https://josm.openstreetmap.de/svn/trunk

Attachments (1)

boundaries.png (32.8 KB) - added by Don-vip 10 months ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 months ago by Klumbumbus

@Vincent: didn't you implement stable ids some time ago? When I add/move a few nodes in the boundary file, it messes the whole file up. Is there some kind of trick?

Changed 10 months ago by Don-vip

Attachment: boundaries.png added

comment:2 Changed 10 months ago by Don-vip

The first trick is to not open the file directly but load the internal dataset from JOSM memory.
I didn't know where to put this very advanced feature only useful to JOSM developers to I put it there:


Still I noticed the last time I tried to edit the file it does not work as expected, and I had to manually edit the file to keep ids in r15564:15565. Yet I managed to mess up with it and had to fix some mistakes in r15566.

I must look to see if I can fix what's not working.

Last edited 10 months ago by Don-vip (previous) (diff)

comment:3 Changed 10 months ago by GerdP

I also missed this feature last time when I changed data_nodist\multipolygon.osm

comment:4 Changed 10 months ago by Don-vip

Keywords: boundaries germany switzerland added
Milestone: 20.01

comment:5 Changed 10 months ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

comment:6 Changed 10 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 15638/josm:

fix #18460 - more precise border between Germany and Switzerland

comment:7 Changed 7 months ago by skyper

Resolution: fixed
Status: closedreopened

Once again not accurate enough. According to JOSM osmwww:way/34953154 is in Germany. I get a warning about cycleway together with foot from the German rules.

comment:8 Changed 7 months ago by Klumbumbus

Resolution: fixed
Status: reopenedclosed

comment:9 Changed 7 months ago by Klumbumbus

Country specific tests will never be free of false posities anyway because of e.g. highways crossing the border.

comment:10 in reply to:  8 Changed 7 months ago by skyper

Replying to Klumbumbus:

The border is correct there. Fixed by https://josm.openstreetmap.de/wiki/Rules/GermanySpecific?action=diff&version=21

Thanks, for finding the issue.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.