Modify

Opened 5 weeks ago

Closed 5 weeks ago

Last modified 3 weeks ago

#18431 closed enhancement (fixed)

Advanced Preference to disable falling stars

Reported by: ika-chan! Owned by: team
Priority: minor Milestone: 19.12
Component: Core Version: latest
Keywords: Cc:

Description

Is there a way to disable the falling stars from r14578 with an Advanced Preference entry? It can get annoying after a while.

Attachments (2)

18431.patch (1.3 KB) - added by GerdP 5 weeks ago.
add expert option gui.start.animation. If set to false JOSM will not show an animation after next start or restart
nofun.png (360.9 KB) - added by Don-vip 4 weeks ago.

Download all attachments as: .zip

Change History (25)

comment:1 Changed 5 weeks ago by stoecker

Resolution: wontfix
Status: newclosed

What about: Do something with josm instead of staring at the start screen.

comment:2 Changed 5 weeks ago by stoecker

Ticket #18432 has been marked as a duplicate of this ticket.

comment:3 Changed 5 weeks ago by maarten

What about: don't even spend your time coding something like this but spend time working on all the other open tickets.

comment:4 Changed 5 weeks ago by GerdP

I'd be happy to invest my time to remove it.
My first thought when I saw it last year: Shit, a virus :(
Next thought: No, very unlikely. I looked the svn log and found that it was intended.
Next thought: I don't like this because it is some kind of religious statement and I am kind of against all religions.

comment:5 Changed 5 weeks ago by stoecker

Sorry, but falling snow is in no way a religious statement. Are the walking Lemmings on the boot screen of openSUSE a religious statement also?

comment:6 Changed 5 weeks ago by GerdP

The religios statement is in the source code and in the svn log message:
"It's Christmas time! Animate our "Getting Started" page with shining stars."

comment:7 Changed 5 weeks ago by maarten

And in the source
"The gui/animation Christmas GPL code is from Jiri Vanek (Red Hat):"

It's not snowflakes.

comment:8 Changed 5 weeks ago by stoecker

Please don't start such hairsplitting.

JOSM is used and probably developed by people of different opinion. For me these things always have been snowflakes (I've never seen stars falling down). Anyway beside this I personally never believed in any deity and nevertheless Christmas is a time to celebrate for me.

Christmas and this animation is only a religious statement when you want it to be a religious statement.

This is a harmless animation and not a statement to fight the pagans and whoever sees this different should try to readjust his view.

BTW I would fight for it especially as atheist and somebody who does not really care for it, because nothing can be more wrong than not doing something because SOMEBODY could misunderstand it.

comment:9 in reply to:  4 Changed 5 weeks ago by skyper

+1 for an option to disable it.

  • it is distracting when reading the news.
  • it is power consuming.
  • snow falls are only appropriate for the northern part of the norther hemisphere.
  • the time span shows that the background (Christmas) is religious/cultural not winter.

Replying to stoecker:

What about: Do something with josm instead of staring at the start screen.

Not a nice answer for a simply question.

Replying to GerdP:

I'd be happy to invest my time to remove it.

This would be welcome. Thanks in advance.

Changed 5 weeks ago by GerdP

Attachment: 18431.patch added

add expert option gui.start.animation. If set to false JOSM will not show an animation after next start or restart

comment:10 Changed 4 weeks ago by GerdP

Resolution: wontfixfixed

In 15602/josm:

fix #18431: add expert option gui.start.animation. If set to false JOSM will not show an animation after next start or restart

comment:11 Changed 4 weeks ago by Don-vip

Milestone: 19.12

comment:12 Changed 4 weeks ago by stoecker

Ticket #18446 has been marked as a duplicate of this ticket.

comment:13 Changed 4 weeks ago by stoecker

I really have the feeling the world is going down the drain. 3 bug reports complaining about a harmless animation in 3 days. I expect that people like it or not, but who the hell opens a bug-report to complain about an obviously temporary funny animation?

And it should be obvious that JOSM developers are aware of the fact that the world is round, has a northern and a southern hemisphere, different regions, religions and traditions.

Nevertheless this software is developed by a few people only and these people have the right to add any funny jokes or animations to the software. In the 90ies it was even expected that each software has such things. The spirit of freedom and tolerance seems getting lost faster and faster each year since the millenium. Very sad!

comment:14 Changed 4 weeks ago by mario@…

how do I switch it off?
I find it distracting, in particular while I'm perspiring like a pig in 30°C.
I am from the previous millennium, and I was used to this kind of funny shit.
so my first guess was to click on a star and smash it on the screen, like on xroaches,
but no, they keep falling.

comment:15 Changed 4 weeks ago by GerdP

The easiest way is to press Crtl+N to start a new edit layer.

comment:16 in reply to:  14 Changed 4 weeks ago by stoecker

Replying to mario@…:

so my first guess was to click on a star and smash it on the screen, like on xroaches,

Ah, that would be a nice extension...

Changed 4 weeks ago by Don-vip

Attachment: nofun.png added

comment:17 in reply to:  13 ; Changed 4 weeks ago by Don-vip

Replying to stoecker:

I really have the feeling the world is going down the drain. 3 bug reports complaining about a harmless animation in 3 days. I expect that people like it or not, but who the hell opens a bug-report to complain about an obviously temporary funny animation?

And it should be obvious that JOSM developers are aware of the fact that the world is round, has a northern and a southern hemisphere, different regions, religions and traditions.

Nevertheless this software is developed by a few people only and these people have the right to add any funny jokes or animations to the software. In the 90ies it was even expected that each software has such things. The spirit of freedom and tolerance seems getting lost faster and faster each year since the millenium. Very sad!

+1. Seeing all these incredibly negative/hostile comments for a funny feature I made one year ago just want make me stop coding for JOSM for the holidays. Well done guys. Seriously, seeing some harmless stars for a few days should suddenly be the most important matter we need to discuss and focus on?

@Gerd: I propose to rename the property to no.fun.allowed. This way we could disable every fun feature Dirk or I would like to add to JOSM, so that angry people remain happy.


comment:18 Changed 4 weeks ago by anonymous

Well said Don-vip. We are really surrounded by embittered idiots. I wish you all a Merry Christmas

comment:19 Changed 4 weeks ago by anonymous

hey, lower the tone please. we're not calling anybody names, and we don't like to be called names.

I enjoyed, in the old times, when I could start xsnow and ask for -santa
but that was something we would do conscientiously, willingly, and expecting to have some company on the screen.

xsnow and xroaches would stay in the area *outside* the windows where we worked.
this occupies much more space, flies in front of the letters I am trying to read, and we're not in control.

comment:20 Changed 4 weeks ago by mario@…

you know what? maybe, if one line in the news would mention something like:

happy Christmas you all, these flying stars will stop on the 26th of December at 12:00 UTC

you would not have received a single bug report. at least: you would not have received mine.

comment:21 in reply to:  20 Changed 4 weeks ago by stoecker

Replying to mario@…:

you know what? maybe, if one line in the news would mention something like:

happy Christmas you all, these flying stars will stop on the 26th of December at 12:00 UTC

you would not have received a single bug report. at least: you would not have received mine.

Yes that's so true and one must note that fun and jokes should never be made without a disclaimer and be explained afterwards.

comment:22 Changed 4 weeks ago by ika-chan!

Guys, your arrogance and excessive political "war on Christmas" and "no fun" arguments about a simple request to manually disable the falling stars is really alarming.

Where did I ever say that it must be turned off by default?

comment:23 in reply to:  17 Changed 3 weeks ago by Klumbumbus

Replying to Don-vip:

all these incredibly negative/hostile comments

Here is some positive feedback for you :) starting from this post: https://forum.openstreetmap.org/viewtopic.php?pid=772698#p772698

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.