Modify

Opened 3 months ago

Closed 3 months ago

#18399 closed defect (fixed)

display problem on the "add a node..." window in French

Reported by: leni Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin utilsplugin2 Version:
Keywords: template_report i18n french regression Cc: stoecker

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Windows 10 Josm 15553
  2. Ctrl+Shift+L

What is the expected result?

a window similar to the one in English

What happens instead?

a window with /r - the spanish and german windows are ok

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-12-01 23:10:15 +0100 (Sun, 01 Dec 2019)
Build-Date:2019-12-02 02:30:57
Revision:15553
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15553 fr) Windows 10 64-Bit
OS Build number: Windows 10 Home 1903 (18362)
Memory Usage: 836 MB / 1751 MB (300 MB allocated, but free)
Java version: 1.8.0_231-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1280x1024
Maximum Screen Size: 1280x1024
Dataset consistency test: No problems found

Plugins:
+ Mapillary (1.5.20)
+ PicLayer (35104)
+ apache-commons (35092)
+ apache-http (34908)
+ buildings_tools (35171)
+ cadastre-fr (35194)
+ changeset-viewer (22)
+ conflation (0.6.4)
+ ejml (35122)
+ geotools (35169)
+ imagery_offset_db (34908)
+ jaxb (35014)
+ jna (34908)
+ jts (35122)
+ opendata (35179)
+ pt_assistant (34678)
+ reverter (35226)
+ rex (53)
+ scripting (30796)
+ tageditor (34977)
+ todo (30306)
+ turnlanes-tagging (281)
+ utilsplugin2 (35238)
+ wikipedia (1.1.3)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features_ryg&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/PTStops&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1

Validator rules:
+ https://raw.githubusercontent.com/nlehuby/transport_mapcss/master/transport.validator.mapcss

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Avertissement: le scan du fichier 'fr.toulouse.jar' pour le module d'information a échoué. Action ignorée.

French "add a node"

Attachments (2)

add a node French.png (38.6 KB) - added by leni 3 months ago.
French "add a node"
add a node English.png (34.6 KB) - added by leni 3 months ago.
English add a node

Download all attachments as: .zip

Change History (17)

Changed 3 months ago by leni

Attachment: add a node French.png added

French "add a node"

Changed 3 months ago by leni

Attachment: add a node English.png added

English add a node

comment:1 Changed 3 months ago by Don-vip

Component: unspecifiedCore
Description: modified (diff)
Keywords: i18n french added

comment:2 Changed 3 months ago by Don-vip

Keywords: regression added

comment:3 Changed 3 months ago by Don-vip

Milestone: 19.12
Owner: changed from team to Don-vip
Status: newassigned

comment:4 Changed 3 months ago by Don-vip

Component: CorePlugin utilsplugin2
Milestone: 19.12

comment:5 Changed 3 months ago by Don-vip

Cc: stoecker added

Dirk can you please help me? I don't understand what's wrong. The translation didn't change since 2012. Neither the plugin code calling the translation, neither the plugin *.lang files. I don't understand why tr returns "\r" strings instead of \n characters.

comment:6 Changed 3 months ago by stoecker

The french translation contains these characters. Do a grep '\\r' fr.po. So I doubt your "The translation didn't change since 2012" is true :-)

Added an check for this: [o35246].

comment:7 Changed 3 months ago by stoecker

I fixed issues in languages ast to uk (I hope).

Last edited 3 months ago by stoecker (previous) (diff)

comment:8 Changed 3 months ago by stoecker

Well, 3 changes failed and guess what, the one of this ticket was among them :-) I hope I got it now.

comment:9 Changed 3 months ago by stoecker

@Vincent: Can you please add the new check to Jenkins i18n target?

comment:10 in reply to:  9 Changed 3 months ago by Don-vip

Replying to stoecker:

@Vincent: Can you please add the new check to Jenkins i18n target?

It's done automatically, as you cleverly used the same syntax: https://josm.openstreetmap.de/jenkins/job/JOSM-i18n/1593/parsed_console/

comment:11 Changed 3 months ago by stoecker

Sometimes laziness is helpful...

comment:12 Changed 3 months ago by stoecker

Updated all translation files. I think it is time to recompile all/most plugins (there have been many i18n updates). I'm not sure - I have Java 8 and 11 devel installed, but build will use 11. Is this ok or will I produce invalid plugins?

comment:13 Changed 3 months ago by Don-vip

Build must be done with 8. I'll do it right now.

comment:14 Changed 3 months ago by Don-vip

Updated in [o35249].

comment:15 Changed 3 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.