Modify

Opened 2 weeks ago

Closed 8 days ago

Last modified 4 days ago

#18355 closed defect (fixed)

JOSM settings: does not remember language

Reported by: anonymous Owned by: Don-vip
Priority: normal Milestone: 19.11
Component: Core Version: latest
Keywords: language preferences regression Cc:

Description

I am trying to set language which is different from my OS language.
Open Settings -> Look and Feel -> Select Language -> Restart -> Open Settings -> Look and Feel -> Language: Default (Auto determined).
And that happens all time.
JSOM version: 15492.
Target language: Ukrainian.
OS language: English.

Attachments (1)

03.gif (947.5 KB) - added by Klumbumbus 12 days ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 2 weeks ago by Klumbumbus

Thanks for your report, however your ticket is incomplete and therefore not helpful in its current form.

Please add all needed information according to this list:

  • The required parts of the Status Report from your JOSM.
  • Describe what behaviour you expected.
  • Describe what did happen instead.
  • Describe if and how the issue is reproducible.
  • Add any relevant information like error messages or screenshots.

To ensure that all technical relevant information is contained, create new tickets by clicking in JOSMs Main Menu on Helpsource:trunk/images/bug.png Report Bug.


comment:2 Changed 2 weeks ago by Don-vip

Owner: changed from team to anonymous
Status: newneedinfo

comment:3 Changed 13 days ago by skyper

Keywords: language preferences added
Owner: changed from anonymous to team
Priority: normalmajor
Status: needinfonew

What steps will reproduce the problem?

  1. open preferences
  2. change language under Display Settings -> Look and Feel (anything but not English) and close preference dialog with "OK".
  3. open preferences
  4. change anything (I checked plus unchecked expert mode) and close preference dialog with "OK".

What is the expected result?

No changes at all in preferences

What happens instead?

  1. a dialog about restart
  2. the language is changed to "Default"

Please provide any additional information below. Attach a screenshot if possible.

  • Did check it with different languages. Only English was not changed.
  • Did try it with different changes in settings. All seem to trigger the bug.
Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-11-24 21:23:35 +0100 (Sun, 24 Nov 2019)
Revision:15541
Build-Date:2019-11-25 02:31:03
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15541 en) Linux Debian GNU/Linux 10 (buster)
Memory Usage: 184 MB / 964 MB (79 MB allocated, but free)
Java version: 11.0.5+10-post-Debian-1deb10u1, Debian, OpenJDK 64-Bit Server VM
Screen: :0.0 1366x768
Maximum Screen Size: 1366x768
Java package: openjdk-11-jre:amd64-11.0.5+10-1~deb10u1
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-22
libcommons-compress-java: libcommons-compress-java:all-1.18-2
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:all-20181227-1
VM arguments: [-Djosm.home=<josm.pref>]

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Region [TMS_BLOCK_v2] Resetting cache
- W: Region [WMS_BLOCK_v2] Resetting cache
- W: Region [WMTS_BLOCK_v2] Resetting cache

comment:4 Changed 13 days ago by Klumbumbus

Keywords: regression added

So it happens when you cancel the restart and reopen preferences before you restart, right?
It seems to be another regression of r15395. It works with josm-snapshot-15390 but not with josm-snapshot-15400, if I didn't tangle up during my tests.

comment:5 in reply to:  4 Changed 13 days ago by skyper

Replying to Klumbumbus:

So it happens when you cancel the restart and reopen preferences before you restart, right?

Yes, but you can also restart. It does not matter.

It seems to be another regression of r15395. It works with josm-snapshot-15390 but not with josm-snapshot-15400, if I didn't tangle up during my tests.

Yes.

comment:6 Changed 13 days ago by Don-vip

Milestone: 19.11
Owner: changed from team to Don-vip
Status: newassigned

comment:7 in reply to:  3 ; Changed 13 days ago by Don-vip

Owner: changed from Don-vip to anonymous
Status: assignedneedinfo

Replying to skyper:

What steps will reproduce the problem?

I tried various languages changes and everything behaves fine. I changed language from French to Asturian, then to Belarusian, then to English. What's wrong? A step is probably missing in your description.

comment:8 Changed 12 days ago by Klumbumbus

This is how I can reproduce. See attachment. (I cropped the part during restart).

Changed 12 days ago by Klumbumbus

Attachment: 03.gif added

comment:9 Changed 12 days ago by Don-vip

Milestone: 19.11
Priority: majorminor

Even using Cancel I don't reproduce. Language changed correctly for every combination I tried.

comment:10 in reply to:  7 Changed 8 days ago by skyper

Owner: changed from anonymous to team
Status: needinfonew

Replying to Don-vip:

Replying to skyper:

What steps will reproduce the problem?

I tried various languages changes and everything behaves fine. I changed language from French to Asturian, then to Belarusian, then to English. What's wrong? A step is probably missing in your description.

I tried to show a short way but that was not a good idea.

  • The language changes if you restart after setting it in preferences but when closing the preferences dialog with "OK", the next time, it will be changed back to "default".
  • a work around is to always use the --language=<> option on start up.

Long version how to reproduce:

What steps will reproduce the problem?

  1. open preferences
  2. change language under Display Settings -> Look and Feel (anything but not English) and close preference dialog with "OK".
  3. click on "restart"
  4. josm starts in previous chosen language
  5. open preferences
  6. close preference dialog with "OK"
  7. click on "restart"

What is the expected result?

after 6. no changes in preferences

What happens instead?

  1. a dialog about restart in 7.
  2. the language is changed to "Default" on next start up

Please provide any additional information below. Attach a screenshot if possible.

My system default language is English and the user language is set to English.

For me, the problem seems to be the language box, which should reflect/show the current language settings but which does always changes to "Default".

comment:11 Changed 8 days ago by Don-vip

Milestone: 19.11
Owner: changed from team to Don-vip
Priority: minornormal
Status: newassigned

OK thank you now I can reproduce.

comment:12 Changed 8 days ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 15547/josm:

fix #18355 - fix regression in determination of locale/country (introduced in r15395)

comment:13 Changed 4 days ago by anonymous

Big thanks for fixing this!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.