Modify

Opened 3 months ago

Closed 3 months ago

#18288 closed defect (duplicate)

InvalidPathException: Malformed input or input contains unmappable characters

Reported by: ccezali@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report linux encoding Cc:

Description

What steps will reproduce the problem?

  1. open a map file
  2. go up folder
  3. open document folder

What is the expected result?

open document directory

What happens instead?

not open the directory instead open bug report pop up

Please provide any additional information below. Attach a screenshot if possible.

Revision:15390
Is-Local-Build:true
Build-Date:2019-10-22 13:26:44

Identification: JOSM/1.5 (15390 SVN en) Linux Ubuntu 18.04.3 LTS
Memory Usage: 172 MB / 954 MB (31 MB allocated, but free)
Java version: 11.0.4+11-post-Ubuntu-1ubuntu218.04.3, Ubuntu, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900
Maximum Screen Size: 1600x900
VM arguments: [-Duser.home=${HOME}]

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: java.nio.file.InvalidPathException: Malformed input or input contains unmappable characters: /home/<user.name>/Documents/k��z��lagac evler.ods
- E: Handled by bug report queue: java.nio.file.InvalidPathException: Malformed input or input contains unmappable characters: /home/<user.name>/Documents/k��z��lagac evler.ods


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: Basic L&F File Loading Thread (71)
java.nio.file.InvalidPathException: Malformed input or input contains unmappable characters: /home/ege/Documents/k��z��lagac evler.ods
	at java.base/sun.nio.fs.UnixPath.encode(UnixPath.java:145)
	at java.base/sun.nio.fs.UnixPath.<init>(UnixPath.java:69)
	at java.base/sun.nio.fs.UnixFileSystem.getPath(UnixFileSystem.java:280)
	at java.base/java.nio.file.Path.of(Path.java:147)
	at java.base/java.nio.file.Paths.get(Paths.java:69)
	at java.desktop/sun.awt.shell.ShellFolder.getShellFolder(ShellFolder.java:247)
	at java.desktop/javax.swing.filechooser.FileSystemView.getFiles(FileSystemView.java:523)
	at java.desktop/javax.swing.plaf.basic.BasicDirectoryModel$FilesLoader.run0(BasicDirectoryModel.java:290)
	at java.desktop/javax.swing.plaf.basic.BasicDirectoryModel$FilesLoader.run(BasicDirectoryModel.java:279)
	at java.base/java.lang.Thread.run(Thread.java:834)

Attachments (1)

Screenshot from 2019-11-02 22-43-12.png (216.2 KB) - added by ccezali@… 3 months ago.
screen shot

Download all attachments as: .zip

Change History (4)

Changed 3 months ago by ccezali@…

screen shot

comment:1 Changed 3 months ago by maarten

What filename does the file /home/ege/Documents/k��z��lagac evler.ods have exactly? (probably special ascii characters but as you can see they get replaced by diamonds with question marks).
I'm guessing Kızılagac evle.ods (turkish i) but I did not get the error.

You're not using the latest version of JOSM. Can you try the latest version and see if the error occurs then too?

comment:2 Changed 3 months ago by Don-vip

Keywords: linux encoding added
Summary: can not change open file directoryInvalidPathException: Malformed input or input contains unmappable characters

comment:3 Changed 3 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14596.
This is usually caused by a bad locale configuration. Check locale and LC_ALL configuration on your system, and #14596 on how to fix the issue.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.