Modify

#18184 closed defect (duplicate)

Custom imagery in JOSM does not display above zoom 22 and can crash with "a unexpected exception occurred"

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core imagery Version:
Keywords: template_report tms zoom Cc:

Description (last modified by Don-vip)

(see https://help.openstreetmap.org/questions/70870/how-to-add-custom-imagery-to-josm for info)

What steps will reproduce the problem?

  1. In imagery preferences, add "tms[24]:https://map.atownsend.org.uk/hot/{zoom}/{x}/{y}.png"
  2. Use that imagery layer, and zoom in to levels 22, 23 and 24.

What is the expected result?

Tiles returned at that zoom level. https://map.atownsend.org.uk will return tiles up to zoom 24.
I control that server, and I'd also expect to see the requests from JOSM for levels 23 and 24.

What happens instead?

instead of the expected request to the server such as this:

(my ip address) - - [29/Sep/2019:19:31:51 +0200] "GET /hot/21/1040840/672594.png HTTP/1.1" 200 433 "-" "JOSM/1.5 (15322 en_GB) Linux Ubuntu 18.04.3 LTS Java/11.0.4"

at zooms 23 and 24 this request is made. At zoom 23, JOSM didn't crash immediately afterwards. At zoom 24, it did (I clicked "report bug" to get here):

(my ip address) - - [29/Sep/2019:19:31:52 +0200] "GET /hot/24/0/0.png HTTP/1.1" 200 432 "-" "JOSM/1.5 (15322 en_GB) Linux Ubuntu 18.04.3 LTS Java/11.0.4"

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-08-26 08:55:27 +0200 (Mon, 26 Aug 2019)
Revision:15322
Build-Date:2019-08-26 06:57:10
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15322 en_GB) Linux Ubuntu 18.04.3 LTS
Memory Usage: 477 MB / 3946 MB (255 MB allocated, but free)
Java version: 11.0.4+11-post-Ubuntu-1ubuntu218.04.3, Ubuntu, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080, :0.1 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-11-jre:amd64-11.0.4+11-1ubuntu2~18.04.3
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-20ubuntu0.1
libcommons-compress-java: libcommons-compress-java:all-1.18-1~18.04
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:all-20171026-2
liboauth-signpost-java: liboauth-signpost-java:-

Plugins:
+ reverter (35084)
+ undelete (34977)

Last errors/warnings:
- W: Update plug-ins - org.openstreetmap.josm.plugins.PluginHandler$UpdatePluginsMessagePanel[,0,0,0x0,invalid,layout=java.awt.GridBagLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]
- W: Invalid plugin main version '0.1.0' in plugin microdata_scraping
- W: Invalid plugin main version '0.1.0' in plugin microdata_scraping
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Region [WMS_BLOCK_v2] Resetting cache
- W: Region [WMTS_BLOCK_v2] Resetting cache
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: tileXYToLatLon returned Coordinate[NaN, NaN]


=== REPORTED CRASH DATA ===
TileCoordinateConverter#getPixelForTile:
 - tileSource: AJT
 - x: 0
 - y: 0
 - zoom: 24

BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
org.openstreetmap.josm.tools.JosmRuntimeException: tileXYToLatLon returned Coordinate[NaN, NaN]
	at org.openstreetmap.josm.gui.layer.imagery.TileCoordinateConverter.getPixelForTile(TileCoordinateConverter.java:87)
	at org.openstreetmap.josm.gui.layer.imagery.TileCoordinateConverter.getPixelForTile(TileCoordinateConverter.java:101)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.paintTileText(AbstractTileSourceLayer.java:1150)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.drawInViewArea(AbstractTileSourceLayer.java:1602)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.access$2600(AbstractTileSourceLayer.java:143)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer$TileSourcePainter.doPaint(AbstractTileSourceLayer.java:1931)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer$TileSourcePainter.paint(AbstractTileSourceLayer.java:1925)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:469)
	at org.openstreetmap.josm.gui.MapView.drawMapContent(MapView.java:584)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:491)
	at java.desktop/javax.swing.JComponent.paintChildren(JComponent.java:907)
	at java.desktop/javax.swing.JComponent.paint(JComponent.java:1083)
	at java.desktop/javax.swing.JComponent.paintToOffscreen(JComponent.java:5255)
	at java.desktop/javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:246)
	at java.desktop/javax.swing.RepaintManager.paint(RepaintManager.java:1323)
	at java.desktop/javax.swing.JComponent._paintImmediately(JComponent.java:5203)
	at java.desktop/javax.swing.JComponent.paintImmediately(JComponent.java:5013)
	at java.desktop/javax.swing.RepaintManager$4.run(RepaintManager.java:865)
	at java.desktop/javax.swing.RepaintManager$4.run(RepaintManager.java:848)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:848)
	at java.desktop/javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:823)
	at java.desktop/javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:772)
	at java.desktop/javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1890)
	at java.desktop/java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:313)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:770)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:740)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

Attachments (0)

Change History (2)

comment:1 Changed 21 months ago by Don-vip

Component: CoreCore imagery
Description: modified (diff)
Keywords: tms zoom added

comment:2 Changed 21 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #18064.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.