Modify

Opened 3 weeks ago

Closed 3 days ago

#18105 closed enhancement (fixed)

Show a notification if no notes can be downloaded

Reported by: anonymous Owned by: Don-vip
Priority: minor Milestone: 19.09
Component: Core notes Version: latest
Keywords: download Cc:

Description

What is the expected result?

Something like an information window would be great, which says nothing can be downloaded and JOSM will return to the front page.

What happens instead?

If you download an area, eg. in the middle of the ocean or only notes where aren't any, JOSM runs the download then returns to the 'front page' without any notification.
This only applies when the editor not opened.

Attachments (1)

18105.png (8.4 KB) - added by Klumbumbus 3 weeks ago.

Download all attachments as: .zip

Change History (13)

Changed 3 weeks ago by Klumbumbus

Attachment: 18105.png added

comment:1 Changed 3 weeks ago by Klumbumbus

I get a notification in the bottom left corner which says that nothing could be downloaded in this area.


comment:2 in reply to:  1 Changed 3 weeks ago by anonymous

Replying to Klumbumbus:

I get a notification in the bottom left corner which says that nothing could be downloaded in this area.

Sorry for the confusion, you are right, this only applies to notes. Please test again only with notes downloading enabled.

comment:3 Changed 3 weeks ago by Don-vip

Component: CoreCore notes
Summary: Show a notification if nothing can be downloadedShow a notification if no notes can be downloaded

comment:4 Changed 3 weeks ago by Don-vip

Keywords: download added
Milestone: 19.09
Owner: changed from team to Don-vip
Status: newassigned

comment:5 Changed 3 weeks ago by Don-vip

Priority: normalminor

comment:6 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 15332/josm:

fix #18105 - Show a notification if no notes can be downloaded

comment:7 Changed 5 days ago by bielebog

With the current change, on every data download that doesn't yield in any notes in the area, JOSM prompts for acknowledgement of the newly introduced notification "No notes found in this area." This is pretty annoying.

The solution could be to have the newly introduced notification configurable.

comment:8 in reply to:  7 Changed 5 days ago by Klumbumbus

Replying to bielebog:

With the current change, on every data download that doesn't yield in any notes in the area, JOSM prompts for acknowledgement of the newly introduced notification "No notes found in this area." This is pretty annoying.

I agree.

The solution could be to have the newly introduced notification configurable.

Or change the notification type to the one shown in comment:1 as then there is no user action required?

comment:9 Changed 5 days ago by Klumbumbus

Resolution: fixed
Status: closedreopened

comment:10 in reply to:  9 Changed 4 days ago by bielebog

Replying to Klumbumbus:

Agreed, this would be more consistent. It could even be extended to GPX data.

comment:11 Changed 4 days ago by anonymous

Replying to Klumbumbus:

Or change the notification type to the one shown in comment:1 as then there is no user action required?

I agree, the current state is annoying and that notification style would be maybe better. Off-topic, but it seems easy to change. The problem is, I couldn't get JOSM source from git to make a patch :/

comment:12 Changed 3 days ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 15358/josm:

fix #18105 - Show a notification if no notes can be downloaded

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.