Modify

Opened 3 weeks ago

Closed 2 weeks ago

#18098 closed defect (fixed)

"Download from OSM" and "Download from Cadastre" dialogs are too similar

Reported by: anonymous Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin cadastre-fr Version:
Keywords: template_report sotmfr2019 Cc:

Description

What steps will reproduce the problem?

  1. Install the "cadastre-fr" plugin
  2. Click download: the regular tab "Download from OSM" and the new tab "Download from Cadastre" look very similar

What is the expected result?

The two tabs should be easily distinguishable.

What happens instead?

I often make the mistake of downloading Cadastre data while I actually want to download OSM data. Since I download such data in the current layer, it completely messes up the data I am working on.

Here is the workflow that leads to this mistake:

  • download some data from OSM
  • download data for the same area from the Cadastre, as a new layer
  • work on the data, possibly copy some objects from the cadastre layer, etc
  • I need to load a new adjacent area from OSM
  • click on Download in the main JOSM interface
  • fail to notice that the active tab is still "Download from Cadastre"
  • use the slippy map to select the new area, click "Download"
  • MISTAKE: the cadastre data gets imported in the current layer, while I wanted OSM data instead

What could be done to improve the situation?

I see several possibilities:

  • make sure that the two tabs are visually very different (for instance on the slippy map: different tiles, or provide a selection rectangle with a different colour)
  • always show the first tab "Download from OSM" when clicking on the Download button in the main JOSM interface

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-07-10 00:52:47 +0200 (Wed, 10 Jul 2019)
Build-Date:2019-07-10 01:30:51
Revision:15238
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15238 fr) Linux Arch Linux
Memory Usage: 452 MB / 869 MB (342 MB allocated, but free)
Java version: 1.8.0_222-b05, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1280x800
Maximum Screen Size: 1280x800
VM arguments: [-Djosm.restart=true]

Plugins:
+ apache-commons (34908)
+ cadastre-fr (34977)
+ ejml (35049)
+ geotools (34908)
+ jts (35064)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (1)

cadastre_color.png (154.0 KB) - added by Don-vip 2 weeks ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 3 weeks ago by Don-vip

Keywords: sotmfr2019 added
Status: newassigned

comment:2 Changed 3 weeks ago by skyper

Ii it really useful to load cadastre into normal data layer ?

Would a different/own layer type for cadastre help ?

comment:3 Changed 3 weeks ago by anonymous

Currently the "Download from Cadastre" dialog has two buttons, exactly like the regular download dialog: "Download" or "Download as a new layer".

It may be useful to load cadastre data in the data layer, I don't know.

But even if the cadastre download always used a new layer by default, the confusion between the two dialogs would still happen. It would be less annoying but still annoying (especially because downloading cadastre data may take a lot of time/bandwidth and cancelling doesn't always work immediately).

Changed 2 weeks ago by Don-vip

Attachment: cadastre_color.png added

comment:4 Changed 2 weeks ago by Don-vip

Here you go:


comment:5 Changed 2 weeks ago by Don-vip

Resolution: fixed
Status: assignedclosed

Fixed in [o35106:35107].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.