Modify

Opened 4 weeks ago

Closed 4 weeks ago

Last modified 2 weeks ago

#18079 closed defect (invalid)

Abkhaz character Ҟ. Tag value contains non-printing character - Tag 'name:ab' invalid.

Reported by: Mazda05 Owned by: Mazda05
Priority: minor Milestone:
Component: Core validator Version: latest
Keywords: abkhaz unicode Cc:

Description

What steps will reproduce the problem?

Adding charater Ҟ to name:ab (Unicode 049E)

What is the expected result?

https://en.wikipedia.org/wiki/Abkhaz_alphabet
Letter Ҟ ҟ

What happens instead?

Validation Results: Warning «Tag value contains non-printing character - Tag 'name:ab' invalid.»

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-07-10 00:52:47 +0200 (Wed, 10 Jul 2019)
Build-Date:2019-07-10 01:30:51
Revision:15238
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15238 en) Windows 7 64-Bit
OS Build number: Windows 7 Ultimate (7601)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Attachments (0)

Change History (9)

comment:1 Changed 4 weeks ago by Klumbumbus

Component: CoreCore validator

comment:2 Changed 4 weeks ago by Don-vip

Keywords: unicode added
Milestone: 19.08
Owner: changed from team to Don-vip
Status: newassigned

comment:3 Changed 4 weeks ago by Don-vip

Owner: changed from Don-vip to Mazda05
Status: assignedneedinfo

I can't reproduce with just the letter Ҟ.
Can you please share an .osm file showing the problem?

comment:4 Changed 4 weeks ago by Don-vip

Milestone: 19.0819.09

Ticket retargeted after milestone closed

comment:5 Changed 4 weeks ago by Mazda05

Resolution: invalid
Status: needinfoclosed

The warning no longer appears, the ticket may be closed

comment:6 Changed 4 weeks ago by stoecker

Very likely you did copy an invalid character, some hidden invisible one. The warning is exactly for such cases.

comment:7 Changed 4 weeks ago by Klumbumbus

Milestone: 19.09

comment:8 Changed 2 weeks ago by anonymous

Maybe it would be useful to mention that nonprinting character can be invisible?

comment:9 Changed 2 weeks ago by stoecker

In 15337/josm:

see #18079 - make a bit more obvious, that you don't see non-printing characters

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Mazda05.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.