Modify

Opened 2 years ago

Closed 2 years ago

#17996 closed defect (wontfix)

NoClassDefFoundError: javafx/embed/swing/JFXPanel - on start and when downloading images

Reported by: anticompositenumber@… Owned by: vodryc
Priority: major Milestone:
Component: Plugin MicrosoftStreetside Version:
Keywords: template_report javafx Cc:

Description

What steps will reproduce the problem?

  1. Install the Microsoft Streetside plugin
  2. Restart JOSM
  3. The plugin has an error.
  4. After disabling or updating the plugin or ignoring the error, JOSM throws an unexpected exception.
  5. Ignore that as well, try to download images.
  6. Open the Streetside window and press Shift + Comma to download images
  7. Another exception is thrown and no images are downloaded.

What is the expected result?

Images are downloaded from Streetside and displayed on the map

What happens instead?

The plugin crashes

Please provide any additional information below. Attach a screenshot if possible.

Began happening on 15155, continues in 15262 (from SVN, as the Arch repo package is out of date)

Build-Date:2019-07-28 18:57:17
Revision:15262
Is-Local-Build:true

Identification: JOSM/1.5 (15262 SVN en) Linux Arch Linux
Memory Usage: 947 MB / 1716 MB (529 MB allocated, but free)
Java version: 1.8.0_222-b05, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080, :0.1 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ Create_grid_of_ways (34908)
+ FastDraw (34977)
+ HouseNumberTaggingTool (34977)
+ Mapillary (1.5.18)
+ MicrosoftStreetside (34977)
+ OpeningHoursEditor (34977)
+ RoadSigns (UNKNOWN)
+ ShapeTools (1240)
+ apache-commons (34908)
+ apache-http (34908)
+ auto_tools (73)
+ buildings_tools (34982)
+ changeset-viewer (22)
+ continuosDownload (82)
+ editgpx (34908)
+ gridify (1556174547)
+ javafx-unixoid
+ jna (34908)
+ measurement (35051)
+ openqa (1557250801)
+ print (34972)
+ tageditor (34977)
+ todo (30306)
+ touchscreenhelper (34908)
+ turnlanes-tagging (281)
+ turnrestrictions (34977)
+ utilsplugin2 (34977)
+ wikipedia (v1.1.1)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-stops&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/US.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-highways&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ ${HOME}/Documents/Presets_Golf_Course.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Telecom&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Enhanced_Lane_and_Road_Attributes&zip=1
- https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs_AME.zip
+ https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1

Last errors/warnings:
- W: Plugin javafx-unixoid requires Java version 10. The current Java version is 8. You have to update Java in order to use this plugin.
- W: Unable to decode URL data part: Illegal base64 character 25 (iVBORw0KGgoAAAANSUhEUgAAADAAAAAhCAYAAACfiCi5AAAABHNCSVQICAgIfAhkiAAAAAlwSFlzAAAE0gAABNIB9duA0gAAABl0RVh0U29mdHdhcmUAd3d3Lmlua3NjYXBlLm9yZ5vuPBoAAAWJSURBVFjD7VhrbBRVFL4YIIJIRCQ%2Bfgg%2BEA0KaAOxEZuZfc1QrOJj7c6ABeWhRpoGfIARw9qdO9uCvDSk1GAwYKjxhyREFDU8fPwwBB8QfEQk8EMRTAUTIBDQrt89d3Z2Znd22S6B2KSTfLk7954553znNdMyFrOfZTpvJ8R4ggVdMT4HWMNql1zn7tU234W91UyzdzDN%2BhjPL2eT0ne75%2BJ3Vm8WGm8DmiE%2Fl0Xt%2B1gyeRk731WXHAg7TxUX0HgDkCHEeDRQRrefxvnvHkKLcf8PyK%2BCMw8x3ZqP%2B4PAkZze5NWuXo1vBxZAfiEIr8Az3zv7R6CrkSnJvkX9EwHW%2BKHiMrpleAypRQjMJAfJMWsCfnfBcIdP5sHWK7G3M5eB5GCPXitAZy32O2XgrC1w8PIiBPaSjG4%2FUjkBkUKdH%2FBEX8i2FGazZWzZBMh2ejzOzkkHUWL5VzQd8%2Bj4vHICmv0kzvb7CVh%2FMD01qmjqyyEg9a1xZERW7%2FT7xjdj%2F2dXT5SPuxACv0jHrHs98qdxtgzr9RUT0Hk4J2e15p5P3YK9k6zWvg3rGUdmXYU9wGdQJHJRsz3PZBwDbdS43SUgyGfldHubJ2gr0BtrHXsdrp0wv7aCHrCn4%2BzHPMOP02TyEUFZRVJ3dItAVXs%2Fj9yX7kDQ%2BN%2FUI2TfqvHIvFpBCYlRa%2B8r2I8vH4CzJuBwQRTLJRBpudEzxjc4EW%2FE%2FXeB00jYiif7e5soUR4BvqeoE2F7KJ1LHf%2BSgbKb2Kr3yJmMZfrIxrW%2B9b8E3XeHGLtTvQSiuehZDxdp4pfcGa81jy5RZlKPkhxUfg%2BINznJ%2FCrLKa3j9wl68RXiuCO7i%2BW9MWWXizdrcAY%2BpWkjf1uU9qDPDan8p7JLKMbnudNMTDep%2FyNE%2B60iw%2BQNT6lWex20nIOT1DB%2B52eRgWhqpNMzS2V60yNyE8ceRj0iZnn2jVmKgM7HQMd6kqfPCcemsCFKMJauCu4XDAj5DHTa73lOUHc6f9lJXRc5qPGtNPs1%2Byi99nOl8gClW5DV%2BCYH4pPgGPVKUHPKJt%2FtkOx0HNgHvYuIaNYHzd5Ik6zUJb6LpM6zvje%2FdG7pFfL1bc%2BWQFMHfqPAmIiSnGBNIDWF6t571VrDmZaK%2BBBLhSj6ImP51%2BT0EFdOjNGgi8arR1%2B27Hr2lQg9wwx1G7CFGaENzFRXsYSyWO6Ho8yM3MwUpe9Fsd0QHsoM5XZgIjAFNmdjfQVrC0uo7fDpHeB9%2BPQJ1s8ICWUX1t0SeAaCzbjJAGeAY8AJ596Ls5Dbj%2FVDImeqGosrg87roDlxCGSrmBmKM1NZQMERDgnjpnoqwE73YCoz8TatHsDi8f6FfwnVDZQOhIazacqtWCeAsY4sGSDxHKL0AkiF6XmRofrQPRTBhPImlO8A%2Fgoweg74DTr2Yt0JfR9Ax1r8XoK9hTID6qNwLCIhyAP16liqBFqdPQFDuYbBcAwPv04po7SFOpwoCbwNRW3Yn4f9kHxAfEIg%2Bgl1Ms5bsfdFXjSPAl8DGyHDcT6LiD5Rc1O3SnHqpMEsfv8wctwIj%2FE57iOQK6HDTp2thrONVCZmzUg3OyLCZigJ%2Ba%2BopCT2QG49FD1PToqaDvy7FtkUtS5kDGU6Ir0INlbi%2BXeBrdDxDdYDlLXulBaV0DR1FNI%2BItCwEa6G4DLgoJP6DpCYS2Tyy26GchWrD4%2BHkyZkX3MyKZqt84JrvSSBgi9MpE1E1FC2I1LrEJEGSr9vckVvgIN1TmMiA%2BoPQNdFc7QsAiLFIrqG%2BiJFmLE%2BtC%2F%2B9WEq44AmOL0J539eckdLEphT1Y%2BmjLeMRO0b6nyQ2oz1%2BP%2FG4dIZUEdTk8q6zfQIEIGE8hhuDvUYpwsJuGO0l0AvgV4CvQQuPYH%2FAFdZYQlsjq3yAAAAAElFTkSuQmCC): java.lang.IllegalArgumentException: Illegal base64 character 25
- E: Failed to locate image 'data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAADAAAAAhCAYAAACfiCi5AAAABHNCSVQICAgIfAhkiAAAAAlwSFlzAAAE0gAABNIB9duA0gAAABl0RVh0U29mdHdhcmUAd3d3Lmlua3NjYXBlLm9yZ5vuPBoAAAWJSURBVFjD7VhrbBRVFL4YIIJIRCQ%2Bfgg%2BEA0KaAOxEZuZfc1QrOJj7c6ABeWhRpoGfIARw9qdO9uCvDSk1GAwYKjxhyREFDU8fPwwBB8QfEQk8EMRTAUTIBDQrt89d3Z2Znd22S6B2KSTfLk7954553znNdMyFrOfZTpvJ8R4ggVdMT4HWMNql1zn7tU234W91UyzdzDN%2BhjPL2eT0ne75%2BJ3Vm8WGm8DmiE%2Fl0Xt%2B1gyeRk731WXHAg7TxUX0HgDkCHEeDRQRrefxvnvHkKLcf8PyK%2BCMw8x3ZqP%2B4PAkZze5NWuXo1vBxZAfiEIr8Az3zv7R6CrkSnJvkX9EwHW%2BKHiMrpleAypRQjMJAfJMWsCfnfBcIdP5sHWK7G3M5eB5GCPXitAZy32O2XgrC1w8PIiBPaSjG4%2FUjkBkUKdH%2FBEX8i2FGazZWzZBMh2ejzOzkkHUWL5VzQd8%2Bj4vHICmv0kzvb7CVh%2FMD01qmjqyyEg9a1xZERW7%2FT7xjdj%2F2dXT5SPuxACv0jHrHs98qdxtgzr9RUT0Hk4J2e15p5P3YK9k6zWvg3rGUdmXYU9wGdQJHJRsz3PZBwDbdS43SUgyGfldHubJ2gr0BtrHXsdrp0wv7aCHrCn4%2BzHPMOP02TyEUFZRVJ3dItAVXs%2Fj9yX7kDQ%2BN%2FUI2TfqvHIvFpBCYlRa%2B8r2I8vH4CzJuBwQRTLJRBpudEzxjc4EW%2FE%2FXeB00jYiif7e5soUR4BvqeoE2F7KJ1LHf%2BSgbKb2Kr3yJmMZfrIxrW%2B9b8E3XeHGLtTvQSiuehZDxdp4pfcGa81jy5RZlKPkhxUfg%2BINznJ%2FCrLKa3j9wl68RXiuCO7i%2BW9MWWXizdrcAY%2BpWkjf1uU9qDPDan8p7JLKMbnudNMTDep%2FyNE%2B60iw%2BQNT6lWex20nIOT1DB%2B52eRgWhqpNMzS2V60yNyE8ceRj0iZnn2jVmKgM7HQMd6kqfPCcemsCFKMJauCu4XDAj5DHTa73lOUHc6f9lJXRc5qPGtNPs1%2Byi99nOl8gClW5DV%2BCYH4pPgGPVKUHPKJt%2FtkOx0HNgHvYuIaNYHzd5Ik6zUJb6LpM6zvje%2FdG7pFfL1bc%2BWQFMHfqPAmIiSnGBNIDWF6t571VrDmZaK%2BBBLhSj6ImP51%2BT0EFdOjNGgi8arR1%2B27Hr2lQg9wwx1G7CFGaENzFRXsYSyWO6Ho8yM3MwUpe9Fsd0QHsoM5XZgIjAFNmdjfQVrC0uo7fDpHeB9%2BPQJ1s8ICWUX1t0SeAaCzbjJAGeAY8AJ596Ls5Dbj%2FVDImeqGosrg87roDlxCGSrmBmKM1NZQMERDgnjpnoqwE73YCoz8TatHsDi8f6FfwnVDZQOhIazacqtWCeAsY4sGSDxHKL0AkiF6XmRofrQPRTBhPImlO8A%2Fgoweg74DTr2Yt0JfR9Ax1r8XoK9hTID6qNwLCIhyAP16liqBFqdPQFDuYbBcAwPv04po7SFOpwoCbwNRW3Yn4f9kHxAfEIg%2Bgl1Ms5bsfdFXjSPAl8DGyHDcT6LiD5Rc1O3SnHqpMEsfv8wctwIj%2FE57iOQK6HDTp2thrONVCZmzUg3OyLCZigJ%2Ba%2BopCT2QG49FD1PToqaDvy7FtkUtS5kDGU6Ir0INlbi%2BXeBrdDxDdYDlLXulBaV0DR1FNI%2BItCwEa6G4DLgoJP6DpCYS2Tyy26GchWrD4%2BHkyZkX3MyKZqt84JrvSSBgi9MpE1E1FC2I1LrEJEGSr9vckVvgIN1TmMiA%2BoPQNdFc7QsAiLFIrqG%2BiJFmLE%2BtC%2F%2B9WEq44AmOL0J539eckdLEphT1Y%2BmjLeMRO0b6nyQ2oz1%2BP%2FG4dIZUEdTk8q6zfQIEIGE8hhuDvUYpwsJuGO0l0AvgV4CvQQuPYH%2FAFdZYQlsjq3yAAAAAElFTkSuQmCC'
- E: unable to find dependency javafx for plugin MicrosoftStreetside
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin MicrosoftStreetside. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.NoClassDefFoundError: javafx/embed/swing/JFXPanel. Cause: java.lang.ClassNotFoundException: javafx.embed.swing.JFXPanel
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: javafx/embed/swing/JFXPanel. Cause: java.lang.ClassNotFoundException: javafx.embed.swing.JFXPanel


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.NoClassDefFoundError: javafx/embed/swing/JFXPanel
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:468)
	at java.net.URLClassLoader.access$100(URLClassLoader.java:74)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:369)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:363)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:362)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:73)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	at org.openstreetmap.josm.plugins.streetside.gui.StreetsideViewerDialog.<init>(StreetsideViewerDialog.java:35)
	at org.openstreetmap.josm.plugins.streetside.gui.StreetsideViewerDialog.getInstance(StreetsideViewerDialog.java:46)
	at org.openstreetmap.josm.plugins.streetside.StreetsideData.<init>(StreetsideData.java:65)
	at org.openstreetmap.josm.plugins.streetside.StreetsideLayer.<init>(StreetsideLayer.java:93)
	at org.openstreetmap.josm.plugins.streetside.StreetsideLayer.getInstance(StreetsideLayer.java:167)
	at org.openstreetmap.josm.plugins.streetside.actions.StreetsideDownloadAction.actionPerformed(StreetsideDownloadAction.java:52)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1668)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2882)
	at javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:307)
	at javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:263)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2974)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2966)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2845)
	at java.awt.Component.processEvent(Component.java:6316)
	at java.awt.Container.processEvent(Container.java:2239)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2297)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1954)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:834)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1102)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:973)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:799)
	at java.awt.Component.dispatchEventImpl(Component.java:4760)
	at java.awt.Container.dispatchEventImpl(Container.java:2297)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:760)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:84)
	at java.awt.EventQueue$4.run(EventQueue.java:733)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:730)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Caused by: java.lang.ClassNotFoundException: javafx.embed.swing.JFXPanel
	at java.net.URLClassLoader.findClass(URLClassLoader.java:382)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:73)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 57 more

Attachments (0)

Change History (4)

comment:1 Changed 2 years ago by anticompositenumber@…

I installed java8-openjfx from the Arch repos and the plugin now works.

comment:2 Changed 2 years ago by skyper

Keywords: javafx added
Priority: normalmajor

Plugin should depend on javafx plugin

comment:3 Changed 2 years ago by Don-vip

Summary: Microsoft Streetside plugin throws an exception on start and when downloading images.NoClassDefFoundError: javafx/embed/swing/JFXPanel - on start and when downloading images

comment:4 Changed 2 years ago by Don-vip

Resolution: wontfix
Status: newclosed

JavaFX is a separate package with Java 8. The Java FX JOSM plugin ships JavaFX 11 which requires Java 11. So either native javafx binaries must be installed with java 8 (as you did) or JOSM must be run with Java 11.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain vodryc.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.