Modify

Opened 4 weeks ago

Closed 3 weeks ago

Last modified 12 days ago

#17977 closed enhancement (fixed)

public_transport=platform icon looks like an execution scaffold

Reported by: mkoniecz Owned by: team
Priority: minor Milestone: 19.08
Component: Internal mappaint style Version:
Keywords: template_report Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Map in area using more complicated bus stop schema
  2. Notice highway=bus_stop tagged also with public_transport=platform
  3. Become confused why someone mapped execution scaffold here

What is the expected result?

Things that are not execution scaffold does not look like them.

What happens instead?

I repeatedly confused bus stop icon with execution scaffold.

Please provide any additional information below. Attach a screenshot if possible.

Maybe give highway=bus_stop icon priority over public_transport=platform icon?

Or maybe remove roof from icon?


URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-07-17 21:59:54 +0200 (Wed, 17 Jul 2019)
Build-Date:2019-07-18 01:30:57
Revision:15255
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15255 en) Linux Ubuntu 16.04.6 LTS
Memory Usage: 713 MB / 869 MB (407 MB allocated, but free)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
libcommons-logging-java: libcommons-logging-java:all-1.2-1+build1
fonts-noto: fonts-noto:-
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34977)
+ PicLayer (35030)
+ buildings_tools (34982)
+ continuosDownload (82)
+ ejml (35049)
+ geotools (34908)
+ imagery_offset_db (34908)
+ jts (35064)
+ log4j (34908)
+ measurement (35051)
+ reverter (34999)
+ todo (30306)

Validator rules:
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/deprecated.mapcss
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/unnecessary.mapcss
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/combinations.mapcss

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (2)

Selection_001.png (175.8 KB) - added by mkoniecz 4 weeks ago.
scaffold.png (581 bytes) - added by Klumbumbus 3 weeks ago.

Download all attachments as: .zip

Change History (12)

Changed 4 weeks ago by mkoniecz

Attachment: Selection_001.png added

comment:1 Changed 4 weeks ago by mkoniecz

Description: modified (diff)

comment:2 Changed 4 weeks ago by skyper

+1 for changing the icon

-1 for a higher priority of bus_stop

comment:3 Changed 4 weeks ago by Klumbumbus

Component: Core mappaintInternal mappaint style

comment:4 Changed 3 weeks ago by Don-vip

Description: modified (diff)

comment:5 Changed 3 weeks ago by Don-vip

Description: modified (diff)

comment:6 Changed 3 weeks ago by Klumbumbus

I tried with adding glass walls on the sides of the shelter. However I guess the next ticket from you would be "public_transport=platform icon looks like an device to beam someone" ;) So I had no better idea than removing the shelter and making the platform a bit lighter that it is still a bit visible on black background.

Changed 3 weeks ago by Klumbumbus

Attachment: scaffold.png added

comment:7 Changed 3 weeks ago by Klumbumbus

Milestone: 19.08

comment:8 Changed 3 weeks ago by Don-vip

Second one could be someone taking a shower :)

comment:9 Changed 3 weeks ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 15274/josm:

  • fix #17977 - new public_transport=platform icon
  • ignore mapillary=*

comment:10 Changed 12 days ago by mkoniecz

Thanks for a new icon!

Second one could be someone taking a shower :)

Or an entrance to a building.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.