Modify

Opened 6 days ago

Closed 6 days ago

Last modified 5 days ago

#17913 closed defect (duplicate)

IAE: Invalid number of points in LinearRing (found 3 - must be 0 or >= 4)

Reported by: anonymous Owned by: Tyndare
Priority: normal Milestone:
Component: Plugin jts Version:
Keywords: template_report jts Cc:

Description

What steps will reproduce the problem?

  1. Ouverture JOSM à partir du site https://cadastre.damsy.net/#12/47.2445/3.3759
  2. application du script segmented.js.txt et modifications
  3. application du script conflation.js.txt

What is the expected result?

réaliser des conflations

What happens instead?

erreur mise à jour du greffon jts (obsolete)

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-07-09 01:01:06 +0200 (Tue, 09 Jul 2019)
Build-Date:2019-07-08 23:02:00
Revision:15237
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15237 fr) Windows 10 64-Bit
OS Build number: Windows 10 Home 1809 (17763)
Memory Usage: 685 MB / 989 MB (245 MB allocated, but free)
Java version: 1.8.0_211-b12, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ Mapillary (1.5.18)
+ OpenStreetCam (245)
+ RoadSigns (UNKNOWN)
+ apache-commons (34908)
+ apache-http (34908)
+ cadastre-fr (34977)
+ conflation (0.6.3)
+ ejml (35049)
+ geojson (124)
+ geotools (34908)
+ imagery_offset_db (34908)
+ jna (34908)
+ jts (34908)
+ scripting (30795)
+ todo (30306)
+ turnrestrictions (34977)
+ utilsplugin2 (34977)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Invalid number of points in LinearRing (found 3 - must be 0 or >= 4)


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (15) of main
java.lang.IllegalArgumentException: Invalid number of points in LinearRing (found 3 - must be 0 or >= 4)
	at com.vividsolutions.jts.geom.LinearRing.validateConstruction(LinearRing.java:114)
	at com.vividsolutions.jts.geom.LinearRing.<init>(LinearRing.java:106)
	at org.openstreetmap.josm.plugins.jts.JTSConverter.convertWay(JTSConverter.java:94)
	at org.openstreetmap.josm.plugins.jts.JTSConverter.convert(JTSConverter.java:105)
	at org.openstreetmap.josm.plugins.conflation.OsmFeature.<init>(OsmFeature.java:37)
	at org.openstreetmap.josm.plugins.conflation.MatchesComputation.createFeatureCollection(MatchesComputation.java:119)
	at org.openstreetmap.josm.plugins.conflation.MatchesComputation.generateMatches(MatchesComputation.java:48)
	at org.openstreetmap.josm.plugins.conflation.ConflationToggleDialog$2.realRun(ConflationToggleDialog.java:1147)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:94)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:142)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (4)

comment:1 Changed 6 days ago by anonymous

Component: CorePlugin conflation
Owner: changed from team to Tyndare

comment:2 Changed 6 days ago by Don-vip

Keywords: jts added
Summary: Plantage greffon jtsIAE: Invalid number of points in LinearRing (found 3 - must be 0 or >= 4)

comment:3 Changed 6 days ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14650.

comment:4 Changed 5 days ago by skyper

Component: Plugin conflationPlugin jts

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Tyndare.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.