Modify

Opened 6 weeks ago

Closed 6 weeks ago

#17889 closed defect (duplicate)

IOOBE at MemberTableModel.getSelectedMembers

Reported by: dolomynum@… Owned by: Don-vip
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report relation regression Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. remove an element from a walking route

What is the expected result?

the element is removed from the list

What happens instead?

ugly popup, I hope I didn't lose all my work until now :(

Please provide any additional information below. Attach a screenshot if possible.

Null

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-07-08 01:14:04 +0200 (Mon, 08 Jul 2019)
Build-Date:2019-07-07 23:17:09
Revision:15234
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15234 en) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 1903 (18362)
Memory Usage: 488 MB / 989 MB (110 MB allocated, but free)
Java version: 1.8.0_211-b12, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 3440x1440
Maximum Screen Size: 3440x1440
Dataset consistency test: No problems found

Plugins:
+ reverter (34999)
+ turnrestrictions (34977)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: java.lang.IndexOutOfBoundsException: Index: 24, Size: 24


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (15) of main
java.lang.IndexOutOfBoundsException: Index: 24, Size: 24
	at java.util.ArrayList.rangeCheck(Unknown Source)
	at java.util.ArrayList.get(Unknown Source)
	at org.openstreetmap.josm.gui.dialogs.relation.MemberTableModel.getSelectedMembers(MemberTableModel.java:535)
	at org.openstreetmap.josm.gui.dialogs.relation.MemberTableModel.hasIncompleteSelectedMembers(MemberTableModel.java:422)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.DownloadSelectedIncompleteMembersAction.updateEnabledState(DownloadSelectedIncompleteMembersAction.java:46)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.AbstractRelationEditorAction.tableChanged(AbstractRelationEditorAction.java:76)
	at javax.swing.table.AbstractTableModel.fireTableChanged(Unknown Source)
	at javax.swing.table.AbstractTableModel.fireTableDataChanged(Unknown Source)
	at org.openstreetmap.josm.gui.dialogs.relation.MemberTableModel.remove(MemberTableModel.java:307)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.RemoveAction.actionPerformed(RemoveAction.java:36)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (1)

fw3v434g34.png (190.4 KB) - added by dolomynum@… 6 weeks ago.
Null

Download all attachments as: .zip

Change History (7)

Changed 6 weeks ago by dolomynum@…

Attachment: fw3v434g34.png added

Null

comment:1 Changed 6 weeks ago by Don-vip

Description: modified (diff)

comment:2 Changed 6 weeks ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

comment:3 Changed 6 weeks ago by Don-vip

Keywords: relation regression added
Milestone: 19.06
Summary: Some popupIOOBE at MemberTableModel.getSelectedMembers

hotfix required

comment:4 in reply to:  3 Changed 6 weeks ago by Klumbumbus

Replying to Don-vip:

hotfix required

#17887 sounds similar

comment:5 Changed 6 weeks ago by Klumbumbus

Ticket #17890 has been marked as a duplicate of this ticket.

comment:6 Changed 6 weeks ago by Don-vip

Milestone: 19.06
Resolution: duplicate
Status: assignedclosed

Closed as duplicate of #17887.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.