Modify

#17841 closed enhancement (wontfix)

Validator: expand "building:part used on a node" warning to other keys

Reported by: bagage Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: template_report building Cc:

Description

What steps will reproduce the problem?

  1. Add building=yes on a node
  2. Run validator

What is the expected result?

A warning should be raised "building key should not be used on node", similar to "building:part".

What happens instead?

No warning generated.

The wiki explains, for each key, on which object it could be applied. (node/way/area/relation). See for instance building:part.

It would be great if JOSM could generate warning for all keys, based on wiki values.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-06-03 00:05:30 +0200 (Mon, 03 Jun 2019)
Build-Date:2019-06-02 22:10:24
Revision:15155
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15155 fr) Linux Debian GNU/Linux 10 (buster)
Memory Usage: 840 MB / 4436 MB (426 MB allocated, but free)
Java version: 1.8.0_212-8u212-b03-2-b03, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u212-b03-2
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-22

Plugins:
+ AddrInterpolation (34908)
+ HouseNumberTaggingTool (34977)
+ OpeningHoursEditor (34977)
+ PicLayer (35030)
+ apache-commons (34908)
+ buildings_tools (34982)
+ cadastre-fr (34977)
+ conflation (0.6.3)
+ ejml (34908)
+ geotools (34908)
+ jts (34908)
+ poly (34991)
+ reverter (34999)
+ scripting (30794)
+ terracer (34977)
+ todo (30306)
+ utilsplugin2 (34977)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Cannot start IPv4 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect
- W: Cannot start IPv6 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect

Attachments (0)

Change History (5)

comment:1 Changed 10 months ago by bagage

Oops, my bad for building key: actually on the English page it is allowed for nodes, while on the French page it is not. I'll investigate that issue separately.

In the mean time, I don't know how the validator rules are computed. For instance landuse seems to be allowed on nodes (for English version only) but not in JOSM. Seems to be quite a mess actually :D

comment:2 Changed 10 months ago by Don-vip

osmwiki:Key:building states:

Note about using this tag on nodes : although buildings are better represented with their footprints (a closed way or a multipolygon relation), OSM is working by iteration and some areas in the world don't have good aerial imagery or public datasets offering building footprints. Therefore, buildings on nodes should be tolerated until better sources are available.

comment:3 Changed 10 months ago by Don-vip

Keywords: building added

comment:4 Changed 10 months ago by bagage

Regarding buildings, I'll update all pages to match the English one then. Thanks for the quote @Don-vip!

comment:5 Changed 10 months ago by Don-vip

Resolution: wontfix
Status: newclosed

Thanks. I have created #17842 for a more general approach.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.