Modify

Opened 10 years ago

Closed 10 years ago

#1784 closed defect (fixed)

Undocking agpifo picture view from the sidebar into separate window causes hang

Reported by: morinox@… Owned by: morinox@…
Priority: major Milestone:
Component: unspecified Version:
Keywords: agpifo hang Cc:

Description

Undocking the agpifo picture view from the sidebar into separate window
by clicking the 'pin'-icon causes JOSM to hang for a while. During this
time, the picture view is drawn as before in the sidebar and additionally
obviously at coordinates 0,0 wihout a frame border. No reactions to user
interactions occur until eventually the situation is recovered and a requester
stating a software issue pops up woth the following stack trace:

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1065
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1065
Last Changed Date: 2008-11-02 15:06:01 +0100 (Sun, 02 Nov 2008)

java.lang.NullPointerException

at java.awt.Component$BltBufferStrategy.revalidate(Unknown Source)
at java.awt.Component$BltBufferStrategy.revalidate(Unknown Source)
at java.awt.Component$BltBufferStrategy.getDrawGraphics(Unknown Source)
at javax.swing.BufferStrategyPaintManager.prepare(Unknown Source)
at javax.swing.BufferStrategyPaintManager.paint(Unknown Source)
at javax.swing.RepaintManager.paint(Unknown Source)
at javax.swing.JComponent._paintImmediately(Unknown Source)
at javax.swing.JComponent.paintImmediately(Unknown Source)
at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
at javax.swing.RepaintManager.seqPaintDirtyRegions(Unknown Source)
at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by stoecker

Owner: changed from framm to Christian Gallioz <christian.gallioz@…>

comment:2 Changed 10 years ago by xeen

Owner: changed from Christian Gallioz <christian.gallioz@…> to morinox@…
Status: newneedinfo

Works for me using the latest version. Can you still reproduce? If so, would you kindly post the updated stack trace?

comment:3 in reply to:  2 Changed 10 years ago by morinox@…

Resolution: fixed
Status: needinfoclosed

I can't reproduce this defect anymore with JOSM 1460.
Seems to be fixed.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain morinox@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.