Modify

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#17823 closed enhancement (fixed)

Centimeter resolution for length mesurement

Reported by: StephaneP Owned by: Don-vip
Priority: minor Milestone: 19.06
Component: Core Version:
Keywords: lenght sotmfr2019 Cc:

Description (last modified by StephaneP)

Hi!

In the current Josm releases, the lenght mesurement resolution is only 10cm. Is it possible to have a 1 centimeter resolution ?


Attachments (1)

josm_length.jpg (5.7 KB) - added by StephaneP 2 months ago.

Download all attachments as: .zip

Change History (12)

Changed 2 months ago by StephaneP

Attachment: josm_length.jpg added

comment:1 Changed 2 months ago by StephaneP

Description: modified (diff)
Priority: normalminor

comment:2 Changed 2 months ago by Don-vip

Keywords: sotmfr2019 added
Owner: changed from team to Don-vip
Status: newassigned

comment:3 Changed 2 months ago by Klumbumbus

There is a key in the advanced preferences to adjust this, but it might be a good idea to change the default value.

comment:4 Changed 2 months ago by Don-vip

Milestone: 19.06

comment:5 in reply to:  3 Changed 2 months ago by StephaneP

Replying to Klumbumbus:

There is a key in the advanced preferences to adjust this, but it might be a good idea to change the default value.

I had tried to find out a preference setting, but without success. Which pref is it?

Last edited 2 months ago by StephaneP (previous) (diff)

comment:6 Changed 2 months ago by Klumbumbus

statusbar.decimal-format I use 0.00. changing needs a josm restart iirc.

comment:7 Changed 2 months ago by Klumbumbus

There are also latlon.dm.decimal-format and latlon.dms.decimal-format where I'm not sure atm where they take effect.

comment:8 in reply to:  6 Changed 2 months ago by StephaneP

Replying to Klumbumbus:

statusbar.decimal-format I use 0.00. changing needs a josm restart iirc.

Thank you!!

comment:9 Changed 2 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 15185/josm:

fix #17823 - increase statusbar.decimal-format precision, for those crazy cartographers who do high-precision mapping

comment:10 in reply to:  9 Changed 2 months ago by Klumbumbus

Replying to Don-vip:

for those crazy cartographers who do high-precision mapping

... and for those little less crazy ones when the unit changes to km :)

comment:11 Changed 2 months ago by Klumbumbus

Ticket #17637 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.