Modify

Opened 2 years ago

Closed 2 years ago

#17812 closed defect (fixed)

Error repare key and validation

Reported by: anonymous Owned by: geostonemarten
Priority: normal Milestone:
Component: Plugin ​indoorhelper Version: latest
Keywords: validator, highway, street_lamp, repare Cc:

Description

Hi,
there is an error on validator for highway=street_lamp

if value is on a point, JOSM want delete key

the message :
You assigned properties to a node which should only be assigned to a ways!

this key should be only on a point not on a way

Defaut : repare action delete key=value...

Attachments (0)

Change History (4)

comment:1 Changed 2 years ago by GerdP

Owner: changed from team to anonymous
Status: newneedinfo

I cannot reproduce that with r15169 and the default validator rules. I see no warning with highway=street_lamp on a node and a warning with highway=street_lamp on a way, and there is no auto fix (as expected).
I assume you have activated additional rules or replaced the original ones. Please check preferences for "Data validator" tab "Tag Checker Rules" and maybe click the reset button in the lower right corner.

comment:2 Changed 2 years ago by Klumbumbus

Component: CoreExternal rule

comment:3 Changed 2 years ago by j.seigneuret

Owner: changed from anonymous to geostonemarten
Status: needinfonew

Ok this a rules in Indoor Plugin.

After desactivation all are right.

@GerdP good job !

comment:4 Changed 2 years ago by Klumbumbus

Component: External rulePlugin ​indoorhelper
Resolution: fixed
Status: newclosed

The validation rule in the plugin was already removed in #17030. Please update your plugins.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain geostonemarten.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.