Modify

Opened 2 months ago

Closed 7 weeks ago

Last modified 7 weeks ago

#17801 closed defect (fixed)

wms URL is not created correctly

Reported by: Klumbumbus Owned by: Don-vip
Priority: normal Milestone: 19.06
Component: Core imagery Version:
Keywords: template_report wms Cc:

Description

What steps will reproduce the problem?

  1. click on add wms in the imagery preferences
  2. paste "https://geodaten.mainz.de/map/service?" or "https://geodaten.mainz.de/map/service?REQUEST=GetCapabilities" in the first box
  3. get layers
  4. choose "Luftbild"
  5. choose image/jpeg

What is the expected result?

working wms url

What happens instead?

non working url (contains REQUEST=GetCapabilities)
https://geodaten.mainz.de/map/service?REQUEST=GetCapabilities&FORMAT=image/jpeg&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=ortho_2018&STYLES=&SRS={proj}&WIDTH={width}&HEIGHT={height}&BBOX={bbox}

also at the preview in the window the url contains FORMAT=image/jpeg but after closing the window the url which is added to your imagery list cotains FORMAT=image/png instead

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-06-10 21:25:39 +0200 (Mon, 10 Jun 2019)
Build-Date:2019-06-11 01:30:58
Revision:15166
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15166 de) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1803 (17134)
Memory Usage: 863 MB / 1820 MB (482 MB allocated, but free)
Java version: 1.8.0_211-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1680x1050
Maximum Screen Size: 1680x1050
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:<java.home>\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=C:\Program Files (x86)\josm-latest.jnlp, -Djnlpx.remove=false, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.heapsize=NULL,2048m, -Djnlpx.splashport=56779, -Djnlpx.jvm=<java.home>\bin\javaw.exe]

Plugins:
+ DirectUpload (34908)
+ HouseNumberTaggingTool (34977)
+ OpeningHoursEditor (34977)
+ PicLayer (35030)
+ SimplifyArea (34977)
+ apache-commons (34908)
+ apache-http (34908)
+ buildings_tools (34982)
+ editgpx (34908)
+ ejml (34908)
+ geojson (124)
+ geotools (34908)
+ imagery-xml-bounds (35023)
+ imagery_offset_db (34908)
+ jaxb (35014)
+ jna (34908)
+ jogl (1.2.3)
+ jts (34908)
+ log4j (34908)
+ measurement (34977)
+ osm-obj-info (51)
+ photo_geotagging (34908)
+ photoadjust (34977)
+ reltoolbox (34977)
+ reverter (34999)
+ rex (53)
+ tag2link (34977)
+ tageditor (34977)
+ tagging-preset-tester (34908)
+ terracer (34977)
+ turnlanes-tagging (281)
+ turnrestrictions (34977)
+ undelete (34977)
+ utilsplugin2 (34977)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/StolpersteineLight&zip=1
+ %UserProfile%\Documents\OSM\josm\data\defaultpresets.xml
+ %UserProfile%\Documents\OSM\TestNew\newpresets.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Diving&zip=1

Map paint styles:
+ %UserProfile%\Documents\OSM\josm\styles\standard\elemstyles.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/NewHighwayColors&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/HiDPISupport&zip=1
- %UserProfile%\Downloads\Road_Extended_JOSM_style.zip
+ %UserProfile%\Documents\OSM\TestNew\newicons.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/sac_scale&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ShowID&zip=1
- %UserProfile%\Documents\OSM\eigene styles\PriorityRoad\PriorityRoad_1.0.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/LayerChecker&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Osmc&style&zip=1
- https://raw.githubusercontent.com/species/josm-preset-wheelchair/master/sidewalks_kerbs.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/LitObjects&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lit&style&zip=1
- %UserProfile%\Documents\OSM\eigene styles\Tourenplanung.mapcss
- %UserProfile%\Documents\OSM\eigene styles\SpecificBuildingValues\SpecificBuildingValues.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- %UserProfile%\Documents\OSM\eigene styles\area-symbol.zip
- http://www.freietonne.de/ft_icons/josm/FreieTonne_rules_presets_zip.php
- http://www.openrailwaymap.org/styles/standard.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/DestinationSignRelation&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Incline&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PTStops&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/AdvertisingStyle&zip=1
- https://www.dropbox.com/s/qo3ai47fpv241jf/Styles_Fixme_and_Notes.zip?raw=1
- https://github.com/gmgeo/osmic-josm-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/hazmat&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Suburb&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Postcode&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/RecyclingMaterials&zip=1
- %UserProfile%\Documents\OSM\eigene styles\maxspeed\maxspeed_2.9_01 basierend auf 2.7_02 Zahlen.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Bench&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransportV2&zip=1
- %UserProfile%\Documents\OSM\eigene styles\colourtag\colourtag_1.0.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/ColourTag&zip=1
- %UserProfile%\Downloads\coloured_kerbs_style.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Admin_Boundaries&zip=1
- https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&zip=1
- %UserProfile%\Documents\OSM\eigene styles\yes-no-unset\YesNoUnset_1.0.mapcss

Validator rules:
+ https://raw.githubusercontent.com/<user.name>n-a-bauer/josm-validators/master/mtb.validator.mapcss
- %UserProfile%\Documents\OSM\TestNew\germ.validator.mapcss
- https://josm.openstreetmap.de/josmfile?page=Rules/CzechRepublicAddressSystem&zip=1
+ %UserProfile%\Documents\OSM\TestNew\new.validator.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Rules/GermanySpecific&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Rules/OsmoseValidations&zip=1

Last errors/warnings:
- E: java.io.IOException: Die angeforderte URL https://osmlab.github.io/editor-layer-index/imagery.xmlx wurde nicht gefunden
- E: java.nio.file.NoSuchFileException: %UserProfile%\Documents\OSM\TestNew\newimageries.xmlx
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: java.io.IOException: Die angeforderte URL https://osmlab.github.io/editor-layer-index/imagery.xmlx wurde nicht gefunden
- E: java.nio.file.NoSuchFileException: %UserProfile%\Documents\OSM\TestNew\newimageries.xmlx

Attachments (0)

Change History (6)

comment:1 Changed 7 weeks ago by Don-vip

Keywords: wms added

comment:2 Changed 7 weeks ago by Don-vip

Milestone: 19.06
Owner: changed from team to Don-vip
Status: newassigned

comment:3 Changed 7 weeks ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 15209/josm:

fix #17801 - create WMS URL correctly

comment:4 Changed 7 weeks ago by Klumbumbus

Resolution: fixed
Status: closedreopened

Thats not yet fixed:

also at the preview in the window the url contains FORMAT=image/jpeg but after closing the window the url which is added to your imagery list cotains FORMAT=image/png instead

comment:5 Changed 7 weeks ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 15228/josm:

fix #17801 - use selected image format when building WMS URL

comment:6 Changed 7 weeks ago by Klumbumbus

Thanks. Works for me now.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.