Modify

Opened 10 years ago

Closed 10 years ago

#1776 closed defect (fixed)

Preferences Dialog does not come up

Reported by: stefan.leupers@… Owned by: framm
Priority: major Milestone:
Component: unspecified Version: latest
Keywords: Cc:

Description

I tried to open the settings (actually "Einstellungen..." because I use German version), but instead only the Error-Dialog comes up. :-(

This problem already persists for me since several versions.
The settings must be stored somewhere (where?). I assume that these settings have been mixed up somehow.

-StefanL-

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1089
Node Kind: directory
Last Changed Author: framm
Last Changed Rev: 1089
Last Changed Date: 2008-11-20 19:33:47 +0100 (Thu, 20 Nov 2008)

org.openstreetmap.josm.plugins.PluginException: Ein Fehler ist in dem Plugin unglueplugin aufgetreten.

at org.openstreetmap.josm.plugins.PluginInformation.<init>(PluginInformation.java:118)
at org.openstreetmap.josm.plugins.PluginInformation.<init>(PluginInformation.java:58)
at org.openstreetmap.josm.plugins.PluginInformation.findPlugin(PluginInformation.java:203)
at org.openstreetmap.josm.gui.preferences.PluginPreference.refreshPluginPanel(PluginPreference.java:263)
at org.openstreetmap.josm.gui.preferences.PluginPreference.addGui(PluginPreference.java:147)
at org.openstreetmap.josm.gui.preferences.PreferenceDialog.<init>(PreferenceDialog.java:115)
at org.openstreetmap.josm.actions.PreferencesAction.actionPerformed(PreferencesAction.java:39)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Caused by: java.io.IOException: C:\Dokumente und Einstellungen\leupers.AC-UTIMACO\Anwendungsdaten\JOSM\plugins\unglueplugin.jar contains no manifest.

at org.openstreetmap.josm.plugins.PluginInformation.<init>(PluginInformation.java:71)
... 34 more

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by stefan.leupers@…

Summary: Settings Dialog does not come upPreferences Dialog does not come up

Sorry, I meant "Preferences" (not Settings).
Just to avoid any confusion...

comment:2 Changed 10 years ago by anonymous

Delete the unglue plugin in the plugin directory as hotfix (is no longer required). Thought that bug should be fixed nevertheless.

comment:3 Changed 10 years ago by stefan.leupers@…

Ich hatte schon die Radikalkur gewählt und das komplette Plugin-Verzeichnis unter dem JOSM-Verzeichnis, wo auch das .jar liegt, gelöscht, aber es brachte leider nichts.

Das Löschen des Verzeichnisses

C:\Dokumente und Einstellungen\<user>\Anwendungsdaten\JOSM\plugins

und anschließende Neuinstallation der Plugins brachte dann die Rettung.

comment:4 Changed 10 years ago by anonymous

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.