Modify

Opened 15 months ago

Closed 12 months ago

Last modified 6 months ago

#17744 closed defect (fixed)

Bing layer isn't loading - error 403 (forbidden)

Reported by: naoliv Owned by: team
Priority: critical Milestone:
Component: JMapViewer Version:
Keywords: bing Cc: stoecker

Description

I don't know if this is temporary or if maybe something (like the key) needs to be updated, as trying to use the Bing layer gives a 403 (forbidden) error:

2019-05-22 17:49:41.676 INFO: GET https://dev.virtualearth.net/REST/v1/Imagery/Metadata/Aerial?include=ImageryProviders&output=xml&key=Arzdiw4nlOJzRwOz__qailc8NiR31Tt51dN2D7cm57NrnceZnCpgOkmJhNpGoppU -> 403
2019-05-22 17:49:41.682 INFO: Successfully loaded Bing attribution data.
java.lang.NumberFormatException: For input string: ""
	at java.base/java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
	at java.base/java.lang.Integer.parseInt(Integer.java:662)
	at java.base/java.lang.Integer.valueOf(Integer.java:983)
	at org.openstreetmap.gui.jmapviewer.tilesources.BingAerialTileSource.parseAttributionText(BingAerialTileSource.java:113)
	at org.openstreetmap.josm.data.imagery.CachedAttributionBingAerialTileSource.lambda$getAttributionLoaderCallable$0(CachedAttributionBingAerialTileSource.java:83)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at java.base/java.lang.Thread.run(Thread.java:834)

JOSM:

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-05-21 20:24:59 +0200 (Tue, 21 May 2019)
Revision:15104
Build-Date:2019-05-22 01:30:53
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15104 en) Linux Debian GNU/Linux 10 (buster)
Memory Usage: 855 MB / 6144 MB (731 MB allocated, but free)
Java version: 11.0.3+1-Debian-1, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900, :0.1 1280x1024
Maximum Screen Size: 1600x1024
Java package: openjdk-11-jre:amd64-11.0.3+1-1
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-22
VM arguments: [-Dhttps.protocols=TLSv1,TLSv1.1,TLSv1.2, -Dawt.useSystemAAFontSettings=gasp]
Program arguments: [--language=en]

Attachments (0)

Change History (13)

comment:1 Changed 15 months ago by Don-vip

Milestone: 19.05
Priority: normalcritical

comment:2 Changed 15 months ago by Don-vip

Cc: stoecker added

I don't know where the Bing API key comes from. It was before I joined the team.

comment:3 Changed 15 months ago by Don-vip

Component: External imagery sourceJMapViewer

The API key is hardcoded in JmapViewer, added in [o24706] in december 2010.

comment:5 Changed 15 months ago by Don-vip

It seems the issue was only temporary (daily quota exceeded). iD developers are looking to get a new key, I guess we should do the same.

comment:6 Changed 15 months ago by Don-vip

Milestone: 19.05
Resolution: worksforme
Status: newclosed

iD switched to a new key. Vespucci has already its own key. It means we're now the only ones to use the "old" key, so it's less likely we face the problem again. Closing for now.

comment:7 Changed 15 months ago by mmd

Quota seems to be hit again:

<?xml version="1.0" encoding="utf-8"?><Response xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/search/local/ws/rest/v1"><Copyright>Copyright © 2019 Microsoft and its suppliers. All rights reserved. This API cannot be accessed and the content and any results may not be used, reproduced or transmitted in any manner without express written permission from Microsoft Corporation.</Copyright><BrandLogoUri>http://dev.virtualearth.net/Branding/logo_powered_by.png</BrandLogoUri><StatusCode>403</StatusCode><StatusDescription>Forbidden</StatusDescription><AuthenticationResultCode>DeniedCredentials</AuthenticationResultCode><ErrorDetails>The request was forbidden.  Your credentials may be denied or suspended.</ErrorDetails><TraceId>...|DU00000D6A|7.7.0.0</TraceId><ResourceSets /></Response>

comment:8 Changed 15 months ago by GerdP

Resolution: worksforme
Status: closedreopened

comment:9 Changed 15 months ago by Hubert87

I'm having the same problem right now using JOSM.
I'll try again tomorrow, hope this is a quota problem.

Last edited 15 months ago by Don-vip (previous) (diff)

comment:10 Changed 15 months ago by Don-vip

I have added a SettingsAdapter in JMapViewer in ​[o35016:35019] so that we can control the Bing API key from JOSM.

comment:11 Changed 15 months ago by Don-vip

In 15147/josm:

see #17744 - register JMapViewer SettingsAdapter so that the Bing API key can be set using jmapviewer.bing.api-key

comment:12 Changed 12 months ago by Don-vip

Resolution: fixed
Status: reopenedclosed

No complain in the past 3 months, so I guess it's ok now.

comment:13 Changed 6 months ago by Don-vip

Keywords: bing added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.