Modify

Opened 5 months ago

Closed 5 months ago

#17702 closed defect (fixed)

Error opening session with not valid TMS argument

Reported by: mpasha Owned by: team
Priority: normal Milestone: 19.05
Component: Core imagery Version: latest
Keywords: template_report session Cc:

Description

The error occurs if in the .jos file the url contains not valid TMS argument. For example, in https://maps.melda.ru/pub/historic/rkka/z{sasZ}/{folderX}/x{x}/{folderY}/y{y}.jpg

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-05-08 21:48:06 +0200 (Wed, 08 May 2019)
Revision:15062
Build-Date:2019-05-09 01:30:52
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15062 ru) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 2016 LTSB 1607 (14393)
Memory Usage: 920 MB / 1024 MB (162 MB allocated, but free)
Java version: 12+33, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768
VM arguments: [-Djosm.home=<josm.pref>]
Program arguments: [D:\Programs\JOSM_Portable\Session\default1.jos]

Plugins:
+ BuildingGeneralization (23)
+ DirectDownload (34977)
+ DirectUpload (34908)
+ FastDraw (34977)
+ HouseNumberTaggingTool (34977)
+ Mapillary (1.5.18)
+ OpeningHoursEditor (34977)
+ apache-commons (34908)
+ apache-http (34908)
+ continuosDownload (82)
+ contourmerge (v0.1.4)
+ ejml (34908)
+ eventbus (34908)
+ geotools (34908)
+ gpxfilter (34908)
+ gson (34908)
+ imagery_offset_db (34908)
+ jna (34908)
+ jogl (1.2.3)
+ jts (34908)
+ livegps (34977)
+ log4j (34908)
+ merge-overlap (34972)
+ namemanager (34977)
+ osm-obj-info (51)
+ photoadjust (34977)
+ reltoolbox (34977)
+ surveyor (34977)
+ tag2link (34977)
+ tageditor (34977)
+ utilsplugin2 (34977)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-stops&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/UA.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Manholes&zip=1

Map paint styles:
- https://github.com/GlassOceanos/indoor-JOSM-style/archive/master.zip
- D:\GitHub\-= JOSM =-\Map Styles\Test\potlatch2.mapcss
+ https://pasharm.github.io/New_basic_style_for_JOSM/New_basic_style.mapcss
- D:\GitHub\New_basic_style_for_JOSM\New_basic_style2.mapcss
- D:\GitHub\-= JOSM =-\Map Styles\Test\elemstyles standart JOSM.mapcss
- D:\GitHub\New_basic_style_for_JOSM\New_basic_style.mapcss
- D:\GitHub\Ones test style JOSM\Ones test.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1

Validator rules:
- <josm.pref>\validator\indoorhelper.validator.mapcss

Last errors/warnings:
- W: java.io.IOException: Запрашиваемый URL https://maps.melda.ru/pub/historic/rkka/z{sasZ}/{folderX}/x{x}/{folderY}/y{y}.jpg?SERVICE=WMS&REQUEST=GetCapabilities&VERSION=1.3.0 не найден
- W: java.io.IOException: Запрашиваемый URL https://maps.melda.ru/pub/historic/rkka/z{sasZ}/{folderX}/x{x}/{folderY}/y{y}.jpg?SERVICE=WMS&REQUEST=GetCapabilities&VERSION=1.1.1 не найден
- W: java.io.IOException: Запрашиваемый URL https://maps.melda.ru/pub/historic/rkka/z{sasZ}/{folderX}/x{x}/{folderY}/y{y}.jpg не найден
- W: java.io.IOException: Запрашиваемый URL https://maps.melda.ru/pub/historic/rkka/z{sasZ}/{folderX}/x{x}/{folderY}/y{y}.jpg&VERSION=1.3.0 не найден
- W: java.io.IOException: Запрашиваемый URL https://maps.melda.ru/pub/historic/rkka/z{sasZ}/{folderX}/x{x}/{folderY}/y{y}.jpg&VERSION=1.1.1 не найден
- W: java.io.IOException: Запрашиваемый URL https://maps.melda.ru/pub/historic/rkka/z{sasZ}/{folderX}/x{x}/{folderY}/y{y}.jpgSERVICE=WMS&REQUEST=GetCapabilities не найден
- W: java.io.IOException: Запрашиваемый URL https://maps.melda.ru/pub/historic/rkka/z{sasZ}/{folderX}/x{x}/{folderY}/y{y}.jpgSERVICE=WMS&REQUEST=GetCapabilities&VERSION=1.3.0 не найден
- W: java.io.IOException: Запрашиваемый URL https://maps.melda.ru/pub/historic/rkka/z{sasZ}/{folderX}/x{x}/{folderY}/y{y}.jpgSERVICE=WMS&REQUEST=GetCapabilities&VERSION=1.1.1 не найден
- E: java.io.IOException: Запрашиваемый URL https://maps.melda.ru/pub/historic/rkka/z{sasZ}/{folderX}/x{x}/{folderY}/y{y}.jpgSERVICE=WMS&REQUEST=GetCapabilities&VERSION=1.1.1 не найден
- E: Handled by bug report queue: java.lang.IllegalArgumentException: {sasZ} is not a valid TMS argument. Please check this server URL:


=== REPORTED CRASH DATA ===
MapView#layerAdded:
 - layer: TMSLayer [info=ImageryInfo{name='1', countryCode='', url='https://maps.melda.ru/pub/historic/rkka/z{sasZ}/{folderX}/x{x}/{folderY}/y{y}.jpg', imageryType=TMS}]

BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.IllegalArgumentException: {sasZ} is not a valid TMS argument. Please check this server URL:
https://maps.melda.ru/pub/historic/rkka/z{sasZ}/{folderX}/x{x}/{folderY}/y{y}.jpg
	at org.openstreetmap.gui.jmapviewer.tilesources.TemplatedTMSTileSource.checkUrl(TemplatedTMSTileSource.java:163)
	at org.openstreetmap.josm.gui.layer.TMSLayer.getTileSourceStatic(TMSLayer.java:114)
	at org.openstreetmap.josm.gui.layer.TMSLayer.getTileSource(TMSLayer.java:72)
	at org.openstreetmap.josm.gui.layer.TMSLayer.getTileSource(TMSLayer.java:33)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.initializeIfRequired(AbstractTileSourceLayer.java:571)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.attachToMapView(AbstractTileSourceLayer.java:553)
	at org.openstreetmap.josm.gui.MapView.layerAdded(MapView.java:346)
	at org.openstreetmap.josm.gui.layer.LayerManager.fireLayerAdded(LayerManager.java:459)
	at org.openstreetmap.josm.gui.layer.LayerManager.realAddLayer(LayerManager.java:234)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realAddLayer(MainLayerManager.java:284)
	at org.openstreetmap.josm.gui.layer.LayerManager.lambda$addLayer$0(LayerManager.java:218)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:239)
	at org.openstreetmap.josm.gui.layer.LayerManager.addLayer(LayerManager.java:218)
	at org.openstreetmap.josm.gui.layer.LayerManager.addLayer(LayerManager.java:207)
	at org.openstreetmap.josm.actions.SessionLoadAction$Loader.addLayers(SessionLoadAction.java:142)
	at org.openstreetmap.josm.actions.SessionLoadAction$Loader.lambda$finish$0(SessionLoadAction.java:129)
	at java.desktop/java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:313)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:770)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(AccessController.java:389)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:740)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:117)
	at java.desktop/java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:190)
	at java.desktop/java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:235)
	at java.desktop/java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:233)
	at java.base/java.security.AccessController.doPrivileged(AccessController.java:310)
	at java.desktop/java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:233)
	at java.desktop/java.awt.Dialog.show(Dialog.java:1070)
	at java.desktop/java.awt.Component.show(Component.java:1716)
	at java.desktop/java.awt.Component.setVisible(Component.java:1663)
	at java.desktop/java.awt.Window.setVisible(Window.java:1021)
	at java.desktop/java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.progress.swing.PleaseWaitProgressMonitor.lambda$doBeginTask$3(PleaseWaitProgressMonitor.java:255)
	at org.openstreetmap.josm.gui.progress.swing.PleaseWaitProgressMonitor.lambda$doInEDT$0(PleaseWaitProgressMonitor.java:113)
	at java.desktop/java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:313)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:770)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(AccessController.java:389)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:740)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

Attachments (0)

Change History (4)

comment:1 Changed 5 months ago by Don-vip

Component: CoreCore imagery
Keywords: session added

comment:2 Changed 5 months ago by Don-vip

Ticket #17703 has been marked as a duplicate of this ticket.

comment:3 Changed 5 months ago by Don-vip

Milestone: 19.05

comment:4 Changed 5 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 15070/josm:

fix #17701, fix #17702 - add robustness when loading imagery layers from session

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.