Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1765 closed defect (worksforme)

Changeset 1084 breaks lakewalker

Reported by: avarab@… Owned by: framm
Priority: blocker Milestone:
Component: Plugin Version: latest
Keywords: Cc:

Description

Lakewalker won't load after [1084], it probably needs to "rename ShortCut to Shortcut, and shortCut to shortcut".

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by framm

Resolution: worksforme
Status: newclosed

A new version of Lakewalker has been submitted to SVN at the same time as changeset 1084 was submitted. You should get a working version by simply hitting "update" in your plugin preferences. See http://trac.openstreetmap.org/changeset/11979

comment:2 Changed 10 years ago by anonymous

While it is true that the combination of >=changeset 1084 in combination with the updated lakewalker-plugin is a working combination, the solution to the problem is not as straightforward as given.

After updating to a changeset >=1084, josm hangs at the splash screen giving the java.lang.NoSuchFieldError: shortCut; that is there is no way to "simply hit update". On the other hand, after reverting to a <changeset 1084 and updating the plugins from that version, josm hangs at the splash screen on java.lang.NoClassDefFoundError: org/openstreetmap/josm/tools/Shortcut.

The only way (of course apart from manually downloading the correct set of jar-files prior to launching anything) I have found to correct the solution is to first update the plugins from a <1084 josm and with these in place update to a changeset >=1084 (and never look back...). This makes the "more or less stable" changeset utterly unstable *smile*

That is, there is no problem in code, but there might be a problem in information flow....

/Best regards, osm-user sanna

---

System: Debian Lenny, java-6-openjdk

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.