Modify

Opened 2 months ago

Closed 2 months ago

#17619 closed defect (fixed)

offline startup slow on Windows because certificates are always downloaded

Reported by: anonymous Owned by: Don-vip
Priority: normal Milestone: 19.04
Component: Core Version: tested
Keywords: template_report offline certificate windows Cc:

Description

What steps will reproduce the problem?

  1. Starting JOSM on a Machine without internetconnection

What is the expected result?

JOSM should start within a few seconds

What happens instead?

JOSM startup takes almost 1minute

Please provide any additional information below. Attach a screenshot if possible.

I need to run JOSM on a Machine without a connection to the Internet.
When there is no Internetconnection JOSM starts really slow. After starting JOSM it takes about 30sec where nothing seems to happen until the splashscreen appears.

When starting JOSM in Commandprompt it turns out that 25sec of the 30sec JOSM tries to request certificates.

I have found the parameter "--offline=..." to use when working offline. But during startup this does nothing change. JOSM still needs 30sec until the splashscreen appears and it still requests certificates.

Here all Information I see in the commandprompt:

C:\Users\user>java -jar "D:\JOSM\josm-tested.jar" --offline=all
2019-04-18 09:32:35.122 INFO: Log level is at INFO (INFO, 800)
2019-04-18 09:32:35.310 WARNING: JOSM is running in offline mode. This resource will not be available: ALL
2019-04-18 09:32:40.929 WARNING: Unable to request certificate of https://roottest-g2.pkioverheid.nl
2019-04-18 09:32:46.031 WARNING: Unable to request certificate of https://roottest-g3.pkioverheid.nl
2019-04-18 09:32:51.119 WARNING: Unable to request certificate of https://www.certigna.fr
2019-04-18 09:32:56.211 WARNING: Unable to request certificate of https://eidas.disig.sk
2019-04-18 09:33:01.332 WARNING: Unable to request certificate of https://grca.nat.gov.tw
2019-04-18 09:33:03.151 WARNING: OSM API not available (offline mode)
2019-04-18 09:33:03.154 WARNING: org.openstreetmap.josm.io.OfflineAccessException: Unable to access 'https://josm.openstreetmap.de/maps%<?ids=>': JOSM website not available (offline mode)
2019-04-18 09:33:03.169 SEVERE: java.io.IOException: Unable to get cache file for https://josm.openstreetmap.de/maps
2019-04-18 09:33:04.449 WARNING: OSM API not available (offline mode)
2019-04-18 09:33:04.620 WARNING: No configuration settings found.  Using hardcoded default values for all pools.
2019-04-18 09:33:04.674 WARNING: Region [TMS_BLOCK_v2] Resetting cache
2019-04-18 09:33:04.705 INFO: Message notifier not available (offline mode)
2019-04-18 09:33:04.706 INFO: Changeset updater active (checks every 60 minutes if open changesets have been closed)
URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-03-31 21:17:00 +0200 (Sun, 31 Mar 2019)
Build-Date:2019-03-31 20:25:18
Revision:14945
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14945 de) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 1809 (17763)
Memory Usage: 416 MB / 3625 MB (159 MB allocated, but free)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1200, \Display1 1920x1200, \Display2 1920x1200, \Display3 1920x1200
Maximum Screen Size: 1920x1200
Program arguments: [--offline=all]

Last errors/warnings:
- W: Unable to request certificate of https://roottest-g3.pkioverheid.nl
- W: Unable to request certificate of https://www.certigna.fr
- W: Unable to request certificate of https://eidas.disig.sk
- W: Unable to request certificate of https://grca.nat.gov.tw
- W: OSM-API nicht verfügbar (Offline-Modus)
- W: org.openstreetmap.josm.io.OfflineAccessException: Kein Zugriff auf 'https://josm.openstreetmap.de/maps%<?ids=>': JOSM-Internetseite nicht verfügbar (Offline-Modus)
- E: java.io.IOException: Unable to get cache file for https://josm.openstreetmap.de/maps
- W: OSM-API nicht verfügbar (Offline-Modus)
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Region [TMS_BLOCK_v2] Resetting cache

Attachments (0)

Change History (7)

comment:1 Changed 2 months ago by Don-vip

Keywords: certificate added
Milestone: 19.04
Owner: changed from team to Don-vip
Status: newassigned

comment:2 Changed 2 months ago by Don-vip

Keywords: windows added
Summary: offline startup slowoffline startup slow on Windows because certificates are always downloaded

comment:3 Changed 2 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 14999/josm:

fix #17619:

  • improve offline startup time on Windows by making certificate download optional
  • fix Taiwan Windows alias
  • issue a warning when a certificate alias is wrong

comment:4 Changed 2 months ago by Don-vip

In 15006/josm:

see #17619: use a common list of native certificate aliases, as they can change between Windows 7 and Windows 10 and are often the same between Windows and macOS

comment:5 Changed 2 months ago by anonymous

Thanks for the fast fix!
Is it possible to disable the request for certificates when --offline=josm_website too?
In my case, I have a local server with a OSM-likeish API. I figured out, I can not use --offline=all because in this case I can not Download Data from my local-server anymore..

By the way: when using --offline=all on JOSM V15017 there is still an Exception thrown while starting:

2019-04-24 14:33:03.169 SEVERE: java.io.IOException: Unable to get cache file for https://josm.openstreetmap.de/maps

comment:6 Changed 2 months ago by anonymous

Resolution: fixed
Status: closedreopened

comment:7 in reply to:  5 Changed 2 months ago by Don-vip

Resolution: fixed
Status: reopenedclosed

Replying to anonyme:

Is it possible to disable the request for certificates when --offline=josm_website too?
In my case, I have a local server with a OSM-likeish API. I figured out, I can not use --offline=all because in this case I can not Download Data from my local-server anymore..

No, simply use --offline=josm_website,certificates

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.