Modify

Opened 10 months ago

Closed 3 weeks ago

#17563 closed defect (fixed)

NPE at surveyor.ButtonDescription.createComponent

Reported by: mpasha Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin surveyor Version: latest
Keywords: template_report Cc:

Description

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-04-04 14:35:46 +0200 (Thu, 04 Apr 2019)
Revision:14961
Build-Date:2019-04-05 01:30:53
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (14961 ru) Windows 8.1 64-Bit
OS Build number: Windows 8.1 Enterprise (9600)
Memory Usage: 324 MB / 1024 MB (136 MB allocated, but free)
Java version: 12+33, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Djosm.home=<josm.pref>]
Program arguments: [%UserProfile%\Videos\1\JOSM_Portable\Session\default1.jos]

Plugins:
+ BuildingGeneralization (23)
+ DirectDownload (34867)
+ DirectUpload (34867)
+ FastDraw (34949)
+ HouseNumberTaggingTool (34867)
+ Mapillary (1.5.18)
+ OpeningHoursEditor (34867)
+ apache-commons (34506)
+ apache-http (34632)
+ continuosDownload (82)
+ contourmerge (v0.1.4)
+ ejml (34389)
+ eventbus (34636)
+ geotools (34513)
+ gson (34389)
+ imagery_offset_db (34867)
+ jna (34867)
+ jogl (1.2.2)
+ jts (34524)
+ livegps (34678)
+ log4j (34527)
+ merge-overlap (34664)
+ namemanager (34867)
+ osm-obj-info (51)
+ photoadjust (34867)
+ reltoolbox (34867)
+ surveyor (34678)
+ tag2link (34867)
+ tageditor (34867)
+ utilsplugin2 (34932)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-stops&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/UA.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Manholes&zip=1

Map paint styles:
- https://github.com/GlassOceanos/indoor-JOSM-style/archive/master.zip
- D:\GitHub\-= JOSM =-\Map Styles\Test\potlatch2.mapcss
+ https://pasharm.github.io/New_basic_style_for_JOSM/New_basic_style.mapcss
- D:\GitHub\New_basic_style_for_JOSM\New_basic_style2.mapcss
- D:\GitHub\-= JOSM =-\Map Styles\Test\elemstyles standart JOSM.mapcss
- D:\GitHub\New_basic_style_for_JOSM\New_basic_style.mapcss
- D:\GitHub\Ones test style JOSM\Ones test.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1

Validator rules:
- D:\Programs\JOSM_Portable\config\validator\indoorhelper.validator.mapcss

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- E: Не удалось найти изображение «styles/standard/vehicle/tunnel.png»
- E: Не удалось найти изображение «styles/standard/vehicle/tunnel.png»
- E: Не удалось найти изображение «styles/standard/vehicle/tunnel.png»
- E: Не удалось найти изображение «styles/standard/vehicle/tunnel.png»
- E: Handled by bug report queue: java.lang.NullPointerException: name
- W: Внимание - <html>JOSM не может найти информацию о следующих модулях:<ul><li>livegps</li><li>apache-commons</li><li>reltoolbox</li><li>HouseNumberTaggingTool</li><li>geotools</li><li>tageditor</li><li>continuosDownload</li><li>utilsplugin2</li><li>namemanager</li><li>jogl</li><li>jna</li><li>contourmerge</li><li>log4j</li><li>BuildingGeneralization</li><li>imagery_offset_db</li><li>photoadjust</li><li>jts</li><li>Mapillary</li><li>tag2link</li><li>DirectDownload</li><li>osm-obj-info</li><li>surveyor</li><li>DirectUpload</li><li>ejml</li><li>FastDraw</li><li>eventbus</li><li>OpeningHoursEditor</li><li>gson</li><li>apache-http</li><li>merge-overlap</li></ul>Модули не загружаются с сервера.</html>
- W: Отсутствует основной номер версии в модуле RXTXcomm


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.NullPointerException: name
	at java.base/java.util.Objects.requireNonNull(Objects.java:246)
	at org.openstreetmap.josm.tools.ImageProvider.<init>(ImageProvider.java:337)
	at org.openstreetmap.josm.tools.ImageProvider.getIfAvailable(ImageProvider.java:808)
	at org.openstreetmap.josm.plugins.surveyor.ButtonDescription.createComponent(ButtonDescription.java:177)
	at org.openstreetmap.josm.plugins.surveyor.SurveyorComponent.addButton(SurveyorComponent.java:106)
	at org.openstreetmap.josm.plugins.surveyor.SurveyorShowAction.createComponent(SurveyorShowAction.java:153)
	at org.openstreetmap.josm.plugins.surveyor.SurveyorShowAction.createComponent(SurveyorShowAction.java:119)
	at org.openstreetmap.josm.plugins.surveyor.SurveyorShowAction.actionPerformed(SurveyorShowAction.java:56)
	at java.desktop/javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1967)
	at java.desktop/javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2308)
	at java.desktop/javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:405)
	at java.desktop/javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:262)
	at java.desktop/javax.swing.AbstractButton.doClick(AbstractButton.java:369)
	at java.desktop/javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1020)
	at java.desktop/javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1064)
	at java.desktop/java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:297)
	at java.desktop/java.awt.Component.processMouseEvent(Component.java:6632)
	at java.desktop/javax.swing.JComponent.processMouseEvent(JComponent.java:3342)
	at java.desktop/java.awt.Component.processEvent(Component.java:6397)
	at java.desktop/java.awt.Container.processEvent(Container.java:2263)
	at java.desktop/java.awt.Component.dispatchEventImpl(Component.java:5008)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2321)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4840)
	at java.desktop/java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4918)
	at java.desktop/java.awt.LightweightDispatcher.processMouseEvent(Container.java:4547)
	at java.desktop/java.awt.LightweightDispatcher.dispatchEvent(Container.java:4488)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2307)
	at java.desktop/java.awt.Window.dispatchEventImpl(Window.java:2762)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4840)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:772)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(AccessController.java:389)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:95)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:745)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:743)
	at java.base/java.security.AccessController.doPrivileged(AccessController.java:389)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:742)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

Attachments (0)

Change History (5)

comment:1 Changed 10 months ago by Don-vip

Component: CorePlugin surveyor
Summary: Error SurveyorNPE at surveyor.ButtonDescription.createComponent

comment:2 Changed 3 weeks ago by Don-vip

Ticket #17985 has been marked as a duplicate of this ticket.

comment:3 Changed 3 weeks ago by Don-vip

Ticket #18474 has been marked as a duplicate of this ticket.

comment:4 Changed 3 weeks ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

comment:5 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: assignedclosed

Fixed in [o35262:35263].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.