Modify

Opened 3 weeks ago

Closed 3 weeks ago

#17557 closed enhancement (fixed)

Add shop=carpet to presets

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 19.04
Component: Internal preset Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Attempt to tag carpet shop

What is the expected result?

shop=carpet is autocompleted and tagged node has an icon

What happens instead?

neither one

Please provide any additional information below. Attach a screenshot if possible.

https://taginfo.openstreetmap.org//search?q=shop%3Dcarpet

shop type that is real and quite popular, though many of them are in regions at this moment poorly mapped

OSM carto has an icon though it is quite poor one - https://github.com/gravitystorm/openstreetmap-carto/blob/master/symbols/shop/carpet.svg

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-04-03 00:33:43 +0200 (Wed, 03 Apr 2019)
Build-Date:2019-04-03 01:30:50
Revision:14954
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14954 en) Linux Ubuntu 16.04.6 LTS
Memory Usage: 414 MB / 869 MB (54 MB allocated, but free)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34867)
+ buildings_tools (34904)
+ continuosDownload (82)
+ imagery_offset_db (34867)
+ measurement (34867)
+ reverter (34961)
+ todo (30306)

Validator rules:
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/deprecated.mapcss
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/unnecessary.mapcss
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/combinations.mapcss

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Expecting test '{0.tag} is unnecessary for {1.tag}' (i.e., [way[foot'REGEX'^(yes|designated)$][highway'REGEX'^(footway|pedestrian)$][!access], way[bicycle'REGEX'^(yes|designated)$][highway=cycleway][!vehicle][!access][foot'NEQ'designated], *[building:ruian:type=2][building=farm_auxiliary], *[building:ruian:type=7][building=house], *[building:ruian:type=11][building=hotel], *[building:ruian:type=12][building=warehouse], *[building:ruian:type=13][building=barn], *[building:ruian:type=18][building=garage], *[building:ruian:type=21][building=greenhouse], *[gnis:Class=Populated Place][place=city], *[gnis:Class=Populated Place][place=town], *[gnis:Class=Populated Place][place=village], *[gnis:Class=Populated Place][place=hamlet], *[gnis:Class=Summit][natural=peak]]) to match node gnis:Class=Populated Place place=town (i.e., TagMap[gnis:Class=Populated,Place=place=town])
- W: Expecting test '{0.tag} is unnecessary for {1.tag}' (i.e., [way[foot'REGEX'^(yes|designated)$][highway'REGEX'^(footway|pedestrian)$][!access], way[bicycle'REGEX'^(yes|designated)$][highway=cycleway][!vehicle][!access][foot'NEQ'designated], *[building:ruian:type=2][building=farm_auxiliary], *[building:ruian:type=7][building=house], *[building:ruian:type=11][building=hotel], *[building:ruian:type=12][building=warehouse], *[building:ruian:type=13][building=barn], *[building:ruian:type=18][building=garage], *[building:ruian:type=21][building=greenhouse], *[gnis:Class=Populated Place][place=city], *[gnis:Class=Populated Place][place=town], *[gnis:Class=Populated Place][place=village], *[gnis:Class=Populated Place][place=hamlet], *[gnis:Class=Summit][natural=peak]]) to match node gnis:Class='Populated Place' place=town (i.e., TagMap[Place'=place=town,gnis:Class='Populated])
- W: Expecting test '{0.tag} is unnecessary for {1.tag}' (i.e., [way[foot'REGEX'^(yes|designated)$][highway'REGEX'^(footway|pedestrian)$][!access], way[bicycle'REGEX'^(yes|designated)$][highway=cycleway][!vehicle][!access][foot'NEQ'designated], *[building:ruian:type=2][building=farm_auxiliary], *[building:ruian:type=7][building=house], *[building:ruian:type=11][building=hotel], *[building:ruian:type=12][building=warehouse], *[building:ruian:type=13][building=barn], *[building:ruian:type=18][building=garage], *[building:ruian:type=21][building=greenhouse], *[gnis:Class=Populated Place][place=city], *[gnis:Class=Populated Place][place=town], *[gnis:Class=Populated Place][place=village], *[gnis:Class=Populated Place][place=hamlet], *[gnis:Class=Summit][natural=peak]]) to match node gnis:Class='Populated Place' place=town (i.e., TagMap[Place'=place=town,gnis:Class='Populated])
- E: Skipping to the next rule, because of an error:
- E: org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Encountered " "~" "~ "" at line 108, column 14.
- W: org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Reached end of file while parsing
- W: Expecting test '{0.tag} is unnecessary for {1.tag}' (i.e., [way[foot'REGEX'^(yes|designated)$][highway'REGEX'^(footway|pedestrian)$][!access], way[bicycle'REGEX'^(yes|designated)$][highway=cycleway][!vehicle][!access][foot'NEQ'designated], *[building:ruian:type=2][building=farm_auxiliary], *[building:ruian:type=7][building=house], *[building:ruian:type=11][building=hotel], *[building:ruian:type=12][building=warehouse], *[building:ruian:type=13][building=barn], *[building:ruian:type=18][building=garage], *[building:ruian:type=21][building=greenhouse], *[gnis:Class=Populated Place][place=city], *[gnis:Class=Populated Place][place=town], *[gnis:Class=Populated Place][place=village], *[gnis:Class=Populated Place][place=hamlet], *[gnis:Class=Summit][natural=peak]]) to match node gnis:Class=Populated Place place=town (i.e., TagMap[gnis:Class=Populated,Place=place=town])
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Expecting n/node/w/way/r/relation/area, but got '"node'

Attachments (0)

Change History (2)

comment:1 Changed 3 weeks ago by Klumbumbus

Milestone: 19.04

comment:2 Changed 3 weeks ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 14959/josm:

fix #17557 - add shop=carpet (icon from https://wiki.openstreetmap.org/wiki/File:Carpet-14.svg, CC0 and PD licensed)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.