Modify

#17460 closed defect (fixed)

SSL Error downloading tiles with Cadastre imagery

Reported by: lmagreault Owned by: team
Priority: normal Milestone:
Component: External imagery source Version: latest
Keywords: template_report https ssl tls sni cadastre france Cc:

Description

Error message with Cadastre imagery since few days:
"Error downloading tiles:javax.net.ssl.SSLProtocolException:handshake alert: unrecognized_name"

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-03-03 00:16:03 +0100 (Sun, 03 Mar 2019)
Build-Date:2019-03-02 23:16:53
Revision:14824
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14824 fr) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 1809 (17763)
Memory Usage: 978 MB / 989 MB (415 MB allocated, but free)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1200, \Display1 1920x1080, \Display2 1920x1200
Maximum Screen Size: 1920x1200
Dataset consistency test: No problems found

Plugins:
+ FixAddresses (34867)
+ HouseNumberTaggingTool (34867)
+ ImportImagePlugin (34576)
+ Mapillary (v1.5.17)
+ OpeningHoursEditor (34867)
+ RoadSigns (34867)
+ alignways (34867)
+ apache-commons (34506)
+ apache-http (34632)
+ auto_tools (67)
+ buildings_tools (34904)
+ cadastre-fr (34801)
+ ejml (34389)
+ epci-fr (34622)
+ geotools (34513)
+ jna (34867)
+ jts (34524)
+ log4j (34527)
+ reverter (34867)
+ splinex (34901)
+ turnrestrictions (34867)
+ utilsplugin2 (34867)
+ wikipedia (v1.1.1)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Light_sources&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1

Map paint styles:
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs_EUR.zip

Last errors/warnings:
- W: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
- W: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
- W: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
- W: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
- W: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
- W: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
- W: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
- W: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
- W: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
- W: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name

Attachments (1)

2019-03-13 16_45_33-Java OpenStreetMap Editor.png (179.8 KB) - added by lmagreault 10 months ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 months ago by Don-vip

Ticket #17461 has been marked as a duplicate of this ticket.

comment:3 Changed 10 months ago by Don-vip

Rapport SSLLabs: https://www.ssllabs.com/ssltest/analyze.html?d=inspire.cadastre.gouv.fr Note A+, c'est excellent, le seul warning concerne le certificat Certigna qui n'est pas inclus de base dans Java mais qu'on emporte avec JOSM. Il a peut être changé...

Last edited 10 months ago by Don-vip (previous) (diff)

comment:4 Changed 10 months ago by Don-vip

Keywords: https ssl tls sni cadastre france added

comment:5 Changed 10 months ago by Don-vip

Component: Plugin cadastre-frExternal imagery source
Owner: changed from Don-vip to team

Ce n'est pas un problème du plugin cadastre mais de l'imagerie fournie par OSM-FR. Justement une solution est d'utiliser la fonction WMS du plugin (touche F10).

comment:6 Changed 10 months ago by stoecker

I don't understand the french texts fully, but the mentioned SNI error is a configuration issue on server side. It happens when e.g. an Apache vhost has no server name, but fallbacks to default. Solution is simply to set the "ServerName" to the correct value.

That java handles this as error is a bug thought - it should only have warning level.

comment:7 Changed 10 months ago by Don-vip

We have an http TMS service provided by OSM-FR which redirects to a French governmental HTTPS service, I have created https://github.com/osm-fr/infrastructure/issues/99 to ask for a fix.

comment:8 Changed 10 months ago by Don-vip

Ticket #17467 has been marked as a duplicate of this ticket.

comment:9 in reply to:  7 Changed 10 months ago by stoecker

Replying to Don-vip:

We have an http TMS service provided by OSM-FR which redirects to a French governmental HTTPS service, I have created https://github.com/osm-fr/infrastructure/issues/99 to ask for a fix.

If I understand it correctly this issue is twofold:

  • The tms redirect should properly use HTTPS which is does not.
  • The governmental inspire server should use ServerName properly (it's an Apache server as far as I could see).

comment:10 Changed 10 months ago by Don-vip

Ticket #17478 has been marked as a duplicate of this ticket.

comment:11 Changed 10 months ago by Don-vip

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.