Modify

Opened 3 months ago

Closed 3 months ago

Last modified 2 months ago

#17402 closed enhancement (fixed)

complain about leisure=nature_reserve on nodes

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 19.03
Component: Core validator Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. tag leisure=nature_reserve on node
  2. tag leisure=park on node
  3. run validator

What is the expected result?

Warning for both nodes.

What happens instead?

Warning for only leisure=park

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-02-23 17:46:51 +0100 (Sat, 23 Feb 2019)
Build-Date:2019-02-24 02:30:49
Revision:14802
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14802 en) Linux Ubuntu 16.04.5 LTS
Memory Usage: 666 MB / 869 MB (244 MB allocated, but free)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34867)
+ buildings_tools (34867)
+ continuosDownload (82)
+ imagery_offset_db (34867)
+ measurement (34867)
+ reverter (34867)
+ todo (30306)

Validator rules:
+ ${HOME}/Desktop/tmp/test.validator.mapcss

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Region [TMS_BLOCK_v2] Resetting cache
- W: Expecting test '{0.tag}' (i.e., [*[name=parking][amenity=parking], *[name=playground][leisure=playground], *[name=shop][shop][shop'NEQ'no], *[name=building][building][building'NEQ'no], *[name=kiosk][shop=kiosk], *[name=cemetery][amenity=graveyard], *[name=cemetery][landuse=cemetery], *[name=cmentarz][amenity=graveyard], *[name=cmentarz][landuse=cemetery]]) to match relation name=PLAYGROUND leisure=playground (i.e., TagMap[name=PLAYGROUND,leisure=playground])
- W: Expecting test '{0.tag}' (i.e., [*[name=parking][amenity=parking], *[name=playground][leisure=playground], *[name=shop][shop][shop'NEQ'no], *[name=building][building][building'NEQ'no], *[name=kiosk][shop=kiosk], *[name=cemetery][amenity=graveyard], *[name=cemetery][landuse=cemetery], *[name=cmentarz][amenity=graveyard], *[name=cmentarz][landuse=cemetery]]) to match relation name=parking amenity=Parking (i.e., TagMap[amenity=Parking,name=parking])
- W: Expecting test '{0.tag}' (i.e., [*[name=parking][amenity=parking], *[name=playground][leisure=playground], *[name=shop][shop][shop'NEQ'no], *[name=building][building][building'NEQ'no], *[name=kiosk][shop=kiosk], *[name=cemetery][amenity=graveyard], *[name=cemetery][landuse=cemetery], *[name=cmentarz][amenity=graveyard], *[name=cmentarz][landuse=cemetery]]) to match node name=PLaYGrOUNd leisure=playground (i.e., TagMap[name=PLaYGrOUNd,leisure=playground])
- W: Expecting test '{0.tag}' (i.e., [*[name=parking][amenity=parking], *[name=playground][leisure=playground], *[name=shop][shop][shop'NEQ'no], *[name=building][building][building'NEQ'no], *[name=kiosk][shop=kiosk], *[name=cemetery][amenity=graveyard], *[name=cemetery][landuse=cemetery], *[name=cmentarz][amenity=graveyard], *[name=cmentarz][landuse=cemetery]]) to match node name=parking amenity=Parking (i.e., TagMap[amenity=Parking,name=parking])
- W: Expecting test '{0.tag}' (i.e., [*[name=parking][amenity=parking], *[name=playground][leisure=playground], *[name=shop][shop][shop'NEQ'no], *[name=building][building][building'NEQ'no], *[name=kiosk][shop=kiosk], *[name=cemetery][amenity=graveyard], *[name=cemetery][landuse=cemetery], *[name=cmentarz][amenity=graveyard], *[name=cmentarz][landuse=cemetery]]) to match way name=parking amenity=Parking (i.e., TagMap[amenity=Parking,name=parking])

Attachments (0)

Change History (6)

comment:1 Changed 3 months ago by Klumbumbus

Milestone: 19.03

comment:2 Changed 3 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 14830/josm:

fix #17402 - warn about leisure=nature_reserve on nodes

comment:3 Changed 2 months ago by dieterdreist

What is the criterion for warning only on specific object types? Any object that can be represented as a node or as a polygon is generally better represented as an area (shape, size, orientation). This could be seen more conservatively by restricting it to objects typically larger as x (for example 1 m2). Why is there a warning for some, and not for others?

comment:4 Changed 2 months ago by mkoniecz

Note: following is my guideline for reporting issues, not reasoning of JOSM developers.


Because for some benefit is minor or nonexisting and some objects are much more useful as areas. Additionally mapping some cases is much harder than other.

For example park mapped as area is much more useful than park mapped as node, while shop mapped as area is only marginally better than shop mapped as a node.

Additionally mapping park as ares is much easier than mapping shop as areas.

Any object that can be represented as a node or as a polygon is generally better represented as an area

Not all. See traffic signs, street lamps etc.

Last edited 2 months ago by mkoniecz (previous) (diff)

comment:5 in reply to:  4 Changed 2 months ago by Klumbumbus

Replying to mkoniecz:

Any object that can be represented as a node or as a polygon is generally better represented as an area

Not all. See traffic signs, street lamps etc.

And don't forget our most cited defaultest default OpenStreetMap example: vending=excrement_bags ;)

comment:6 Changed 2 months ago by GerdP

(sorry, typo in svn log message)

Last edited 2 months ago by GerdP (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.