Modify

Opened 11 months ago

Closed 10 months ago

Last modified 10 months ago

#17354 closed defect (fixed)

relation panel dont shows all relations in revert sometimes

Reported by: MKnight Owned by: Upliner
Priority: normal Milestone: 19.03
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. close relation-panel
  2. revert a CS with deleted relations for example CS67295231
  3. open relation panel, there are 4 relations
  1. open relation panel
  2. revert a CS with deleted relations for example CS67295231
  3. look at relation window, there are 2 relations

Attachments (1)

17354.patch (695 bytes) - added by GerdP 10 months ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 months ago by Don-vip

Component: CorePlugin reverter
Owner: changed from team to Upliner

Changed 10 months ago by GerdP

Attachment: 17354.patch added

comment:2 Changed 10 months ago by GerdP

@Vincent: I can reproduce this but I see that the dataset always contains 5 relations, so maybe the problem is that the relation list window is not in sync with the dataset. In my case only one relation is shown when the panel was open (2nd list of steps)
Closing and opening the relation list window shows 4 relations, searching for type:relation with checkbox "all objects" enabled shows finds 5 relations.
The attached patch seems to fix this so that always 4 relations are shown. One of the relations is very incomplete, so I guess it is intended that it doesn't appear in this window: Relation 7589682 exists only because it is a member of Relation 8329249.
What do you think?

comment:3 Changed 10 months ago by GerdP

Resolution: fixed
Status: newclosed

In 14886/josm:

fix #17354: Relation list is not always updated

The problem was that RelationListDialog.otherDatasetChange(AbstractDatasetChangedEvent event) did nothing.
The dialog therefore misses events of type PRIMITIVE_FLAGS_CHANGED and if the flags of a relation are changed this should change the list.
When the dialog is build from scratch it looks at the relations with status complete and shows them.

comment:4 Changed 10 months ago by GerdP

Component: Plugin reverterCore

Problem was not related to plugin reverter.

comment:5 Changed 10 months ago by Don-vip

Milestone: 19.03

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Upliner.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.