Modify

Opened 2 months ago

Closed 5 weeks ago

#17335 closed defect (duplicate)

DataIntegrityProblemException: Deleted node referenced

Reported by: Poliakoff Mykhailo Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. при зберіганні правки

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-02-02 21:01:18 +0100 (Sat, 02 Feb 2019)
Build-Date:2019-02-04 21:50:11
Revision:14760
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14760 uk) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 1803 (17134)
Memory Usage: 818 MB / 989 MB (284 MB allocated, but free)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1280x1024
Maximum Screen Size: 1280x1024

Dataset consistency test:
[DELETED REFERENCED] {Way id=25837399 version=13 MVT nodes=[{Node id=281819056 version=4 V lat=47.9846583,lon=37.7838331}, {Node id=281818903 version=3 V lat=47.9834464,lon=37.7929524}, {Node id=2612525103 version=1 V lat=47.9833503,lon=37.7929875}, {Node id=2612525102 version=1 V lat=47.9832695,lon=37.7929385}, {Node id=281819000 version=2 V lat=47.9808161,lon=37.7883548}, {Node id=281818900 version=3 VD lat=47.9843089,lon=37.7837324}]} refers to deleted primitive {Node id=281818900 version=3 VD lat=47.9843089,lon=37.7837324}


Plugins:
+ FastDraw (34867)
+ reltoolbox (34867)
+ reverter (34867)

Last errors/warnings:
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=412, Error Header=<Precondition failed: Node 278710543 is still used by ways 25569259.>
- E: Об’єкт все ще використовується - <html><strong>Збій</strong> вилучення <strong>точки 278710543</strong>. Вона все ще пов’язана з лінією 25569259.<br>Будь ласка, завантажте лінію, вилучіть прив’язку до точки та надішліть дані знову.<br><br>Натисніть <strong>Підготувати розв’язання конфлікту</strong> для їх завантаження.<br>У разі потреби JOSM створить конфлікт, який ви можете розв’язати на панелі Розв’язання конфліктів.</html>
- E: Error header: Precondition failed: Node 281692029 is still used by ways 25825243.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=412, Error Header=<Precondition failed: Node 281692029 is still used by ways 25825243.>
- E: Об’єкт все ще використовується - <html><strong>Збій</strong> вилучення <strong>точки 281692029</strong>. Вона все ще пов’язана з лінією 25825243.<br>Будь ласка, завантажте лінію, вилучіть прив’язку до точки та надішліть дані знову.<br><br>Натисніть <strong>Підготувати розв’язання конфлікту</strong> для їх завантаження.<br>У разі потреби JOSM створить конфлікт, який ви можете розв’язати на панелі Розв’язання конфліктів.</html>
- E: Error header: Precondition failed: Node 281818900 is still used by ways 25837399,25837399.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=412, Error Header=<Precondition failed: Node 281818900 is still used by ways 25837399,25837399.>
- E: Об’єкт все ще використовується - <html><strong>Збій</strong> вилучення <strong>точки 281818900</strong>. Вона все ще пов’язана з лінією 25837399.<br>Будь ласка, завантажте лінію, вилучіть прив’язку до точки та надішліть дані знову.<br><br>Натисніть <strong>Підготувати розв’язання конфлікту</strong> для їх завантаження.<br>У разі потреби JOSM створить конфлікт, який ви можете розв’язати на панелі Розв’язання конфліктів.</html>
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted node referenced: {Way id=25837399 version=13 MVT nodes=[{Node id=2612525104 version=1 V lat=47.9844171,lon=37.7837129}, {Node id=281819056 version=4 V lat=47.9846583,lon=37.7838331}, {Node id=281818903 version=3 V lat=47.9834464,lon=37.7929524}, {Node id=2612525103 version=1 V lat=47.9833503,lon=37.7929875}, {Node id=2612525102 version=1 V lat=47.9832695,lon=37.7929385}, {Node id=281819000 version=2 V lat=47.9808161,lon=37.7883548}, {Node id=281818900 version=3 VD lat=47.9843089,lon=37.7837324}]}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted node referenced: {Way id=25837399 version=13 MVT nodes=[{Node id=281819056 version=4 V lat=47.9846583,lon=37.7838331}, {Node id=281818903 version=3 V lat=47.9834464,lon=37.7929524}, {Node id=2612525103 version=1 V lat=47.9833503,lon=37.7929875}, {Node id=2612525102 version=1 V lat=47.9832695,lon=37.7929385}, {Node id=281819000 version=2 V lat=47.9808161,lon=37.7883548}, {Node id=281818900 version=3 VD lat=47.9843089,lon=37.7837324}]}


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (15) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted node referenced: {Way id=25837399 version=13 MVT nodes=[{Node id=281819056 version=4 V lat=47.9846583,lon=37.7838331}, {Node id=281818903 version=3 V lat=47.9834464,lon=37.7929524}, {Node id=2612525103 version=1 V lat=47.9833503,lon=37.7929875}, {Node id=2612525102 version=1 V lat=47.9832695,lon=37.7929385}, {Node id=281819000 version=2 V lat=47.9808161,lon=37.7883548}, {Node id=281818900 version=3 VD lat=47.9843089,lon=37.7837324}]}
	at org.openstreetmap.josm.data.osm.Way.checkNodes(Way.java:545)
	at org.openstreetmap.josm.data.osm.Way.fireNodesChanged(Way.java:561)
	at org.openstreetmap.josm.data.osm.Way.setNodes(Way.java:63)
	at org.openstreetmap.josm.data.osm.DataSet.unlinkNodeFromWays(DataSet.java:756)
	at org.openstreetmap.josm.data.osm.DataSet.unlinkReferencesToPrimitive(DataSet.java:816)
	at org.openstreetmap.josm.command.conflict.DeletedStateConflictResolveCommand.deleteMy(DeletedStateConflictResolveCommand.java:77)
	at org.openstreetmap.josm.command.conflict.DeletedStateConflictResolveCommand.executeCommand(DeletedStateConflictResolveCommand.java:60)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:79)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:289)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:331)
	at org.openstreetmap.josm.gui.dialogs.ConflictResolutionDialog$ApplyResolutionAction.actionPerformed(ConflictResolutionDialog.java:206)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.WaitDispatchSupport$2.run(Unknown Source)
	at java.awt.WaitDispatchSupport$4.run(Unknown Source)
	at java.awt.WaitDispatchSupport$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(Unknown Source)
	at java.awt.Dialog.show(Unknown Source)
	at java.awt.Component.show(Unknown Source)
	at java.awt.Component.setVisible(Unknown Source)
	at java.awt.Window.setVisible(Unknown Source)
	at java.awt.Dialog.setVisible(Unknown Source)
	at org.openstreetmap.josm.gui.ExtendedDialog.setVisible(ExtendedDialog.java:459)
	at org.openstreetmap.josm.gui.ExtendedDialog.showDialog(ExtendedDialog.java:255)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog.resolve(ConflictDialog.java:208)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog.access$200(ConflictDialog.java:78)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog$ResolveAction.actionPerformed(ConflictDialog.java:466)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 2 months ago by Don-vip

Description: modified (diff)
Summary: при зберіганні правкиDataIntegrityProblemException: Deleted node referenced

comment:2 Changed 5 weeks ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #6529.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.