Modify

Opened 17 months ago

Closed 17 months ago

Last modified 16 months ago

#17286 closed enhancement (fixed)

remember state of minimized docked panels

Reported by: MKnight Owned by: GerdP
Priority: normal Milestone: 19.02
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. dock a panel in josm
  2. minimize it (click on top of the panel)
  3. undock it
  4. dock it again (close)

What is the expected result?

panel should be minimized again

What happens instead?

panel is maximized

Please provide any additional information below. Attach a screenshot if possible.

Attachments (5)

1before.png (15.8 KB) - added by MKnight 17 months ago.
2undockit.png (17.5 KB) - added by MKnight 17 months ago.
3dockagain.png (19.7 KB) - added by MKnight 17 months ago.
17286glitch.gif (378.8 KB) - added by Klumbumbus 17 months ago.
hc_080.png (13.0 KB) - added by MKnight 17 months ago.
glitch-minimized

Download all attachments as: .zip

Change History (12)

Changed 17 months ago by MKnight

Attachment: 1before.png added

Changed 17 months ago by MKnight

Attachment: 2undockit.png added

Changed 17 months ago by MKnight

Attachment: 3dockagain.png added

comment:1 Changed 17 months ago by GerdP

Milestone: 19.02
Owner: changed from team to GerdP

I agree that this should be changed.

comment:2 Changed 17 months ago by GerdP

Resolution: fixed
Status: newclosed

In 14765/josm:

fix #17286 remember state of minimized docked panels when closing undocked panel

comment:3 Changed 17 months ago by Klumbumbus

Resolution: fixed
Status: closedreopened

There a graphic glitches after undocking an redocking a minimized panel, see gif below.

Last edited 17 months ago by Klumbumbus (previous) (diff)

Changed 17 months ago by Klumbumbus

Attachment: 17286glitch.gif added

comment:4 Changed 17 months ago by GerdP

I also sometimes see those glitches but I have no idea where they are produced. Any help is welcome.

Changed 17 months ago by MKnight

Attachment: hc_080.png added

glitch-minimized

comment:5 Changed 17 months ago by MKnight

dunno if it helps, looks like its not totally minimized.

https://josm.openstreetmap.de/attachment/ticket/17286/hc_080.png

comment:6 Changed 17 months ago by GerdP

Resolution: fixed
Status: reopenedclosed

In 14820/josm:

fix #17286: graphic glitches after undocking an redocking a minimized panel

comment:7 Changed 16 months ago by MKnight

thx.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain GerdP.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.