Modify

Opened 3 months ago

Last modified 4 weeks ago

#17266 reopened defect

Plugin "Download along" does not increment status popup

Reported by: wambacher Owned by: team
Priority: minor Milestone:
Component: Plugin download_along Version: tested
Keywords: Cc:

Description (last modified by GerdP)

The popup "Download along" does not increment the counter while downloading.

Reproduce: Select all elements of a boundary which has a lot of members like https://www.openstreetmap.org/relation/2029050. Then "download along".

current version: Josm 14620, plugin 34867
snapshot

Attachments (5)

download_along.png (31.1 KB) - added by wambacher 3 months ago.
snapshot
wrongAreas.PNG (94.8 KB) - added by GerdP 3 months ago.
Peek 2019-01-28 13-03.gif (1.2 MB) - added by wambacher 3 months ago.
animated gif
17266.patch (449 bytes) - added by GerdP 3 months ago.
17266-v2.patch (472 bytes) - added by GerdP 3 months ago.

Download all attachments as: .zip

Change History (34)

Changed 3 months ago by wambacher

Attachment: download_along.png added

snapshot

Changed 3 months ago by GerdP

Attachment: wrongAreas.PNG added

comment:1 Changed 3 months ago by GerdP

Description: modified (diff)

I cannot reproduce that with settings
downloadAlongWay.area 20.0
downloadAlongWay.distance 50.0
downloadAlongWay.download.gps false
What are your settings?

What I see is that the plugin seems to download areas which don't make sense, see .

comment:2 Changed 3 months ago by GerdP

I'll create a new ticket for my problem. Maybe yours is related, the calculation of the download areas is wrong.

comment:3 Changed 3 months ago by GerdP

Description: modified (diff)

comment:4 Changed 3 months ago by GerdP

see #17267. Please retry again with the new version later, the automatic build process is still working.

comment:5 Changed 3 months ago by wambacher

distance 200m, area=5 km

but that does not matter anyhow.

when i do the download, the result are 140 steps, but the counter permanently says "1/140".

and yes, sometimes the results are strange - but that is not the problem.

walter

hi gerd, ich hab verschiedene parameter für den download verwendet, es macht aber garnix aus. ich bekomme diesen Popup und der ändert sich solange nicht, bis die Aufgabe erledigt ist. damit weiss ich nicht, wie lange das noch dauert. also: bekommst du diesen Popup überhaupt?

Last edited 3 months ago by wambacher (previous) (diff)

comment:6 Changed 3 months ago by GerdP

I see the popup and the counter increases. Are you sure that you use r14620 without any patches?

comment:7 Changed 3 months ago by wambacher

yes, i do.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-12-31 15:09:58 +0100 (Mon, 31 Dec 2018)
Build-Date:2018-12-31 14:24:10
Revision:14620
Relative:URL: /trunk

wambacher@server2:~/osm/maven/missing_boundaries$ josm
Using /usr/lib/jvm/java-11-openjdk-amd64/bin/java to execute josm.
2019-01-28 12:44:03.811 INFORMATION: Protokollierungsgrad ist bei INFORMATION (INFO, 800)
2019-01-28 12:44:07.573 INFORMATION: Erweiterung 'jaxb' wird geladen (Version 34678)
2019-01-28 12:44:07.577 INFORMATION: Erweiterung 'log4j' wird geladen (Version 34527)
Warning: Nashorn engine is planned to be removed from a future JDK release
2019-01-28 12:44:10.301 INFORMATION: GET https://josm.openstreetmap.de/wiki/De:StartupPage -> 200
2019-01-28 12:44:10.760 WARNUNG: Not a single layer for the name 'AeroWest': []
2019-01-28 12:44:10.760 WARNUNG: Not a single layer for the name 'Bing Sat': []
2019-01-28 12:44:10.761 WARNUNG: Not a single layer for the name 'Bing Sat': []
2019-01-28 12:44:10.761 WARNUNG: Not a single layer for the name 'Bing Sat': []
2019-01-28 12:44:10.762 WARNUNG: Not a single layer for the name 'Bing Sat': []
2019-01-28 12:44:10.762 WARNUNG: Not a single layer for the name 'Bing Sat': []
2019-01-28 12:44:10.762 WARNUNG: Not a single layer for the name 'Bing Sat': []
2019-01-28 12:44:10.763 WARNUNG: Not a single layer for the name 'Bing Sat': []
2019-01-28 12:44:10.763 WARNUNG: Not a single layer for the name 'Bing Sat': []
2019-01-28 12:44:10.764 WARNUNG: Not a single layer for the name 'wms.wambachers-osm.website: Stadtteilgrenzen_KreisRE': []
2019-01-28 12:44:12.072 SCHWERWIEGEND: Fehler beim Laden des Bildes 'dialogs/up.png'
2019-01-28 12:44:12.073 WARNUNG: Sidewalk both: Could not get presets icon dialogs/up.png
2019-01-28 12:44:12.074 SCHWERWIEGEND: Fehler beim Laden des Bildes 'dialogs/previous.png'
2019-01-28 12:44:12.074 WARNUNG: Sidewalk left: Could not get presets icon dialogs/previous.png
2019-01-28 12:44:12.075 SCHWERWIEGEND: Fehler beim Laden des Bildes 'dialogs/next.png'
2019-01-28 12:44:12.075 WARNUNG: Sidewalk right: Could not get presets icon dialogs/next.png
2019-01-28 12:44:12.076 SCHWERWIEGEND: Fehler beim Laden des Bildes 'presets/way_unclassified.png'
2019-01-28 12:44:12.076 WARNUNG: Sidewalk no: Could not get presets icon presets/way_unclassified.png
2019-01-28 12:44:12.078 SCHWERWIEGEND: Fehler beim Laden des Bildes 'presets/bus_halt.png'
2019-01-28 12:44:12.079 WARNUNG: Bus Haltestelle/Schild: Could not get presets icon presets/bus_halt.png
Warning: Nashorn engine is planned to be removed from a future JDK release
2019-01-28 12:44:12.332 WARNUNG: Cannot lock cache directory. Will not use disk cache
2019-01-28 12:44:12.397 INFORMATION: Could not load tool definition continuosdownload/activate
2019-01-28 12:44:12.550 INFORMATION: Erweiterung 'reverter' wird geladen (Version 34867)
2019-01-28 12:44:12.567 INFORMATION: RemoteControl: adding command "revert_changeset" (handled by RevertChangesetHandler)
2019-01-28 12:44:12.570 INFORMATION: Erweiterung 'apache-commons' wird geladen (Version 34506)
2019-01-28 12:44:12.581 INFORMATION: Erweiterung 'reltoolbox' wird geladen (Version 34867)
2019-01-28 12:44:12.604 INFORMATION: Erweiterung 'jts' wird geladen (Version 34524)
2019-01-28 12:44:12.606 INFORMATION: Erweiterung 'ejml' wird geladen (Version 34389)
2019-01-28 12:44:12.628 INFORMATION: Erweiterung 'geotools' wird geladen (Version 34513)
2019-01-28 12:44:12.703 WARNUNG: No configuration settings found. Using hardcoded default values for all pools.
2019-01-28 12:44:13.165 INFORMATION: Warp/affine reduction enabled: true
2019-01-28 12:44:13.988 INFORMATION: dataFileCache open start
2019-01-28 12:44:14.219 INFORMATION: Erweiterung 'utilsplugin2' wird geladen (Version 34867)
2019-01-28 12:44:14.375 INFORMATION: Erweiterung 'HouseNumberTaggingTool' wird geladen (Version 34867)
2019-01-28 12:44:14.382 INFORMATION: Erweiterung 'opendata' wird geladen (Version 34867)
2019-01-28 12:44:14.411 INFORMATION: Erweiterung 'RoadSigns' wird geladen (Version 34867)
2019-01-28 12:44:14.465 INFORMATION: Erweiterung 'dataimport' wird geladen (Version 34749)
2019-01-28 12:44:14.470 INFORMATION: Erweiterung 'continuosDownload' wird geladen (Version 82)
2019-01-28 12:44:14.475 INFORMATION: Erweiterung 'pdfimport' wird geladen (Version 34867)
2019-01-28 12:44:14.483 INFORMATION: Erweiterung 'namemanager' wird geladen (Version 34867)
2019-01-28 12:44:14.488 INFORMATION: Erweiterung 'terracer' wird geladen (Version 34867)
2019-01-28 12:44:14.502 INFORMATION: Erweiterung 'wikipedia' wird geladen (Version v1.1.1)
2019-01-28 12:44:14.632 INFORMATION: Erweiterung 'PicLayer' wird geladen (Version 34867)
2019-01-28 12:44:14.662 INFORMATION: Erweiterung 'DirectUpload' wird geladen (Version 34867)
2019-01-28 12:44:14.667 INFORMATION: Erweiterung 'geojson' wird geladen (Version 116)
2019-01-28 12:44:14.671 INFORMATION: Erweiterung 'pbf' wird geladen (Version 34576)
2019-01-28 12:44:14.680 INFORMATION: Erweiterung 'photo_geotagging' wird geladen (Version 34867)
2019-01-28 12:44:14.711 INFORMATION: Erweiterung 'OpeningHoursEditor' wird geladen (Version 34867)
2019-01-28 12:44:14.737 INFORMATION: Erweiterung 'poly' wird geladen (Version 34867)
2019-01-28 12:44:14.740 INFORMATION: Erweiterung 'undelete' wird geladen (Version 34867)
2019-01-28 12:44:14.762 INFORMATION: Erweiterung 'buildings_tools' wird geladen (Version 34867)
2019-01-28 12:44:14.788 INFORMATION: Erweiterung 'Tracer2' wird geladen (Version 34867)
2019-01-28 12:44:14.872 INFORMATION: Erweiterung 'download_along' wird geladen (Version 34867)
2019-01-28 12:44:14.874 INFORMATION: Reassigning shortcut 'tools:download_along' from null to 576 because of conflict with Alt+Umschalt+D
2019-01-28 12:44:14.874 INFORMATION: Tastenkürzelkonflikt: 'tools:download_along' wurde von 'continuosdownload:activate' auf 'Alt+Umschalt+F1' verschoben.
2019-01-28 12:44:15.317 WARNUNG: Cannot start IPv4 remotecontrol server on port 8111: Die Adresse wird bereits verwendet (Bind failed)
2019-01-28 12:44:15.317 WARNUNG: Cannot start IPv6 remotecontrol server on port 8111: Die Adresse wird bereits verwendet (Bind failed)
2019-01-28 12:44:15.358 WARNUNG: Cannot start IPv4 remotecontrol https server on port 8112: Die Adresse wird bereits verwendet (Bind failed)
2019-01-28 12:44:15.360 WARNUNG: Cannot start IPv6 remotecontrol https server on port 8112: Die Adresse wird bereits verwendet (Bind failed)
2019-01-28 12:44:15.364 INFORMATION: Message notifier active (checks every 5 minutes)
2019-01-28 12:44:15.381 INFORMATION: Changeset updater active (checks every 60 minutes if open changesets have been closed)
2019-01-28 12:44:15.446 INFORMATION: GET http://www.openstreetmap.org/api/0.6/user/details (Anzahl der ungelesenen Nachrichten abrufen) -> 301 (345 B)
2019-01-28 12:44:15.446 INFORMATION: Herunterladen umgelenkt auf 'https://www.openstreetmap.org/api/0.6/user/details'
2019-01-28 12:44:15.724 INFORMATION: GET https://www.openstreetmap.org/api/0.6/user/details (Anzahl der ungelesenen Nachrichten abrufen) -> 200 (614 B)
wambacher@server2:~/osm/maven/missing_boundaries$

some minor warnings, but that is not important, i think.

comment:8 Changed 3 months ago by GerdP

Maybe a problem with the JRE? I use java version "1.8.0_201"

Changed 3 months ago by wambacher

Attachment: Peek 2019-01-28 13-03.gif added

animated gif

comment:9 Changed 3 months ago by wambacher

added animated gif.

comment:10 Changed 3 months ago by wambacher

wambacher@server2:~/osm/maven/boundaries_work/alb$ java -version
openjdk version "11.0.1" 2018-10-16
OpenJDK Runtime Environment (build 11.0.1+13-Ubuntu-2ubuntu1)
OpenJDK 64-Bit Server VM (build 11.0.1+13-Ubuntu-2ubuntu1, mixed mode, sharing)
wambacher@server2:~/osm/maven/boundaries_work/alb$

but 2-3 month before running java 1.8 - same problem.

Last edited 3 months ago by wambacher (previous) (diff)

comment:11 Changed 3 months ago by GerdP

Do you see a progress in other popups? E.g. when you use continousDownload?

comment:12 Changed 3 months ago by GerdP

I've just tried with

openjdk version "11.0.1" 2018-10-16
OpenJDK Runtime Environment 18.9 (build 11.0.1+13)
OpenJDK 64-Bit Server VM 18.9 (build 11.0.1+13, mixed mode)

No problems on Windows. Don't know how to make an animated gif, so you have to trust me ;)

comment:13 Changed 3 months ago by simon04

I cannot reproduce neither.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-12-31 15:09:58 +0100 (Mon, 31 Dec 2018)
Build-Date:2018-12-31 14:24:10
Revision:14620
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14620 en_GB) Linux Arch Linux
Memory Usage: 1338 MB / 3506 MB (849 MB allocated, but free)
Java version: 1.8.0_202-b26, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Djosm.home=<josm.pref>]
Dataset consistency test: No problems found

Plugins:
+ download_along (34869)

@wambacher: Please retry having only the download_along plugin enabled, e.g., using josm.home from Help/CommandLineOptions#Javaoptions. Otherwise this issue seems to be impossible to reproduce/debug.

comment:14 Changed 3 months ago by wambacher

Bingo: new empty home for josm, the only plugin is "download_along"

---> problem gone. :)

give me some time to find the reason. you can close this ticket and may be, i'll open a new one asap.

Last edited 3 months ago by wambacher (previous) (diff)

comment:15 Changed 3 months ago by GerdP

Maybe you now have the newer plugin version.

comment:16 Changed 3 months ago by wambacher

yes, the plugin version was wrong.

old log: 2019-01-28 12:44:14.872 INFORMATION: Erweiterung 'download_along' wird geladen (Version 34867)

new log: 2019-01-28 14:12:20.715 INFORMATION: Erweiterung 'download_along' wird geladen (Version 34869)

But the problem is not gone in the live josm. only test josm is running fine.

comment:17 Changed 3 months ago by wambacher

activated all plugins in test josm --> no problem

now i'll check preferences and local profile :(

comment:18 Changed 3 months ago by wambacher

Using my old preferences.xml brings the problem back :(

will check it in the next 1-2 days.

comment:19 Changed 3 months ago by simon04

Resolution: worksforme
Status: newclosed

Please reopen this ticket if you find a way to reproduce it w/ a fresh config.

comment:20 Changed 3 months ago by wambacher

It's crasy.

OSM Server address = default (https://api.openstreetmap.org) --> OK
OSM server address = http://api.openstreetmap.org) --> problem

and yes, my josm was using http :(

using http josm does a reconnect to https. may be that is the reason?

2019-01-30 10:42:43.826 INFORMATION: GET http://www.openstreetmap.org/api/0.6/map?bbox=28.0472217,51.5538382,28.0741319,51.5556308 -> 301 (385 B)
2019-01-30 10:42:43.827 INFORMATION: Herunterladen umgelenkt auf 'https://www.openstreetmap.org/api/0.6/map?bbox=28.0472217,51.5538382,28.0741319,51.5556308'
2019-01-30 10:42:43.983 INFORMATION: GET https://www.openstreetmap.org/api/0.6/map?bbox=28.0472217,51.5538382,28.0741319,51.5556308 -> 200
2019-01-30 10:42:44.094 INFORMATION: GET http://www.openstreetmap.org/api/0.6/map?bbox=28.03487,51.5715121,28.0741319,51.5733135 -> 301 (383 B)
2019-01-30 10:42:44.095 INFORMATION: Herunterladen umgelenkt auf 'https://www.openstreetmap.org/api/0.6/map?bbox=28.03487,51.5715121,28.0741319,51.5733135'
2019-01-30 10:42:44.149 INFORMATION: GET https://www.openstreetmap.org/api/0.6/map?bbox=28.03487,51.5715121,28.0741319,51.5733135 -> 200
Last edited 3 months ago by GerdP (previous) (diff)

comment:21 Changed 3 months ago by wambacher

Resolution: worksforme
Status: closedreopened

comment:22 Changed 3 months ago by GerdP

For me, http://api.openstreetmap.org doesn't work at all. One proably has to change more than that.

comment:24 Changed 3 months ago by GerdP

I get an error when I use that address:

2019-01-30 18:04:18.161 FINE: Bad OAuth request.
2019-01-30 18:04:18.188 SEVERE: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<Bad OAuth request.>
org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<Bad OAuth request.>

comment:25 Changed 3 months ago by GerdP

I was finally able to reproduce it with http://master.apis.dev.openstreetmap.org/api. Working on it...

Changed 3 months ago by GerdP

Attachment: 17266.patch added

comment:26 Changed 3 months ago by GerdP

With 17266.patch it works for both http and https.
Please review:
Class HttpClient starts a new subtask monitor in line 133. I found no place where this is finished. The patch changes this.
No idea if there is a case where this causes trouble. So far I found none.

comment:27 Changed 3 months ago by GerdP

Arg, patch doesn't work with undelete plugin when undeleting multiple objects using https.
So, sorry, that's too complex for me :(

Changed 3 months ago by GerdP

Attachment: 17266-v2.patch added

comment:28 Changed 3 months ago by GerdP

With v2 it seems to work better. Now progressMonitor.finishTask() is only called if the connection was not established.
That's probably what is missing because the redirect calls another connect() which means one more progressMonitor.beginTask(tr("Contacting Server..."), 1).

Hope this helps, I'll not commit this since my knowledge about this stuff is poor. With the first patch you get much uglier problems than a "missing progress" ;)

comment:29 Changed 4 weeks ago by GerdP

Please can somebody look at patch v2?

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to wambacher
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.