Modify

Opened 3 months ago

Closed 4 weeks ago

#17236 closed defect (duplicate)

DataIntegrityProblemException: Deleted member referenced

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report conflict Cc:

Description

What steps will reproduce the problem?

  1. Mapping
  2. Some mapping
  3. More mapping

What is the expected result?

Maps

What happens instead?

Crash

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-12-31 15:09:58 +0100 (Mon, 31 Dec 2018)
Build-Date:2018-12-31 14:24:10
Revision:14620
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14620 fr) Linux Ubuntu 18.04.1 LTS
Memory Usage: 796 MB / 1276 MB (43 MB allocated, but free)
Java version: 1.8.0_171-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1366x768
Maximum Screen Size: 1366x768
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]

Dataset consistency test:
[DELETED REFERENCED] {Relation id=8188526 version=4 VT [nœud 287784197, chemin 577537499, chemin 577537495, chemin 577537498, chemin 577537497, chemin 606174807, chemin 50736277, chemin 606172732, chemin 574894742, chemin 574894747]} refers to deleted primitive {Way id=577537495 version=1 MVD nodes=[]}
[DELETED REFERENCED] {Relation id=8188526 version=4 VT [nœud 287784197, chemin 577537499, chemin 577537495, chemin 577537498, chemin 577537497, chemin 606174807, chemin 50736277, chemin 606172732, chemin 574894742, chemin 574894747]} refers to deleted primitive {Way id=577537498 version=1 MVD nodes=[]}
[DELETED REFERENCED] {Relation id=8189528 version=3 VT [chemin 578235861, chemin 577600974, chemin 577537495, chemin 577537498, chemin 577537497, chemin 577537489, chemin 577600978, chemin -230860, chemin -230859, chemin 577600975, nœud 292779234]} refers to deleted primitive {Way id=577537495 version=1 MVD nodes=[]}
[DELETED REFERENCED] {Relation id=8189528 version=3 VT [chemin 578235861, chemin 577600974, chemin 577537495, chemin 577537498, chemin 577537497, chemin 577537489, chemin 577600978, chemin -230860, chemin -230859, chemin 577600975, nœud 292779234]} refers to deleted primitive {Way id=577537498 version=1 MVD nodes=[]}


Plugins:
+ PicLayer (34544)
+ ShapeTools (1240)
+ apache-commons (34506)
+ ejml (34389)
+ ext_tools (34509)
+ geotools (34513)
+ jaxb (34506)
+ jts (34524)
+ measurement (34529)
+ opendata (34805)
+ utilsplugin2 (34793)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
- http://www.openrailwaymap.org/styles/josm-additional.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&zip=1

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: Conflits détectés - <html>23 conflits ont été détectés.</html>
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted member referenced: {Relation id=8189528 version=3 VT [chemin 578235861, chemin 577600974, chemin 577537495, chemin 577537498, chemin 577537497, chemin 577537489, chemin 577600978, chemin -230860, chemin -230859, chemin 577600975, nœud 292779234]}


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (16) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted member referenced: {Relation id=8189528 version=3 VT [chemin 578235861, chemin 577600974, chemin 577537495, chemin 577537498, chemin 577537497, chemin 577537489, chemin 577600978, chemin -230860, chemin -230859, chemin 577600975, nœud 292779234]}
	at org.openstreetmap.josm.data.osm.Relation.checkMembers(Relation.java:476)
	at org.openstreetmap.josm.data.osm.Relation.fireMembersChanged(Relation.java:488)
	at org.openstreetmap.josm.data.osm.Relation.setMembers(Relation.java:59)
	at org.openstreetmap.josm.data.osm.Relation.cloneFrom(Relation.java:243)
	at org.openstreetmap.josm.command.ChangeCommand.executeCommand(ChangeCommand.java:65)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:79)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:289)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:331)
	at org.openstreetmap.josm.actions.SplitWayAction.doSplitWay(SplitWayAction.java:293)
	at org.openstreetmap.josm.actions.SplitWayAction$SegmentToKeepSelectionDialog.buttonAction(SplitWayAction.java:235)
	at org.openstreetmap.josm.gui.ExtendedDialog$1.actionPerformed(ExtendedDialog.java:378)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.Component.processMouseEvent(Component.java:6533)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2238)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2296)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4897)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4534)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4475)
	at java.awt.Container.dispatchEventImpl(Container.java:2282)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:760)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:90)
	at java.awt.EventQueue$4.run(EventQueue.java:733)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:730)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (2)

comment:1 Changed 3 months ago by Don-vip

Summary: Mapping ends in crashDataIntegrityProblemException: Deleted member referenced

comment:2 Changed 4 weeks ago by Don-vip

Keywords: conflict added
Resolution: duplicate
Status: newclosed

Closed as duplicate of #6529.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.