Modify

Opened 4 weeks ago

Closed 3 weeks ago

#17228 closed defect (fixed)

Session (.jos) with gpx in subfolder : error loading layer

Reported by: StephaneP Owned by: team
Priority: normal Milestone: 19.01
Component: Core Version: latest
Keywords: session windows regression Cc: simon04

Description

Hi!
When I load a .jos session in Josm (Windows) with a nmea file stored in a subfolder, Josm can't load the file and give me this error:

2019-01-21 18:18:28.112 INFO: Open file: C:\pei\session1.jos (662 bytes)
2019-01-21 18:18:28.166 SEVERE: java.io.IOException: java.net.URISyntaxException: Illegal character in path at index 4: nmea\btnmeatrack_2019-01-19_11-44-01.nmea. Cause: java.net.URISyntaxException: Illegal character in path at index 4: nmea\btnmeatrack_2019-01-19_11-44-01.nmea
java.io.IOException: java.net.URISyntaxException: Illegal character in path at index 4: nmea\btnmeatrack_2019-01-19_11-44-01.nmea
        at org.openstreetmap.josm.io.session.SessionReader$ImportSupport.getFile(SessionReader.java:359)
        at org.openstreetmap.josm.io.session.SessionReader$ImportSupport.getInputStream(SessionReader.java:302)
        at org.openstreetmap.josm.io.session.GpxTracksSessionImporter.load(GpxTracksSessionImporter.java:45)
        at org.openstreetmap.josm.io.session.SessionReader.parseJos(SessionReader.java:563)
        at org.openstreetmap.josm.io.session.SessionReader.loadSession(SessionReader.java:746)
        at org.openstreetmap.josm.io.session.SessionReader.loadSession(SessionReader.java:706)
        at org.openstreetmap.josm.actions.SessionLoadAction$Loader.realRun(SessionLoadAction.java:180)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:95)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:143)
        at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
        at java.util.concurrent.FutureTask.run(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.net.URISyntaxException: Illegal character in path at index 4: nmea\btnmeatrack_2019-01-19_11-44-01.nmea
        at java.net.URI$Parser.fail(Unknown Source)
        at java.net.URI$Parser.checkChars(Unknown Source)
        at java.net.URI$Parser.parseHierarchical(Unknown Source)
        at java.net.URI$Parser.parse(Unknown Source)
        at java.net.URI.<init>(Unknown Source)
        at org.openstreetmap.josm.io.session.SessionReader$ImportSupport.getFile(SessionReader.java:330)
        ... 13 more

No problem with Ubuntu

Attachments (1)

session1.jos (662 bytes) - added by StephaneP 4 weeks ago.

Download all attachments as: .zip

Change History (4)

Changed 4 weeks ago by StephaneP

Attachment: session1.jos added

comment:1 Changed 4 weeks ago by Don-vip

Cc: simon04 added
Keywords: windows added

comment:2 Changed 3 weeks ago by simon04

Keywords: regression added
Milestone: 19.01
Version: latest

Regression of r14630.

comment:3 Changed 3 weeks ago by simon04

Resolution: fixed
Status: newclosed

In 14723/josm:

see #16497 fix #17228 - Avoid backslashes in session files

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.