Modify

Opened 9 days ago

Closed 7 days ago

#17191 closed defect (fixed)

[PATCH] Plugin osm-obj-info crashes when Mapillary is clicked and nothing is selected

Reported by: taylor.smock Owned by: Rub21
Priority: normal Milestone:
Component: Plugin osm-obj-info Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Open JOSM
  2. Download arbitrary area (doesn't matter)
  3. Click on the Mapillary icon

What is the expected result?

Nothing happens OR a something saying "nothing selected"

What happens instead?

An exception occurs

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-01-08 21:33:32 +0100 (Tue, 08 Jan 2019)
Revision:14668
Build-Date:2019-01-09 02:32:11
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (14668 en) Mac OS X 10.14.2
OS Build number: Mac OS X 10.14.2 (18C54)
Memory Usage: 359 MB / 2048 MB (117 MB allocated, but free)
Java version: 11.0.1+13, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: Display 188945226 1920x1080, Display 69978068 2048x1152
Maximum Screen Size: 2048x1152
Dataset consistency test: No problems found

Plugins:
+ Mapillary (v1.5.17)
+ apache-commons (34506)
+ apache-http (34632)
+ auto_tools (67)
+ buildings_tools (34807)
+ download_along (34503)
+ ejml (34389)
+ geotools (34513)
+ graphview (34576)
+ imagery_offset_db (34641)
+ jaxb (34506)
+ jna (34633)
+ jts (34524)
+ kaartvalidation (1544737498)
+ opendata (34805)
+ osm-obj-info (49)
+ reverter (34552)
+ rex (49)
+ tageditor (34560)
+ turnrestrictions (34643)
+ utilsplugin2 (34793)

Tagging presets:
+ http://zibi.openstreetmap.org.pl/kendzi/k/Simple3dPreset/s3db-preset.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Simple_Indoor_Tagging&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/HiDPISupport&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/DestinationSignRelation&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Noname&zip=1
+ ${HOME}/workspace/osm/JOSM Paint Styles and Presets/Kaart Styles 3.1.mapcss
+ /Volumes/Clingstone/JOSM Paint Styles and Presets/Overlapping Ways.mapcss
+ https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NewHighwayColors&zip=1

Validator rules:
+ ${HOME}/workspace/osm/kaart.validator.mapcss

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Skipping to the next rule, because of an error:
- E: org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Encountered " <REGEX> "/^name/ "" at line 446, column 3.
- W: Failed to add ${HOME}/workspace/osm/kaart.validator.mapcss to tag checker
- W: org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Encountered " "+" "+ "" at line 446, column 21.
- W: Cannot start IPv4 remotecontrol server on port 8111: Address already in use (Bind failed)
- W: Cannot start IPv6 remotecontrol server on port 8111: Address already in use (Bind failed)
- W: Cannot start IPv4 remotecontrol https server on port 8112: Address already in use (Bind failed)
- W: Cannot start IPv6 remotecontrol https server on port 8112: Address already in use (Bind failed)
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: Index 1 out of bounds for length 1


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (23) of main
java.lang.ArrayIndexOutOfBoundsException: Index 1 out of bounds for length 1
	at org.openstreetmap.josm.plugins.osmobjinfo.OSMObjInfoActions.openinBrowserMapillary(OSMObjInfoActions.java:106)
	at org.openstreetmap.josm.plugins.osmobjinfo.OSMObjInfotDialog$15.mouseClicked(OSMObjInfotDialog.java:363)
	at java.desktop/java.awt.Component.processMouseEvent(Component.java:6635)
	at java.desktop/javax.swing.JComponent.processMouseEvent(JComponent.java:3342)
	at java.desktop/java.awt.Component.processEvent(Component.java:6397)
	at java.desktop/java.awt.Container.processEvent(Container.java:2263)
	at java.desktop/java.awt.Component.dispatchEventImpl(Component.java:5008)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2321)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4840)
	at java.desktop/java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4918)
	at java.desktop/java.awt.LightweightDispatcher.processMouseEvent(Container.java:4556)
	at java.desktop/java.awt.LightweightDispatcher.dispatchEvent(Container.java:4488)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2307)
	at java.desktop/java.awt.Window.dispatchEventImpl(Window.java:2772)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4840)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:772)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:95)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:745)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:743)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:742)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

Attachments (1)

infoactions.patch (1.2 KB) - added by taylor.smock 9 days ago.
Possible defensive implementation

Download all attachments as: .zip

Change History (2)

Changed 9 days ago by taylor.smock

Attachment: infoactions.patch added

Possible defensive implementation

comment:1 Changed 7 days ago by Don-vip

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Rub21.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.