Modify

Opened 3 months ago

Closed 7 weeks ago

#17162 closed defect (fixed)

Japanese translation replaced by Korean

Reported by: LuxuryCoop Owned by: team
Priority: critical Milestone: 19.01
Component: Core Version:
Keywords: i18n regression japan Cc: stoecker, simon04, GerdP

Description

I uploaded a traslation(.po) file to Launchpad for Korean few weeks ago, but actually the file was imported in Japanese translation due to my mistake.
Then I had seen error messege that the import failed, so I think no problem was occoured.
However, I just knew there are successful some import.

Is it possible that Translation in Japanese revert to before version 14620? I can't repair the translation in Launchpad, and the faults is too many to revert one by one.
I'm sorry about my huge mistake.

Attachments (1)

ja_ko.png (37.2 KB) - added by Don-vip 3 months ago.

Download all attachments as: .zip

Change History (25)

comment:1 Changed 3 months ago by Don-vip

Cc: stoecker added
Keywords: i18n added

Dirk, any idea?

comment:2 Changed 3 months ago by Don-vip

It seems someone reuploaded the japanese translations already:
Uploaded by Yuki Shira on 2019-01-01 02:15:07 UTC

https://bazaar.launchpad.net/~openstreetmap/josm/josm_trans/revision/2501#josm/ja.po

comment:3 Changed 3 months ago by stoecker

"Yuki Shira" uploaded ja.po today at 02:15 UTC.

Sounds like a hotfix is necessary...

comment:4 Changed 3 months ago by Don-vip

Translations look fine now, but all entries are marked "for review" with the korean translation being suggested. Is there a way to dismiss suggestions in batch? There's 4866 strings, too much to dismiss individually.

comment:5 Changed 3 months ago by Don-vip

Keywords: regression added
Milestone: 18.12

comment:6 Changed 3 months ago by Shirayuki

I have dismissed all Korean translation suggestion with using Tampermonkey.

But there are 300+ Korean translations still remain and they should be removed.

Use this regular expression to find Korean characters: [가-힣]

Last edited 3 months ago by Shirayuki (previous) (diff)

comment:7 Changed 3 months ago by stoecker

When you download the current ja.po, then you can replace the wrong strings with "" and upload again to remove them (or translate them instead :-).

You need a current downloaded file, as the header contains information about the launchpad time.

It's better, when one of you does this. For us Europeans it simply looks too similar...

comment:8 Changed 3 months ago by stoecker

Downloading current file, copying the header lines into a pre-error-file and uploading again can do a "reset". But if there have been changes inbetween, they will be lost in this case.

Most important header is the "X-Launchpad-Export-Date".

Historic files can be found here: https://code.launchpad.net/~openstreetmap/josm/josm_trans

comment:9 Changed 3 months ago by Shirayuki

At first, I replaced the wrong strings with "" and uploaded, but launchpad completely ignored empty strings :(

So we have replaced the remaining wrong strings manually.

I think you can release a hotfix.

comment:10 Changed 3 months ago by stoecker

At first, I replaced the wrong strings with "" and uploaded, but launchpad completely ignored empty strings :(

Was the "X-Launchpad-Export-Date" after the error date? Otherwise Launchpad assumes you uploaded an old file and thus ignores changes which reverse the last modifications.

I think you can release a hotfix.

It needs a bit until the changes are in BZR for the i18n tools.

comment:11 Changed 3 months ago by Shirayuki

As I did not know about "reset", I uploaded ja.po file with this header:

"X-Launchpad-Export-Date: 2019-01-01 00:25+0000\n"

I used Japanese translations in ja.po (revision 2480) which has this header:

"X-Launchpad-Export-Date: 2018-12-10 04:53+0000\n"

comment:12 Changed 3 months ago by Don-vip

I will do an i18n update tomorrow to get latest changes from Launchpad. I'll let you check it to be sure the hotfix is correct before releasing it.

Changed 3 months ago by Don-vip

Attachment: ja_ko.png added

comment:13 Changed 3 months ago by Don-vip

Dirk, we should update the i18n script to detect this kind of mistake early. In this case we had the opportunity to detect the error by checking the value of following lines:

  • Korean translation for josm => Japanese translation for josm
  • Language-Team : Korean <ko@…>\n => Language-Team : Japanese <tr@…>\n
  • Language: ko\n => Language: ja\n

Probably checking the "Language" line is pretty straightforward.


comment:14 Changed 2 months ago by Don-vip

In 14661/josm:

see #17162 - i18n update

comment:15 Changed 2 months ago by Don-vip

@Shirayuki can you please check if Japanese translations are ok now?

comment:16 Changed 2 months ago by Shirayuki

I have checked josm-snapshot-14663.jar and josm_josm-ja.po.
I have no problem with Japanese translations :)

But could you remove LuxuryCoop from Japanese translation contributors list? :P

comment:17 in reply to:  16 ; Changed 2 months ago by stoecker

But could you remove LuxuryCoop from Japanese translation contributors list? :P

No. That's automatic...

Even if it was a bad contribution, it was one :-)

comment:18 in reply to:  17 Changed 2 months ago by Don-vip

Replying to stoecker:

But could you remove LuxuryCoop from Japanese translation contributors list? :P

No. That's automatic...

Even if it was a bad contribution, it was one :-)

On the same topic you and I are also "contributors" of almost every language. It doesn't mean we speak 30+ languages, just that we fixed a lot of (technical) translation errors :)

comment:19 Changed 2 months ago by stoecker

You don't speak. Shame on you. I thought you do. 😛

comment:20 Changed 2 months ago by Don-vip

Cc: simon04 GerdP added

Sorry, I don't even know enough German to order something different from beer or sausages... :)

So. If this issue is fixed we can release an hotfix now.

@Simon, Gerd: as there has been a lot of changes since a few days, do you feel comfortable with promoting current JOSM as new tested version, or do you need a few days to stabilize any work in progress? Maybe we could wait to fix the keyboard issue #13160 first.

comment:21 Changed 2 months ago by GerdP

I am still trying to find the first version that shows #13160. For me it is working fine with r10533. No other important work in progress.

comment:22 Changed 2 months ago by simon04

@Don-vip: I tried to be careful. However, the commits r14628, r14653 might introduce unexpected behaviour in unforeseen cases (which we be detected not before releasing a new tested version), and I hope to not have introduced any regression in r14654. My other commits should be unproblematic.

comment:23 Changed 2 months ago by Don-vip

Keywords: japan added
Milestone: 18.1219.01
Summary: My mistake for Japanese translationJapanese translation replaced by Korean

comment:24 Changed 7 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.