Modify

Opened 4 months ago

Closed 4 months ago

#17051 closed defect (fixed)

Can't copy and paste an object

Reported by: naoliv Owned by: team
Priority: normal Milestone: 18.12
Component: Core Version:
Keywords: Cc:

Description

Open the attached file, select that small round building at the middle, copy (Ctrl+C) and try to paste:

https://i.imgur.com/UOMUPRN.png

This object was restored (ie, it was previously deleted and I am restoring it now), but this shouldn't interfere while copying it and pasting as a new object, right?

JOSM:

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-11-28 01:09:01 +0100 (Wed, 28 Nov 2018)
Revision:14460
Build-Date:2018-11-28 00:26:41
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (14460 en) Linux Debian GNU/Linux testing (buster)
Memory Usage: 855 MB / 6144 MB (535 MB allocated, but free)
Java version: 11.0.1+13-Debian-2, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900, :0.1 1280x1024
Maximum Screen Size: 1600x1024
Java package: openjdk-11-jre:amd64-11.0.1+13-2
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-21
VM arguments: [-Dawt.useSystemAAFontSettings=gasp]
Program arguments: [--language=en]
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34535)
+ PicLayer (34544)
+ SimplifyArea (34586)
+ apache-commons (34506)
+ buildings_tools (34724)
+ download_along (34503)
+ ejml (34389)
+ geojson (87)
+ geotools (34513)
+ jaxb (34506)
+ jts (34524)
+ log4j (34527)
+ measurement (34529)
+ merge-overlap (34664)
+ opendata (34698)
+ poly (34546)
+ reverter (34552)
+ tageditor (34560)
+ todo (30306)
+ turnlanes-tagging (272)
+ turnrestrictions (34643)
+ undelete (34568)
+ utilsplugin2 (34506)

Attachments (2)

problem.joz (87.8 KB) - added by naoliv 4 months ago.
data.osm (2.0 KB) - added by stoecker 4 months ago.
mini-example

Download all attachments as: .zip

Change History (9)

Changed 4 months ago by naoliv

Attachment: problem.joz added

comment:1 Changed 4 months ago by stoecker

Resolution: wontfix
Status: newclosed

You can't create a new object referencing non-existing data. Simply make the relation not-incomplete (i.e. download the missing members before) to fix the problem.

Incomplete objects aren't available for most editing actions for a good reason.

comment:2 Changed 4 months ago by naoliv

It's a simple building (a way with 8 nodes), not a relation.
I am copying a geometry that that I can see, move and edit in JOSM.

If I ask to download the related ways/relations nothing happens.
I would expect it to to copy the way (with its 8 nodes) and paste it as a new way with 8 nodes.

And I also fail to see why JOSM thinks that this object is incomplete.

Last edited 4 months ago by naoliv (previous) (diff)

comment:3 Changed 4 months ago by GerdP

Seems the problem is that the nodes have the status "deleted-on-server modified"

comment:4 Changed 4 months ago by stoecker

It's a simple building (a way with 8 nodes), not a relation.

Ah sorry.

And I also fail to see why JOSM thinks that this object is incomplete.

Right.

comment:5 Changed 4 months ago by stoecker

Resolution: wontfix
Status: closedreopened

Changed 4 months ago by stoecker

Attachment: data.osm added

mini-example

comment:6 Changed 4 months ago by stoecker

Milestone: 18.12

JOSM probably should offer to add them "undeleted".

comment:7 Changed 4 months ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 14493/josm:

fix #17051 - allow to copy/paste undeleted objects

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.