Modify

Opened 5 years ago

Closed 4 years ago

#17048 closed task (fixed)

High DPI on Windows 10

Reported by: gpermant@… Owned by: gpermant@…
Priority: normal Milestone:
Component: Core Version: latest
Keywords: windows hidpi gsoc-candidate Cc: gpermant

Description (last modified by Don-vip)

What steps will reproduce the problem?

Opening JOSM on my new laptop, with Win 10 and 3840x2160 resolution

What is the expected result?

Legible text in all parts of JOSM

What happens instead?

Text is very small, hardly legible.
In Lists and trees, text overlaps.

Please provide any additional information below. Attach a screenshot if possible.

Screenshot of overlapping, non-legible text in JOSM

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-11-28 01:09:01 +0100 (Wed, 28 Nov 2018)
Build-Date:2018-11-28 00:26:41
Revision:14460
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14460 de) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1803 (17134)
Memory Usage: 628 MB / 1820 MB (202 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 3840x2160
Maximum Screen Size: 3840x2160
Dataset consistency test: No problems found

Plugins:
+ imagery_offset_db (34641)
+ turnrestrictions (34643)

Last errors/warnings:
- W: Erweiterungen aktualisieren - org.openstreetmap.josm.plugins.PluginHandler$UpdatePluginsMessagePanel[,0,0,0x0,invalid,layout=java.awt.GridBagLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (1)

Overlapping text.JPG (134.4 KB ) - added by gpermant 5 years ago.
Screenshot of overlapping, non-legible text in JOSM

Download all attachments as: .zip

Change History (17)

by gpermant, 5 years ago

Attachment: Overlapping text.JPG added

Screenshot of overlapping, non-legible text in JOSM

comment:1 by Don-vip, 5 years ago

Description: modified (diff)
Keywords: windows hidpi added
Owner: changed from team to gpermant@…
Status: newneedinfo

High DPI on Windows requires Java >= 9. Please try with latest version of Java (11 right now)

comment:2 by Don-vip, 5 years ago

Keywords: View removed
Summary: On my new laptop under Windows 10, text in JOSM is very small, and overlapsHigh DPI on Windows 10

comment:3 by Don-vip, 5 years ago

See also #9995

in reply to:  1 comment:4 by anonymous, 5 years ago

Replying to Don-vip:

High DPI on Windows requires Java >= 9. Please try with latest version of Java (11 right now)

Uugh!
I cannot switch to Java 9 all of a sudden.
All my own projects are based on Java 8.
I am convinced there are thousands out there in the same situation...

comment:5 by GerdP, 5 years ago

You can use the newer JRE for JOSM only and the older for your projects.

comment:6 by gpermant, 5 years ago

I managed to download and install an early access version of JRE 11 from softfamous.com. That, however, has expired on 16 Nov and I get all sorts of warnings. The JRE does not seem to be generally available yet.

Be that as it may: JOSM now is legible again and can be operated.
Thanks for the hint!
And I will see when there will be an up to date Version of JRE 11.

in reply to:  6 comment:7 by Don-vip, 5 years ago

Replying to gpermant:

I managed to download and install an early access version of JRE 11 from softfamous.com. That, however, has expired on 16 Nov and I get all sorts of warnings. The JRE does not seem to be generally available yet.

Wow, be careful. This download looks like crap and could be potentially harmful (infected by virus).

Java is currently going through major changes and we won't advise to download it from Oracle soon. Right now the best way to get Java 11 is either from adoptopenjdk or Azul (Zulu).

comment:8 by gpermant, 5 years ago

Wow, be careful. This download looks like crap and could be potentially harmful (infected by virus).

I had no problems with it, just the warnings...
anyway, I have since changed to the official Java JDK 11.0.1 from Oracle.
As I am developing in Java too, I will need it.

But now: how do I tell JOSM to use the JRE that came with the JDK 11?
It is now back on Java 8, with fonts illegibly small.

comment:9 by GerdP, 5 years ago

Create a script that sets java_home and the path and start josm from that script.

comment:10 by gpermant, 5 years ago

I just tried to set java_home via environment variables, to C:\Program Files\Java\jdk-11.0.1\bin
But that does not work [immediately], JOSM still has small fonts.

comment:11 by GerdP, 5 years ago

Did you also set path?
Your script might look similar to this:

SETLOCAL
set java_home=%ProgramFiles%\Java\jre-11.0.1
set path=%java_home%\bin;%PATH%
start java.exe -Xmx2G -jar josm-latest.jar %1 %2 %3 %4 %5 %6 %7 %8 %9
Last edited 5 years ago by GerdP (previous) (diff)

comment:12 by gpermant, 5 years ago

I tried with a script josmstart.bat filled with

SETLOCAL
set java_home=C:\Program Files\Java\jdk-11.0.1
set path=%java_home%\bin;%PATH%
start java.exe -Xmx2G -jar josm-latest.jar %1 %2 %3 %4 %5 %6 %7 %8 %9

But when starting it from the command line,
I just get a short flashing window, then it returns to the command line.

Isn't there an easier way to choose the necessary java version for JOSM?

comment:13 by GerdP, 5 years ago

Well, this is a bit off topic.
1) make sure that the paths are correct, maybe add the full path to josm-latest.jar
2) for debugging remove the start and add pause as last line

comment:14 by michael2402, 5 years ago

Keywords: gsoc-candidate added

comment:15 by johsin18, 4 years ago

IMHO we should close this bug unless it's confirmed that it can be reproduced with Java>=9.

Last edited 4 years ago by johsin18 (previous) (diff)

comment:16 by stoecker, 4 years ago

Resolution: fixed
Status: needinfoclosed

There were many HIDPI changes over the time. Open new report in case of remaining issues with recent Java version.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain gpermant@….
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.