Modify

Opened 3 weeks ago

Closed 3 weeks ago

#17017 closed defect (fixed)

Unable to load indoorhelper plugin

Reported by: mrohret@… Owned by: rebsc
Priority: normal Milestone:
Component: Plugin ​indoorhelper Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-10-28 22:27:31 +0100 (Sun, 28 Oct 2018)
Build-Date:2018-10-28 21:33:32
Revision:14382
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14382 en) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 1803 (17134)
Memory Usage: 247 MB / 989 MB (85 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080, \Display1 1920x1080, \Display2 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ buildings_tools (34724)
+ importvec (34520)
+ indoorhelper

Last errors/warnings:
- E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin indoorhelper. Cause: java.lang.reflect.InvocationTargetException. Cause: java.io.IOException: Cannot get resource "/data/indoorhelper.validator.mapcss" from Jar file.
- W: Disable plugin - Could not load plugin 'indoorhelper'. Delete from preferences?
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (15) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.indoorhelper.IndoorHelperPlugin.paintableInvalidated(IndoorHelperPlugin.java:163)
	at org.openstreetmap.josm.gui.layer.AbstractMapViewPaintable.invalidate(AbstractMapViewPaintable.java:89)
	at org.openstreetmap.josm.gui.layer.OsmDataLayer.highlightUpdated(OsmDataLayer.java:1194)
	at org.openstreetmap.josm.data.osm.DataSet.lambda$fireHighlightingChanged$7(DataSet.java:988)
	at org.openstreetmap.josm.tools.ListenerList.fireEvent(ListenerList.java:150)
	at org.openstreetmap.josm.data.osm.DataSet.fireHighlightingChanged(DataSet.java:988)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.setHighlighted(OsmPrimitive.java:598)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.lambda$repaintIfRequired$1(SelectAction.java:378)
	at java.util.Optional.ifPresent(Unknown Source)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.repaintIfRequired(SelectAction.java:378)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.giveUserFeedback(SelectAction.java:295)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.giveUserFeedback(SelectAction.java:251)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.mouseMoved(SelectAction.java:471)
	at java.awt.AWTEventMulticaster.mouseMoved(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseMoved(Unknown Source)
	at java.awt.Component.processMouseMotionEvent(Unknown Source)
	at javax.swing.JComponent.processMouseMotionEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 3 weeks ago by Don-vip

Component: CorePlugin ​indoorhelper
Owner: changed from team to rebsc

comment:2 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

I've made some changes in [o34733:34735] but the root cause is that your .jar file is corrupted. Please delete the file %APPDATA%\JOSM\plugins\indoorhelper.jar and reinstall the plugin to solve the issue.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain rebsc.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.