Modify

Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#16976 closed defect (fixed)

[Patch] Meaningless debug message {0} cannot be converted to float

Reported by: GerdP Owned by: team
Priority: minor Milestone: 18.11
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Start JOSM with --debug
  2. Create node with addr:housenumber=1a
  3. Run Validator

What is the expected result?

no idea

What happens instead?

{0} cannot be converted to float is printed

Please provide any additional information below. Attach a screenshot if possible.

Message comes from Cascade.java, which is wrong.

Instead of
Logging.debug("'{0}' cannot be converted to float", o);
it should be
Logging.debug("{0} cannot be converted to float", o);
That prints '1a' cannot be converted to float
which at least says something. I think OverpassDownloadReader.java contains a similar problem:
Logging.debug("Area '{0}' resolved to {1}", area, osmId);

Maybe there are more. Did not find a grep pattern yet.

Build-Date:2018-11-10 15:44:56
Revision:14419
Is-Local-Build:true

Identification: JOSM/1.5 (14419 SVN en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1803 (17134)
Memory Usage: 563 MB / 3641 MB (443 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-agentlib:jdwp=transport=dt_socket,suspend=y,address=localhost:54845, -ea, -Dfile.encoding=UTF-8]
Program arguments: [--debug]

Plugins:
+ OpeningHoursEditor (34535)
+ apache-commons (34506)
+ buildings_tools (34572)
+ download_along (34503)
+ ejml (34389)
+ geotools (34513)
+ jaxb (34506)
+ jts (34524)
+ measurement (34529)
+ merge-overlap (34664)
+ o5m (34405)
+ opendata (34698)
+ pbf (34576)
+ poly (34546)
+ reverter (34552)
+ undelete (34568)
+ utilsplugin2 (34506)

Last errors/warnings:
- W: Update plugins - org.openstreetmap.josm.plugins.PluginHandler$UpdatePluginsMessagePanel[,0,0,0x0,invalid,layout=java.awt.GridBagLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Failed to locate resource '/README'.
- W: Failed to locate resource '/CONTRIBUTION'.
- W: Failed to locate resource '/LICENSE'.

Attachments (2)

16976_core.patch (2.9 KB) - added by GerdP 5 months ago.
16976_plugins.patch (714 bytes) - added by GerdP 5 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 5 months ago by Don-vip

Milestone: 18.11

Changed 5 months ago by GerdP

Attachment: 16976_core.patch added

Changed 5 months ago by GerdP

Attachment: 16976_plugins.patch added

comment:2 Changed 5 months ago by GerdP

Summary: Meaningless debug message {0} cannot be converted to float[Patch] Meaningless debug message {0} cannot be converted to float

Found some more using this pattern on all java sources:

[^']'{[0-9]}'

See attached patches.

Last edited 5 months ago by GerdP (previous) (diff)

comment:3 Changed 5 months ago by Don-vip

Looks fine I think you can safely apply these patches.

comment:4 Changed 5 months ago by GerdP

Resolution: fixed
Status: newclosed

In 14439/josm:

fix #16976 meaningless debug messages caused by missing quotes
16976_core.patch

comment:5 Changed 5 months ago by GerdP

It seems I don't have access to the Mapillary svn repo.

comment:6 Changed 5 months ago by stoecker

What's your GitHub account?

comment:7 Changed 5 months ago by GerdP

It's also GerdP, but I don't use it often.
I think the problem is already gone. My patch was for an completely outaged svn version. Sorry for the noise.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.