Modify

Opened 3 weeks ago

Closed 3 weeks ago

Last modified 3 weeks ago

#16879 closed defect (fixed)

Zoom to downloaded data no longer works

Reported by: stephankn Owned by: Don-vip
Priority: normal Milestone: 18.10
Component: Core Version: latest
Keywords: zoom download regression Cc:

Description

In a quite old version 10955 JOSM did zoom to downloaded data.

In recent versions this is no longer functioning.

Reproduction (with 14358):
1) Start JOSM and open new layer
2) select "Download Location" and enter URL "https://www.openstreetmap.org/api/0.6/way/610336317/full"
3) make sure "zoom to downloaded data" is selected

It will load the data, but not zoom to it.

When selecting "download as new layer", then JOSM correctly zooms to the data

Attachments (0)

Change History (5)

comment:1 Changed 3 weeks ago by stephankn

Seems to be broken since a while. I tracked it down to the following range:
12238 works as expected
12244 fails to zoom

comment:2 Changed 3 weeks ago by stephankn

Cc: Don-vip added

By checking the changelog my best guess is that this one causes it:
https://josm.openstreetmap.de/changeset/12240/josm/

@Don-vip, please check as you changed it

I suppose the fix needs to be more specific. I don't know why bounds seems to be null in this case, as opposed to the situation in the bug report the OSM API actually returns valid data.

comment:3 Changed 3 weeks ago by Don-vip

Cc: Don-vip removed
Keywords: zoom download regression added
Milestone: 18.10
Owner: changed from team to Don-vip
Status: newassigned

comment:4 Changed 3 weeks ago by simon04

Resolution: fixed
Status: assignedclosed

In 14374/josm:

fix #16879, see #14831 - Fix zoom to downloaded data

comment:5 Changed 3 weeks ago by Don-vip

Thanks!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.