Modify

Opened 10 months ago

Closed 5 weeks ago

#16876 closed defect (fixed)

NoSuchElementException in MergeOverlapAction

Reported by: mpasha Owned by: team
Priority: normal Milestone:
Component: Plugin merge-overlap Version: latest
Keywords: template_report Cc:

Description

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-10-22 00:07:37 +0200 (Mon, 22 Oct 2018)
Revision:14353
Build-Date:2018-10-22 01:38:41
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (14353 ru) Windows 8.1 64-Bit
OS Build number: Windows 8.1 Pro (9600)
Memory Usage: 360 MB / 1024 MB (127 MB allocated, but free)
Java version: 11.0.1+13-LTS, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768
VM arguments: [-Djosm.home=<josm.pref>]
Program arguments: [%UserProfile%\Desktop\JOSM_Portable\Session\default1.jos]
Dataset consistency test: No problems found

Plugins:
+ BuildingGeneralization (23)
+ DirectDownload (34593)
+ DirectUpload (34502)
+ FastDraw (34510)
+ HouseNumberTaggingTool (34517)
+ Mapillary (v1.5.17)
+ OpeningHoursEditor (34535)
+ apache-commons (34506)
+ apache-http (34632)
+ buildings_tools (34572)
+ continuosDownload (82)
+ contourmerge (v0.1.1)
+ ejml (34389)
+ eventbus (34636)
+ geotools (34513)
+ gson (34389)
+ imagery_offset_db (34641)
+ jna (34633)
+ jogl (1.2.2)
+ jts (34524)
+ kendzi3d-resources (0.0.2)
+ livegps (34526)
+ log4j (34527)
+ merge-overlap (34664)
+ namemanager (34532)
+ osm-obj-info (49)
+ photoadjust (34684)
+ reltoolbox (34614)
+ surveyor (34591)
+ tag2link (34559)
+ tageditor (34560)
+ utilsplugin2 (34506)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-stops&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/UA.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Manholes&zip=1

Map paint styles:
- https://github.com/GlassOceanos/indoor-JOSM-style/archive/master.zip
- D:\GitHub\-= JOSM =-\Map Styles\Test\potlatch2.mapcss
+ https://pasharm.github.io/New_basic_style_for_JOSM/New_basic_style.mapcss
- D:\GitHub\New_basic_style_for_JOSM\New_basic_style2.mapcss
- D:\GitHub\-= JOSM =-\Map Styles\Test\elemstyles standart JOSM.mapcss
- D:\GitHub\New_basic_style_for_JOSM\New_basic_style.mapcss
- D:\GitHub\Ones test style JOSM\Ones test.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1

Validator rules:
- D:\Programs\JOSM_Portable\config\validator\indoorhelper.validator.mapcss

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- E: Handled by bug report queue: java.util.NoSuchElementException
- W: Внимание - <html>JOSM не может найти информацию о следующих модулях:<ul><li>livegps</li><li>apache-commons</li><li>reltoolbox</li><li>HouseNumberTaggingTool</li><li>geotools</li><li>tageditor</li><li>continuosDownload</li><li>utilsplugin2</li><li>namemanager</li><li>jogl</li><li>jna</li><li>contourmerge</li><li>log4j</li><li>BuildingGeneralization</li><li>imagery_offset_db</li><li>photoadjust</li><li>jts</li><li>kendzi3d-resources</li><li>Mapillary</li><li>tag2link</li><li>DirectDownload</li><li>osm-obj-info</li><li>surveyor</li><li>DirectUpload</li><li>ejml</li><li>FastDraw</li><li>eventbus</li><li>OpeningHoursEditor</li><li>buildings_tools</li><li>gson</li><li>apache-http</li><li>merge-overlap</li></ul>Модули не загружаются с сервера.</html>
- W: Отсутствует основной номер версии в модуле RXTXcomm


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.util.NoSuchElementException
	at java.base/java.util.LinkedList$ListItr.next(LinkedList.java:894)
	at org.openstreetmap.josm.command.SequenceCommand.<init>(SequenceCommand.java:56)
	at org.openstreetmap.josm.command.SequenceCommand.<init>(SequenceCommand.java:65)
	at mergeoverlap.MergeOverlapAction.actionPerformed(MergeOverlapAction.java:231)
	at java.desktop/javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1967)
	at java.desktop/javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2308)
	at java.desktop/javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:405)
	at java.desktop/javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:262)
	at java.desktop/javax.swing.AbstractButton.doClick(AbstractButton.java:369)
	at java.desktop/javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1020)
	at java.desktop/javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1064)
	at java.desktop/java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:297)
	at java.desktop/java.awt.Component.processMouseEvent(Component.java:6632)
	at java.desktop/javax.swing.JComponent.processMouseEvent(JComponent.java:3342)
	at java.desktop/java.awt.Component.processEvent(Component.java:6397)
	at java.desktop/java.awt.Container.processEvent(Container.java:2263)
	at java.desktop/java.awt.Component.dispatchEventImpl(Component.java:5008)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2321)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4840)
	at java.desktop/java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4918)
	at java.desktop/java.awt.LightweightDispatcher.processMouseEvent(Container.java:4547)
	at java.desktop/java.awt.LightweightDispatcher.dispatchEvent(Container.java:4488)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2307)
	at java.desktop/java.awt.Window.dispatchEventImpl(Window.java:2772)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4840)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:772)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:95)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:745)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:743)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:742)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

Attachments (0)

Change History (3)

comment:1 Changed 10 months ago by floscher

Component: CorePlugin merge-overlap
Summary: ErrorNoSuchElementException in MergeOverlapAction

comment:2 Changed 5 weeks ago by Don-vip

Ticket #17951 has been marked as a duplicate of this ticket.

comment:3 Changed 5 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o35072:35073].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.